summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-23 15:43:51 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-23 15:43:51 +0000
commit55cc591b6d1a3eee9666a5d64c2da49f715d2a8c (patch)
tree4a376325d2fa7483f114f04704c5b5ac4f8792e4 /app-text
parentmasked new pspell build (diff)
downloadgentoo-2-55cc591b6d1a3eee9666a5d64c2da49f715d2a8c.tar.gz
gentoo-2-55cc591b6d1a3eee9666a5d64c2da49f715d2a8c.tar.bz2
gentoo-2-55cc591b6d1a3eee9666a5d64c2da49f715d2a8c.zip
added aspell as a dep
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pspell/ChangeLog10
-rw-r--r--app-text/pspell/files/digest-pspell-0.12.2-r41
-rw-r--r--app-text/pspell/pspell-0.12.2-r3.ebuild7
-rw-r--r--app-text/pspell/pspell-0.12.2-r4.ebuild46
4 files changed, 59 insertions, 5 deletions
diff --git a/app-text/pspell/ChangeLog b/app-text/pspell/ChangeLog
index 14ac6b893749..d5159808bbeb 100644
--- a/app-text/pspell/ChangeLog
+++ b/app-text/pspell/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/pspell
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/pspell/ChangeLog,v 1.5 2002/08/06 14:51:24 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pspell/ChangeLog,v 1.6 2002/08/23 15:43:51 seemant Exp $
+
+*pspell-0.12.2-r4 (23 Aug 2002)
+
+ 23 Aug 2002; Seemant Kulleen <seemant@gentoo.org> pspell-0.12.2-r4.ebuild
+ files/digest-pspell-0.12.2-r4 :
+
+ Added dependency upon new aspell. Now, this installs just the old stuff
+ and into a separate set of places, so as not to clobber.
*pspell-0.12.2-r3 (19 Jun 2002)
diff --git a/app-text/pspell/files/digest-pspell-0.12.2-r4 b/app-text/pspell/files/digest-pspell-0.12.2-r4
new file mode 100644
index 000000000000..e75fdd207d2a
--- /dev/null
+++ b/app-text/pspell/files/digest-pspell-0.12.2-r4
@@ -0,0 +1 @@
+MD5 cfd3816b2372932a1b71c0ce4e9f881e pspell-.12.2.tar.gz 434193
diff --git a/app-text/pspell/pspell-0.12.2-r3.ebuild b/app-text/pspell/pspell-0.12.2-r3.ebuild
index 532738a0a353..f7cbcbcdfa06 100644
--- a/app-text/pspell/pspell-0.12.2-r3.ebuild
+++ b/app-text/pspell/pspell-0.12.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-text/pspell/pspell-0.12.2-r3.ebuild,v 1.5 2002/08/16 02:42:01 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pspell/pspell-0.12.2-r3.ebuild,v 1.6 2002/08/23 15:43:51 seemant Exp $
inherit libtool
@@ -11,11 +11,10 @@ DESCRIPTION="A spell checker frontend for aspell and ispell"
SRC_URI="http://telia.dl.sf.net/${PN}/${PN}-${MYPV}.tar.gz" #2481
HOMEPAGE="http://pspell.sourceforge.net"
-DEPEND="virtual/glibc
- >=sys-devel/libtool-1.4.1-r4"
+DEPEND=">=sys-devel/libtool-1.4.1-r4"
SLOT="0"
-LICENSE="GPL"
+LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc sparc64"
src_compile() {
diff --git a/app-text/pspell/pspell-0.12.2-r4.ebuild b/app-text/pspell/pspell-0.12.2-r4.ebuild
new file mode 100644
index 000000000000..668e6dd332e2
--- /dev/null
+++ b/app-text/pspell/pspell-0.12.2-r4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-text/pspell/pspell-0.12.2-r4.ebuild,v 1.1 2002/08/23 15:43:51 seemant Exp $
+
+inherit libtool
+
+#Remove leading zero from version number
+MYPV=${PV#0}
+S=${WORKDIR}/${PN}-${MYPV}
+DESCRIPTION="A spell checker frontend for aspell and ispell"
+SRC_URI="http://telia.dl.sf.net/${PN}/${PN}-${MYPV}.tar.gz" #2481
+HOMEPAGE="http://pspell.sourceforge.net"
+
+DEPEND=">=app-text/aspell-0.50"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+src_compile() {
+
+ elibtoolize
+ econf \
+ --libdir=/usr/lib/pspell \
+ --enable-doc-dir=/usr/share/doc/${PF} \
+ --enable-ltdl \
+ || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+src_install () {
+
+ make \
+ DESTDIR=${D} \
+ install || die "Installation Failed"
+
+ #remove things which are installed by aspell
+ rm -f ${D}/usr/bin/pspell-config
+ rm -f ${D}/usr/include/pspell/pspell.h
+ dodoc README*
+
+ cd ${D}/usr/share/doc/${PF}
+ mv man-html html
+ mv man-text txt
+}