summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-05 20:22:01 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-05 20:22:01 +0000
commit59f640232ddfc25977429730c0c9e067477ab936 (patch)
tree10cc07c1a7a98177350e33d47a38b15b2dbab8d8 /app-text
parentVersion bump (diff)
downloadgentoo-2-59f640232ddfc25977429730c0c9e067477ab936.tar.gz
gentoo-2-59f640232ddfc25977429730c0c9e067477ab936.tar.bz2
gentoo-2-59f640232ddfc25977429730c0c9e067477ab936.zip
Version bump, bug 366145
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gv/ChangeLog7
-rw-r--r--app-text/gv/gv-3.7.2.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/app-text/gv/ChangeLog b/app-text/gv/ChangeLog
index adea69853edf..603a2cee8a90 100644
--- a/app-text/gv/ChangeLog
+++ b/app-text/gv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/gv
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gv/ChangeLog,v 1.86 2011/05/14 09:38:32 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gv/ChangeLog,v 1.87 2011/06/05 20:22:01 dilfridge Exp $
+
+*gv-3.7.2 (05 Jun 2011)
+
+ 05 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org> +gv-3.7.2.ebuild:
+ Version bump, bug 366145
*gv-3.7.1-r1 (14 May 2011)
diff --git a/app-text/gv/gv-3.7.2.ebuild b/app-text/gv/gv-3.7.2.ebuild
new file mode 100644
index 000000000000..5fa83bc3550a
--- /dev/null
+++ b/app-text/gv/gv-3.7.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gv/gv-3.7.2.ebuild,v 1.1 2011/06/05 20:22:01 dilfridge Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="Viewer for PostScript and PDF documents using Ghostscript"
+HOMEPAGE="http://www.gnu.org/software/gv/"
+SRC_URI="mirror://gnu/gv/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xinerama"
+
+DEPEND="x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXext
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/Xaw3d
+ app-text/ghostscript-gpl
+ xinerama? ( x11-libs/libXinerama )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/gv-3.6.1-a0.patch
+
+ if ! use xinerama; then
+ sed -i -e 's:Xinerama:dIsAbLe&:' configure.ac || die
+ fi
+
+ sed -i \
+ -e "s:-dGraphicsAlphaBits=2:\0 -dAlignToPixels=0:" \
+ src/Makefile.am || die #135354
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-scrollbar-code
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ doicon "${FILESDIR}"/gv_icon.xpm
+ make_desktop_entry gv GhostView gv_icon "Graphics;Viewer"
+}