summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-23 07:16:41 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-23 07:16:41 +0000
commit8cf5ca4056c08567cc35cc120f173b0e4a2f0bfa (patch)
tree4436b3f782ec075b3704a17611a910a2d10e08e7 /app-text
parentMore cleanup (diff)
downloadgentoo-2-8cf5ca4056c08567cc35cc120f173b0e4a2f0bfa.tar.gz
gentoo-2-8cf5ca4056c08567cc35cc120f173b0e4a2f0bfa.tar.bz2
gentoo-2-8cf5ca4056c08567cc35cc120f173b0e4a2f0bfa.zip
Fix implicit prototype warnings as well as some printf warnings.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/a2ps/ChangeLog6
-rw-r--r--app-text/a2ps/a2ps-4.14-r1.ebuild4
-rw-r--r--app-text/a2ps/files/a2ps-4.14-cleanup.patch106
3 files changed, 114 insertions, 2 deletions
diff --git a/app-text/a2ps/ChangeLog b/app-text/a2ps/ChangeLog
index c091f79a2d4b..4fcbf7f298e3 100644
--- a/app-text/a2ps/ChangeLog
+++ b/app-text/a2ps/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/a2ps
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/ChangeLog,v 1.93 2010/07/03 23:03:56 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/ChangeLog,v 1.94 2010/08/23 07:16:41 vapier Exp $
+
+ 23 Aug 2010; Mike Frysinger <vapier@gentoo.org> a2ps-4.14-r1.ebuild,
+ +files/a2ps-4.14-cleanup.patch:
+ Fix implicit prototype warnings as well as some printf warnings.
03 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> a2ps-4.14-r1.ebuild:
ppc64 stable wrt #322867
diff --git a/app-text/a2ps/a2ps-4.14-r1.ebuild b/app-text/a2ps/a2ps-4.14-r1.ebuild
index 841e1fd8e979..8b4146225ab2 100644
--- a/app-text/a2ps/a2ps-4.14-r1.ebuild
+++ b/app-text/a2ps/a2ps-4.14-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/a2ps-4.14-r1.ebuild,v 1.7 2010/07/03 23:03:56 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/a2ps-4.14-r1.ebuild,v 1.8 2010/08/23 07:16:41 vapier Exp $
inherit eutils autotools elisp-common
@@ -67,6 +67,8 @@ src_unpack() {
# fix compilation error due to obstack.h issue, bug 269638
epatch "${FILESDIR}/${P}-ptrdiff_t.patch"
+ epatch "${FILESDIR}"/${P}-cleanup.patch
+
eautoreconf
}
diff --git a/app-text/a2ps/files/a2ps-4.14-cleanup.patch b/app-text/a2ps/files/a2ps-4.14-cleanup.patch
new file mode 100644
index 000000000000..25187f315384
--- /dev/null
+++ b/app-text/a2ps/files/a2ps-4.14-cleanup.patch
@@ -0,0 +1,106 @@
+fix missing prototype and printf warnings
+
+--- a/lib/argmatch.c
++++ b/lib/argmatch.c
+@@ -21,6 +21,7 @@
+ #include "argmatch.h"
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #ifdef STDC_HEADERS
+ # include <string.h>
+ #endif
+--- a/lib/encoding.c
++++ b/lib/encoding.c
+@@ -790,7 +790,7 @@ dump_encoding_setup (FILE * stream,
+ /* Create the dictionary and fill it */
+ fprintf (stream, "%% Dictionary for %s support\n",
+ encoding->name);
+- fprintf (stream, "/%sdict %d dict begin\n", encoding->key, nb);
++ fprintf (stream, "/%sdict %zu dict begin\n", encoding->key, nb);
+ for (i = 0 ; i < nb ; i++)
+ fprintf (stream, " /f%s %sEncoding /%s reencode_font\n",
+ font_names [i],
+--- a/lib/output.c
++++ b/lib/output.c
+@@ -84,7 +84,7 @@ new_derivation (enum derivation_type type)
+ static void
+ derivation_self_print (struct derivation * derivation, FILE * stream)
+ {
+- fprintf (stream, "At %x: ", (int) derivation);
++ fprintf (stream, "At %p: ", derivation);
+ switch (derivation->type)
+ {
+ case nothing:
+@@ -525,7 +525,7 @@ output_file (struct output * out, a2ps_job * job,
+ expand_user_string (job, FIRST_FILE (job),
+ (const uchar *) "Expand: requirement",
+ (const uchar *) token));
+- output (dest, expansion);
++ output (dest, "%s", expansion);
+ continue;
+ }
+
+--- a/lib/parseppd.y
++++ b/lib/parseppd.y
+@@ -154,7 +154,7 @@ font_clause :
+ void
+ yyerror (const char *msg)
+ {
+- error_at_line (1, 0, ppdfilename, ppdlineno, msg);
++ error_at_line (1, 0, ppdfilename, ppdlineno, "%s", msg);
+ }
+
+ /*
+--- a/lib/psgen.c
++++ b/lib/psgen.c
+@@ -232,7 +232,7 @@ output_marker (a2ps_job * job, const char * kind, uchar * marker)
+ default:
+ *buf = '\0';
+ ps_escape_char (job, cp[i], buf);
+- output (jdiv, (char *) buf);
++ output (jdiv, "%s", buf);
+ break;
+ }
+ }
+--- a/lib/quotearg.c
++++ b/lib/quotearg.c
+@@ -60,6 +60,7 @@
+
+ #if HAVE_MBRTOWC && HAVE_WCHAR_H
+ # include <wchar.h>
++# include <wctype.h>
+ #else
+ # define iswprint(wc) 1
+ # define mbrtowc(pwc, s, n, ps) 1
+--- a/lib/title.c
++++ b/lib/title.c
+@@ -28,6 +28,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <string.h>
+
+ #if HAVE_VPRINTF || HAVE_DOPRNT || _LIBC
+ # if __STDC__
+--- a/src/long-options.c
++++ b/src/long-options.c
+@@ -22,6 +22,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <getopt.h>
+ #include "closeout.h"
+ #include "long-options.h"
+--- a/src/parsessh.y
++++ b/src/parsessh.y
+@@ -740,7 +740,7 @@ exception_def_opt:
+ void
+ yyerror (const char *msg)
+ {
+- error_at_line (1, 0, sshfilename, sshlineno, msg);
++ error_at_line (1, 0, sshfilename, sshlineno, "%s", msg);
+ }
+
+ /*