summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-17 04:08:48 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-17 04:08:48 +0000
commit9f51c910828692957f8759038be0d4a22680b6bd (patch)
tree0ff181360009813d6d198521a4d8cd1e961f814a /app-text
parentSet RDEPEND. Respect LDFLAGS (bug #337738), CC, CFLAGS. Fix parallel make. (diff)
downloadgentoo-2-9f51c910828692957f8759038be0d4a22680b6bd.tar.gz
gentoo-2-9f51c910828692957f8759038be0d4a22680b6bd.tar.bz2
gentoo-2-9f51c910828692957f8759038be0d4a22680b6bd.zip
Remove unused DEPEND. Respect LDFLAGS (bug #335091), CXX. Fix quoting issue.
(Portage version: 2.2_rc82/cvs/Linux i686)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/htmlinc/ChangeLog9
-rw-r--r--app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild (renamed from app-text/htmlinc/htmlinc-1.0_beta1-r1.ebuild)21
2 files changed, 22 insertions, 8 deletions
diff --git a/app-text/htmlinc/ChangeLog b/app-text/htmlinc/ChangeLog
index 054fdaabf521..bcff3dbbff74 100644
--- a/app-text/htmlinc/ChangeLog
+++ b/app-text/htmlinc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/htmlinc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmlinc/ChangeLog,v 1.18 2010/01/02 11:24:30 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmlinc/ChangeLog,v 1.19 2010/09/17 04:08:48 jer Exp $
+
+*htmlinc-1.0_beta1-r2 (17 Sep 2010)
+
+ 17 Sep 2010; Jeroen Roovers <jer@gentoo.org> -htmlinc-1.0_beta1-r1.ebuild,
+ +htmlinc-1.0_beta1-r2.ebuild:
+ Remove unused DEPEND. Respect LDFLAGS (bug #335091), CXX. Fix quoting
+ issue.
02 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
htmlinc-1.0_beta1-r1.ebuild:
diff --git a/app-text/htmlinc/htmlinc-1.0_beta1-r1.ebuild b/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
index a7f5ba221ba8..a50b294a8978 100644
--- a/app-text/htmlinc/htmlinc-1.0_beta1-r1.ebuild
+++ b/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmlinc/htmlinc-1.0_beta1-r1.ebuild,v 1.5 2010/01/02 11:24:30 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild,v 1.1 2010/09/17 04:08:48 jer Exp $
-inherit eutils
+EAPI="2"
+
+inherit eutils toolchain-funcs
DESCRIPTION="HTML Include System by Ulli Meybohm"
HOMEPAGE="http://www.meybohm.de/"
@@ -13,16 +15,21 @@ SLOT="0"
KEYWORDS="~ppc ~sparc ~x86 ~x86-linux ~ppc-macos ~x86-macos"
IUSE=""
-DEPEND=""
S=${WORKDIR}/htmlinc
-src_unpack() {
- unpack ${A}
- epatch ${FILESDIR}/htmlinc-gcc3-gentoo.patch
+src_prepare() {
+ epatch "${FILESDIR}"/htmlinc-gcc3-gentoo.patch
+ sed -i Makefile \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile"
}
src_compile() {
- emake CFLAGS="${CXXFLAGS} -Wall" || die
+ # This is C++ not C source
+ emake CC=$(tc-getCXX) \
+ CFLAGS="${CXXFLAGS} -Wall" \
+ LDFLAGS="${LDFLAGS}" \
+ || die
}
src_install() {