summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-12-26 14:40:45 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-12-26 14:40:45 +0000
commitb578de32a8c1a8dd22560784c26e74d1f4cbd8a3 (patch)
tree9375fc70fe594c7f750ceee634285d2252487d4a /app-text
parentarm stable, bug #494792 (diff)
downloadgentoo-2-b578de32a8c1a8dd22560784c26e74d1f4cbd8a3.tar.gz
gentoo-2-b578de32a8c1a8dd22560784c26e74d1f4cbd8a3.tar.bz2
gentoo-2-b578de32a8c1a8dd22560784c26e74d1f4cbd8a3.zip
respect PKG_CONFIG wrt #478514, add ~x86
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/blahtexml/ChangeLog6
-rw-r--r--app-text/blahtexml/blahtexml-0.9.ebuild4
-rw-r--r--app-text/blahtexml/files/blahtexml-0.9-Makefile.patch12
3 files changed, 14 insertions, 8 deletions
diff --git a/app-text/blahtexml/ChangeLog b/app-text/blahtexml/ChangeLog
index 519f7c6244db..e8d56b18bf90 100644
--- a/app-text/blahtexml/ChangeLog
+++ b/app-text/blahtexml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/blahtexml
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/blahtexml/ChangeLog,v 1.1 2013/07/10 11:45:01 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/blahtexml/ChangeLog,v 1.2 2013/12/26 14:40:45 hasufell Exp $
+
+ 26 Dec 2013; Julian Ospald <hasufell@gentoo.org> blahtexml-0.9.ebuild,
+ files/blahtexml-0.9-Makefile.patch:
+ respect PKG_CONFIG wrt #478514, add ~x86
*blahtexml-0.9 (10 Jul 2013)
diff --git a/app-text/blahtexml/blahtexml-0.9.ebuild b/app-text/blahtexml/blahtexml-0.9.ebuild
index 6d0c42a63f88..f10a3ef531b1 100644
--- a/app-text/blahtexml/blahtexml-0.9.ebuild
+++ b/app-text/blahtexml/blahtexml-0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/blahtexml/blahtexml-0.9.ebuild,v 1.1 2013/07/10 11:45:01 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/blahtexml/blahtexml-0.9.ebuild,v 1.2 2013/12/26 14:40:45 hasufell Exp $
EAPI=5
@@ -12,7 +12,7 @@ SRC_URI="http://gva.noekeon.org/${PN}/${P}-src.tar.gz"
LICENSE="BSD CC-BY-3.0 ZLIB"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE="doc"
RDEPEND="dev-libs/xerces-c"
diff --git a/app-text/blahtexml/files/blahtexml-0.9-Makefile.patch b/app-text/blahtexml/files/blahtexml-0.9-Makefile.patch
index 1402c9c80109..f5f01eac71aa 100644
--- a/app-text/blahtexml/files/blahtexml-0.9-Makefile.patch
+++ b/app-text/blahtexml/files/blahtexml-0.9-Makefile.patch
@@ -2,22 +2,24 @@ Use pkg-config for xerces-c
Respect CXX and CC
Replace CFLAGS with CXXFLAGS where needed
Add LDFLAGS
---- makefile.old 2010-04-07 18:45:30.000000000 +0200
-+++ makefile 2012-08-15 23:48:03.218394478 +0200
-@@ -93,35 +93,39 @@
+
+--- a/makefile
++++ b/makefile
+@@ -93,35 +93,40 @@
$(BINDIR_XMLIN)/InputSymbolTranslation.o: InputSymbolTranslation.cpp InputSymbolTranslation.inc
-CFLAGS = -O2
++PKG_CONFIG ?= pkg-config
+CFLAGS ?= -O2
VPATH = Source:Source/BlahtexCore:Source/BlahtexXMLin
INCLUDES=-I. -ISource -ISource/BlahtexCore -ISource/BlahtexXMLin
-+CXXFLAGS += $(shell pkg-config --cflags xerces-c)
++CXXFLAGS += $(shell $(PKG_CONFIG) --cflags xerces-c)
+
-+XERCES_LIB = $(shell pkg-config --libs xerces-c)
++XERCES_LIB = $(shell $(PKG_CONFIG) --libs xerces-c)
+
$(BINDIR)/%.o:%.cpp
- $(CXX) $(INCLUDES) $(CFLAGS) -c $< -o $@