summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-12-27 15:12:21 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-12-27 15:12:21 +0000
commitcd471c2ea2c15b00de0ff57da82230979d590cd4 (patch)
treedcaa1fed60350c5814857e1a1cf1fd6888ba3263 /app-text
parentVersion bump (diff)
downloadgentoo-2-cd471c2ea2c15b00de0ff57da82230979d590cd4.tar.gz
gentoo-2-cd471c2ea2c15b00de0ff57da82230979d590cd4.tar.bz2
gentoo-2-cd471c2ea2c15b00de0ff57da82230979d590cd4.zip
Version bump by Andreas Sturmlechner, bug 533478
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libabw/ChangeLog9
-rw-r--r--app-text/libabw/files/libabw-0.1.1-dereference-before-null-check.patch27
-rw-r--r--app-text/libabw/files/libabw-0.1.1-do-not-let-AbiDocument_parse-throw.patch35
-rw-r--r--app-text/libabw/libabw-0.1.1.ebuild47
4 files changed, 117 insertions, 1 deletions
diff --git a/app-text/libabw/ChangeLog b/app-text/libabw/ChangeLog
index 7cda53afdb8f..69a4abe08b4b 100644
--- a/app-text/libabw/ChangeLog
+++ b/app-text/libabw/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/libabw
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libabw/ChangeLog,v 1.6 2014/10/10 20:15:47 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libabw/ChangeLog,v 1.7 2014/12/27 15:12:21 dilfridge Exp $
+
+*libabw-0.1.1 (27 Dec 2014)
+
+ 27 Dec 2014; Andreas K. Huettel <dilfridge@gentoo.org> +libabw-0.1.1.ebuild,
+ +files/libabw-0.1.1-dereference-before-null-check.patch,
+ +files/libabw-0.1.1-do-not-let-AbiDocument_parse-throw.patch:
+ Version bump by Andreas Sturmlechner, bug 533478
10 Oct 2014; Markus Meier <maekke@gentoo.org> libabw-0.1.0.ebuild:
add ~arm, bug #520692
diff --git a/app-text/libabw/files/libabw-0.1.1-dereference-before-null-check.patch b/app-text/libabw/files/libabw-0.1.1-dereference-before-null-check.patch
new file mode 100644
index 000000000000..1df274afbe8f
--- /dev/null
+++ b/app-text/libabw/files/libabw-0.1.1-dereference-before-null-check.patch
@@ -0,0 +1,27 @@
+From: David Tardon <dtardon@redhat.com>
+Date: Sat, 20 Dec 2014 17:35:36 +0000 (+0100)
+Subject: coverity#1259904 dereference before null check
+X-Git-Url: https://gerrit.libreoffice.org/gitweb?p=libabw.git;a=commitdiff_plain;h=a65eb81c5e9d9da0548eb9066f9dde77a7328cc3
+
+coverity#1259904 dereference before null check
+
+Change-Id: If53074b31a821b0764acc9e9f1b0f9d7894e2e5e
+---
+
+diff --git a/src/lib/ABWParser.cpp b/src/lib/ABWParser.cpp
+index cf914bf..426ab54 100644
+--- a/src/lib/ABWParser.cpp
++++ b/src/lib/ABWParser.cpp
+@@ -338,9 +338,11 @@ void libabw::ABWParser::readAbiword(xmlTextReaderPtr reader)
+ void libabw::ABWParser::readM(xmlTextReaderPtr reader)
+ {
+ xmlChar *const key = xmlTextReaderGetAttribute(reader, BAD_CAST("key"));
+- m_state->m_currentMetadataKey = reinterpret_cast<const char *>(key);
+ if (key)
++ {
++ m_state->m_currentMetadataKey = reinterpret_cast<const char *>(key);
+ xmlFree(key);
++ }
+ }
+
+ void libabw::ABWParser::readHistory(xmlTextReaderPtr reader)
diff --git a/app-text/libabw/files/libabw-0.1.1-do-not-let-AbiDocument_parse-throw.patch b/app-text/libabw/files/libabw-0.1.1-do-not-let-AbiDocument_parse-throw.patch
new file mode 100644
index 000000000000..4854072bc8a0
--- /dev/null
+++ b/app-text/libabw/files/libabw-0.1.1-do-not-let-AbiDocument_parse-throw.patch
@@ -0,0 +1,35 @@
+From: David Tardon <dtardon@redhat.com>
+Date: Sat, 20 Dec 2014 17:40:45 +0000 (+0100)
+Subject: coverity#1259905 do not let AbiDocument::parse throw
+X-Git-Url: https://gerrit.libreoffice.org/gitweb?p=libabw.git;a=commitdiff_plain;h=2f372e8adf8e6b1f8cf70f08adddcf66be54d94a
+
+coverity#1259905 do not let AbiDocument::parse throw
+
+This also fixes coverity#1259906 and coverity#1259907 .
+
+Change-Id: I55d892517ac93ca43478d51d8e4a20c704ff6790
+---
+
+diff --git a/src/lib/AbiDocument.cpp b/src/lib/AbiDocument.cpp
+index b8ab661..23ff750 100644
+--- a/src/lib/AbiDocument.cpp
++++ b/src/lib/AbiDocument.cpp
+@@ -110,7 +110,7 @@ is not protected
+ \return A value that indicates whether the conversion was successful and in case it
+ was not, it indicates the reason of the error
+ */
+-ABWAPI bool libabw::AbiDocument::parse(librevenge::RVNGInputStream *input, librevenge::RVNGTextInterface *textInterface)
++ABWAPI bool libabw::AbiDocument::parse(librevenge::RVNGInputStream *input, librevenge::RVNGTextInterface *textInterface) try
+ {
+ ABW_DEBUG_MSG(("AbiDocument::parse\n"));
+ if (!input)
+@@ -122,4 +122,9 @@ ABWAPI bool libabw::AbiDocument::parse(librevenge::RVNGInputStream *input, libre
+ return true;
+ return false;
+ }
++catch (...)
++{
++ return false;
++}
++
+ /* vim:set shiftwidth=2 softtabstop=2 expandtab: */
diff --git a/app-text/libabw/libabw-0.1.1.ebuild b/app-text/libabw/libabw-0.1.1.ebuild
new file mode 100644
index 000000000000..916f0ddcf042
--- /dev/null
+++ b/app-text/libabw/libabw-0.1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libabw/libabw-0.1.1.ebuild,v 1.1 2014/12/27 15:12:21 dilfridge Exp $
+
+EAPI=5
+
+inherit base eutils
+
+DESCRIPTION="Library parsing abiword documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/${PN}"
+SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+PATCHES=(
+ # from git master
+ "${FILESDIR}/${PN}-0.1.1-dereference-before-null-check.patch"
+ "${FILESDIR}/${PN}-0.1.1-do-not-let-AbiDocument_parse-throw.patch"
+)
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --disable-werror \
+ $(use_enable static-libs static) \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}