summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-08-20 03:45:26 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-08-20 03:45:26 +0000
commitd0fb02684ceb2c2e28356eb4c73cf5d5e3f62d31 (patch)
treef1eb342dcd31fc9f9439338df86c1c9e25f14e1e /app-text
parentremove unused patches (diff)
downloadgentoo-2-d0fb02684ceb2c2e28356eb4c73cf5d5e3f62d31.tar.gz
gentoo-2-d0fb02684ceb2c2e28356eb4c73cf5d5e3f62d31.tar.bz2
gentoo-2-d0fb02684ceb2c2e28356eb4c73cf5d5e3f62d31.zip
remove unused patches
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/recode/ChangeLog6
-rw-r--r--app-text/recode/files/recode-3.6-debian-11.patch63
-rw-r--r--app-text/recode/files/recode-3.6-gcc43.patch20
3 files changed, 5 insertions, 84 deletions
diff --git a/app-text/recode/ChangeLog b/app-text/recode/ChangeLog
index 8291d001fbfb..7adf8fb8f0ab 100644
--- a/app-text/recode/ChangeLog
+++ b/app-text/recode/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/recode
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/recode/ChangeLog,v 1.68 2009/08/14 14:22:00 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/recode/ChangeLog,v 1.69 2009/08/20 03:45:25 darkside Exp $
+
+ 20 Aug 2009; Jeremy Olexa <darkside@gentoo.org>
+ -files/recode-3.6-debian-11.patch, -files/recode-3.6-gcc43.patch:
+ remove unused patches
14 Aug 2009; Raúl Porcel <armin76@gentoo.org> recode-3.6_p15-r1.ebuild:
alpha/arm/ia64/s390/sh/sparc stable wrt #279935
diff --git a/app-text/recode/files/recode-3.6-debian-11.patch b/app-text/recode/files/recode-3.6-debian-11.patch
deleted file mode 100644
index d13c2206ae7b..000000000000
--- a/app-text/recode/files/recode-3.6-debian-11.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-Ripped from Debian patchset 3.6-11
-
---- recode-3.6.orig/src/libiconv.c
-+++ recode-3.6/src/libiconv.c
-@@ -195,12 +195,17 @@
- memcpy() doesn't do here, because the regions might overlap.
- memmove() isn't worth it, because we rarely have to move more
- than 12 bytes. */
-- if (input > input_buffer && input_left > 0)
-+ cursor = input_buffer;
-+ if (input_left > 0)
- {
-- cursor = input_buffer;
-- do
-- *cursor++ = *input++;
-- while (--input_left > 0);
-+ if (input > input_buffer)
-+ {
-+ do
-+ *cursor++ = *input++;
-+ while (--input_left > 0);
-+ }
-+ else
-+ cursor += input_left;
- }
- }
-
---- recode-3.6.orig/src/request.c
-+++ recode-3.6/src/request.c
-@@ -1073,7 +1073,7 @@
- if (task->output.cursor + 4 >= task->output.limit)
- {
- RECODE_OUTER outer = task->request->outer;
-- size_t old_size = task->output.limit - task->output.buffer;
-+ size_t old_size = task->output.cursor - task->output.buffer;
- size_t new_size = task->output.cursor + 4 - task->output.buffer;
-
- /* FIXME: Rethink about how the error should be reported. */
---- recode-3.6.orig/src/task.c
-+++ recode-3.6/src/task.c
-@@ -1198,6 +1198,8 @@
- else
- success = transform_mere_copy (subtask);
-
-+ task->output = subtask->output;
-+
- if (subtask->input.name && *subtask->input.name)
- fclose (subtask->input.file);
- if (subtask->output.name && *subtask->output.name)
---- recode-3.6.orig/src/hash.h
-+++ recode-3.6/src/hash.h
-@@ -21,6 +21,11 @@
- /* Make sure USE_OBSTACK is defined to 1 if you want the allocator to use
- obstacks instead of malloc, and recompile `hash.c' with same setting. */
-
-+#define hash_lookup recode_hash_lookup
-+#define hash_delete recode_hash_delete
-+#define hash_free recode_hash_free
-+#define hash_insert recode_hash_insert
-+
- #ifndef PARAMS
- # if PROTOTYPES || __STDC__
- # define PARAMS(Args) Args
diff --git a/app-text/recode/files/recode-3.6-gcc43.patch b/app-text/recode/files/recode-3.6-gcc43.patch
deleted file mode 100644
index beaf26e9a3e1..000000000000
--- a/app-text/recode/files/recode-3.6-gcc43.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-http://bugs.gentoo.org/209036
-
-fix building with gcc-4.3
-
---- src/recodext.h 2008-04-03 18:35:42 +0000
-+++ src/recodext.h 2008-04-03 18:36:32 +0000
-@@ -215,10 +215,10 @@
- struct recode_single *unsurfacer;
-
- /* Non zero if this is an acceptable charset (not only a surface). */
-- enum recode_symbol_type type : 3;
-+ enum recode_symbol_type type : 2;
-
- /* Non zero if this one should be ignored. */
-- bool ignore : 2;
-+ bool ignore : 1;
- };
-
- struct recode_surface_list
-