summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-09-05 01:46:16 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-09-05 01:46:16 +0000
commitb2dc16dba20dcbe876023280f3f41284b774f24a (patch)
treef46c02a54166d45ab4c18ae6424944efcaf6895f /app-vim/minibufexpl/minibufexpl-6.3.1-r1.ebuild
parentAdded help text, bug #62559 (Manifest recommit) (diff)
downloadgentoo-2-b2dc16dba20dcbe876023280f3f41284b774f24a.tar.gz
gentoo-2-b2dc16dba20dcbe876023280f3f41284b774f24a.tar.bz2
gentoo-2-b2dc16dba20dcbe876023280f3f41284b774f24a.zip
Generate help text from the .vim file automatically. Added help text, bug #62559
Diffstat (limited to 'app-vim/minibufexpl/minibufexpl-6.3.1-r1.ebuild')
-rw-r--r--app-vim/minibufexpl/minibufexpl-6.3.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-vim/minibufexpl/minibufexpl-6.3.1-r1.ebuild b/app-vim/minibufexpl/minibufexpl-6.3.1-r1.ebuild
new file mode 100644
index 000000000000..b7fa15c4c9ff
--- /dev/null
+++ b/app-vim/minibufexpl/minibufexpl-6.3.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/minibufexpl/minibufexpl-6.3.1-r1.ebuild,v 1.1 2004/09/05 01:46:16 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: easily switch between buffers"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=159"
+LICENSE="as-is"
+KEYWORDS="~sparc ~x86 ~alpha ~ia64 ~mips ~ppc ~amd64"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="minibufexpl.txt"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir ${S}/doc
+ sed -e '1,/"=\+$/d' -e '/"=\+$/,9999d' -e 's/^" \?//' \
+ -e 's/\(Name Of File: \)\([^.]\+\)\.vim/\1*\2.txt*/' \
+ plugin/minibufexpl.vim \
+ > doc/minibufexpl.txt
+}