summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-05-04 10:09:45 +0000
committerTim Harder <radhermit@gentoo.org>2011-05-04 10:09:45 +0000
commit17b019a7d787c4f66614c9329ad29673d1d4731f (patch)
tree413666e1e47a41784debfd7d04220a32903cf8f2 /app-vim
parentVersion bump and remove old. (diff)
downloadgentoo-2-17b019a7d787c4f66614c9329ad29673d1d4731f.tar.gz
gentoo-2-17b019a7d787c4f66614c9329ad29673d1d4731f.tar.bz2
gentoo-2-17b019a7d787c4f66614c9329ad29673d1d4731f.zip
Version bump.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/minibufexpl/ChangeLog9
-rw-r--r--app-vim/minibufexpl/minibufexpl-6.4.1_p4.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/app-vim/minibufexpl/ChangeLog b/app-vim/minibufexpl/ChangeLog
index 9e50f0bec966..8616faf0f9c1 100644
--- a/app-vim/minibufexpl/ChangeLog
+++ b/app-vim/minibufexpl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/minibufexpl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/minibufexpl/ChangeLog,v 1.24 2010/11/14 06:27:11 radhermit Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/minibufexpl/ChangeLog,v 1.25 2011/05/04 10:09:45 radhermit Exp $
+
+*minibufexpl-6.4.1_p4 (04 May 2011)
+
+ 04 May 2011; Tim Harder <radhermit@gentoo.org> +minibufexpl-6.4.1_p4.ebuild:
+ Version bump.
14 Nov 2010; Tim Harder <radhermit@gentoo.org>
-minibufexpl-6.3.1-r1.ebuild, minibufexpl-6.3.2.ebuild:
diff --git a/app-vim/minibufexpl/minibufexpl-6.4.1_p4.ebuild b/app-vim/minibufexpl/minibufexpl-6.4.1_p4.ebuild
new file mode 100644
index 000000000000..afb9de3df19e
--- /dev/null
+++ b/app-vim/minibufexpl/minibufexpl-6.4.1_p4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/minibufexpl/minibufexpl-6.4.1_p4.ebuild,v 1.1 2011/05/04 10:09:45 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: easily switch between buffers"
+HOMEPAGE="https://github.com/fholgado/minibufexpl.vim"
+SRC_URI="https://github.com/fholgado/${PN}.vim/tarball/${PV/_p/b} -> ${P}.tar.gz"
+
+LICENSE="as-is"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="minibufexpl.txt"
+
+src_unpack() {
+ unpack ${A}
+ mv fholgado-minibufexpl.vim-* "${S}"
+}
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir "${S}"/doc
+ sed -e '1,/"=\+$/d' -e '/"=\+$/,9999d' -e 's/^" \?//' \
+ -e 's/\(Name Of File: \)\([^.]\+\)\.vim/\1*\2.txt*/' \
+ plugin/minibufexpl.vim \
+ > doc/minibufexpl.txt
+}