summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-06-29 00:53:06 +0000
committerTim Harder <radhermit@gentoo.org>2011-06-29 00:53:06 +0000
commit4609a710d565e5fd5815a03b0035c4128f14c26e (patch)
tree8512c28c181526301fe1399c095e9080d898e6d3 /app-vim
parentInitial import. (diff)
downloadgentoo-2-4609a710d565e5fd5815a03b0035c4128f14c26e.tar.gz
gentoo-2-4609a710d565e5fd5815a03b0035c4128f14c26e.tar.bz2
gentoo-2-4609a710d565e5fd5815a03b0035c4128f14c26e.zip
Version bump. Use github mirrored tarball.
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gundo/ChangeLog7
-rw-r--r--app-vim/gundo/gundo-2.2.1.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/app-vim/gundo/ChangeLog b/app-vim/gundo/ChangeLog
index 33032932678f..a1d795f6bd2d 100644
--- a/app-vim/gundo/ChangeLog
+++ b/app-vim/gundo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/gundo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/gundo/ChangeLog,v 1.4 2011/05/30 10:23:12 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gundo/ChangeLog,v 1.5 2011/06/29 00:53:06 radhermit Exp $
+
+*gundo-2.2.1 (29 Jun 2011)
+
+ 29 Jun 2011; Tim Harder <radhermit@gentoo.org> +gundo-2.2.1.ebuild:
+ Version bump. Use github mirrored tarball.
*gundo-2.2.0 (30 May 2011)
diff --git a/app-vim/gundo/gundo-2.2.1.ebuild b/app-vim/gundo/gundo-2.2.1.ebuild
new file mode 100644
index 000000000000..697b5ae35b26
--- /dev/null
+++ b/app-vim/gundo/gundo-2.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gundo/gundo-2.2.1.ebuild,v 1.1 2011/06/29 00:53:06 radhermit Exp $
+
+EAPI=4
+VIM_PLUGIN_VIM_VERSION="7.3"
+
+inherit vim-plugin
+
+MY_PN="Gundo"
+DESCRIPTION="vim plugin: visualize your Vim undo tree"
+HOMEPAGE="http://sjl.bitbucket.org/gundo.vim/"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ >=dev-lang/python-2.4"
+
+VIM_PLUGIN_HELPFILES="gundo.txt"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ rm -f README*
+}