summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-06-16 04:01:46 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2015-06-16 04:01:46 +0000
commitba6c6d42be6441a902d9c9bbc451dc589a71f084 (patch)
tree328980612ab67d4808d1c1a25ef6b4a0e699a984 /app-vim
parentVersion bump. (diff)
downloadgentoo-2-ba6c6d42be6441a902d9c9bbc451dc589a71f084.tar.gz
gentoo-2-ba6c6d42be6441a902d9c9bbc451dc589a71f084.tar.bz2
gentoo-2-ba6c6d42be6441a902d9c9bbc451dc589a71f084.zip
Bump so it stops crashing on my remote gdb sessions.
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/pyclewn/ChangeLog7
-rw-r--r--app-vim/pyclewn/pyclewn-2.1.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/app-vim/pyclewn/ChangeLog b/app-vim/pyclewn/ChangeLog
index 6069ee9bdd29..6bb90edd73e8 100644
--- a/app-vim/pyclewn/ChangeLog
+++ b/app-vim/pyclewn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/pyclewn
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/pyclewn/ChangeLog,v 1.2 2015/06/03 11:40:14 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/pyclewn/ChangeLog,v 1.3 2015/06/16 04:01:46 robbat2 Exp $
+
+*pyclewn-2.1 (16 Jun 2015)
+
+ 16 Jun 2015; Robin H. Johnson <robbat2@gentoo.org> +pyclewn-2.1.ebuild:
+ Bump so it stops crashing on my remote gdb sessions.
03 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add pypi to remote-id in metadata.xml
diff --git a/app-vim/pyclewn/pyclewn-2.1.ebuild b/app-vim/pyclewn/pyclewn-2.1.ebuild
new file mode 100644
index 000000000000..e148c52ec6ef
--- /dev/null
+++ b/app-vim/pyclewn/pyclewn-2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/pyclewn/pyclewn-2.1.ebuild,v 1.1 2015/06/16 04:01:46 robbat2 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit eutils vim-plugin distutils-r1
+
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+DESCRIPTION="Pyclewn allows using vim as a front end to a debugger (pdb or gdb)"
+HOMEPAGE="http://pyclewn.sourceforge.net/"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="|| (
+ >=app-editors/vim-7.3[${PYTHON_USEDEP}]
+ >=app-editors/gvim-7.3[netbeans,${PYTHON_USEDEP}]
+)"
+DEPEND="${CDEPEND}
+ app-arch/vimball
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep \
+ 'dev-python/trollius[${PYTHON_USEDEP}]' python{2_7,3_3})
+"
+
+SLOT="0"
+
+#Completely broken (runs vim), disable for now
+#python_test() {
+# esetup.py test
+#}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ vimball -x -C "${ED}"/usr/share/vim/vimfiles lib/clewn/runtime/${P}.vmb || die "Extracting vimball failed"
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ optfeature "C/C++ debugging" sys-devel/gdb
+ optfeature "Python debugging" dev-python/pdb-clone
+}