summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-12-07 23:30:27 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-12-07 23:30:27 +0000
commit4c6459d4707c1f2a5c372cd91c9614f2ad9f9498 (patch)
treefa5ace5019bb246f7975ebfaaa275bc11463cc4c /dev-cpp/commoncpp2/commoncpp2-1.0.13.ebuild
parentstable (diff)
downloadgentoo-2-4c6459d4707c1f2a5c372cd91c9614f2ad9f9498.tar.gz
gentoo-2-4c6459d4707c1f2a5c372cd91c9614f2ad9f9498.tar.bz2
gentoo-2-4c6459d4707c1f2a5c372cd91c9614f2ad9f9498.zip
moved commoncpp2 from dev-libs to dev-cpp
Diffstat (limited to 'dev-cpp/commoncpp2/commoncpp2-1.0.13.ebuild')
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.0.13.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.0.13.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.0.13.ebuild
new file mode 100644
index 000000000000..34b32929059f
--- /dev/null
+++ b/dev-cpp/commoncpp2/commoncpp2-1.0.13.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.0.13.ebuild,v 1.1 2003/12/07 23:30:22 lanius Exp $
+
+IUSE="doc xml2"
+
+DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for\
+threading, sockets, file access, daemons, persistence, serial I/O, XML parsing,\
+and system services"
+SRC_URI="mirror://gnu/commonc++/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/commonc++/"
+
+DEPEND="xml2? ( dev-libs/libxml2 )
+ doc? ( app-doc/doxygen )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_compile() {
+ local myconf=""
+
+ use xml2 \
+ && myconf="${myconf} --with-xml" \
+ || myconf="${myconf} --without-xml"
+
+ econf ${myconf} --with-ftp || die "./configure failed"
+
+ emake || die
+
+ # kdoc disabled for now, it errors out
+ use doc && make doxy
+}
+
+src_install () {
+
+ einstall || die
+
+ dodoc AUTHORS INSTALL NEWS ChangeLog README\
+ THANKS TODO COPYING COPYING.addendum
+
+ # Only install html docs
+ # man and latex available, but seems a little wasteful
+ use doc && dohtml docs/html/*
+}