summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnders Rune Jensen <arj@gentoo.org>2005-10-30 20:33:38 +0000
committerAnders Rune Jensen <arj@gentoo.org>2005-10-30 20:33:38 +0000
commit44f79dea79515c9b7340d83d4bb65c85173683fa (patch)
tree5925230b0ca0569ca834390e446d7efe93f4de07 /dev-cpp/commoncpp2/commoncpp2-1.3.20.ebuild
parentAdd back logic to strip -fomit-frame-pointer only when using gcc-2; fixes bug... (diff)
downloadgentoo-2-44f79dea79515c9b7340d83d4bb65c85173683fa.tar.gz
gentoo-2-44f79dea79515c9b7340d83d4bb65c85173683fa.tar.bz2
gentoo-2-44f79dea79515c9b7340d83d4bb65c85173683fa.zip
new version
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'dev-cpp/commoncpp2/commoncpp2-1.3.20.ebuild')
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.3.20.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.3.20.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.3.20.ebuild
new file mode 100644
index 000000000000..5dba5bd11e91
--- /dev/null
+++ b/dev-cpp/commoncpp2/commoncpp2-1.3.20.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.3.20.ebuild,v 1.1 2005/10/30 20:33:38 arj Exp $
+
+DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
+SRC_URI="mirror://sourceforge/gnutelephony/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/commoncpp/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="xml2 doc"
+
+DEPEND="xml2? ( >=dev-libs/libxml2-2.6.19 )
+ doc? ( >=app-doc/doxygen-1.3.6 )"
+
+src_compile() {
+ # Save some time
+ ! use doc && \
+ sed "s/^DOXYGEN=.*/DOXYGEN=no/" <configure >tmp && \
+ cat tmp >configure
+
+ econf $(use_with xml2 xml) || die
+ emake || die
+}
+
+src_install () {
+ einstall || die
+
+ dodoc AUTHORS INSTALL NEWS ChangeLog README \
+ THANKS TODO COPYING COPYING.addendum
+
+ # Only install html docs
+ # man and latex available, but seems a little wasteful
+ use doc && dohtml doc/html/*
+}