summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2005-01-25 22:05:42 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2005-01-25 22:05:42 +0000
commitcc5957bad6073ac8cdaf85b937c7e5e7ce32e2b0 (patch)
treed481adccd08a963af502ed4ba20e71fe80847b20 /dev-cpp/gccxml/gccxml-0.6.0.ebuild
parent(Portage version: 2.0.51-r15) (Manifest recommit) (diff)
downloadgentoo-2-cc5957bad6073ac8cdaf85b937c7e5e7ce32e2b0.tar.gz
gentoo-2-cc5957bad6073ac8cdaf85b937c7e5e7ce32e2b0.tar.bz2
gentoo-2-cc5957bad6073ac8cdaf85b937c7e5e7ce32e2b0.zip
New package
(Portage version: 2.0.51-r14)
Diffstat (limited to 'dev-cpp/gccxml/gccxml-0.6.0.ebuild')
-rw-r--r--dev-cpp/gccxml/gccxml-0.6.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-cpp/gccxml/gccxml-0.6.0.ebuild b/dev-cpp/gccxml/gccxml-0.6.0.ebuild
new file mode 100644
index 000000000000..a88d9ecc778e
--- /dev/null
+++ b/dev-cpp/gccxml/gccxml-0.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gccxml/gccxml-0.6.0.ebuild,v 1.1 2005/01/25 22:05:42 g2boojum Exp $
+
+inherit versionator
+PVM="$(get_version_component_range 1-2)"
+DESCRIPTION="XML output extension to GCC"
+HOMEPAGE="http://www.gccxml.org/"
+SRC_URI="http://www.gccxml.org/files/v${PVM}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-util/cmake"
+RDEPEND=""
+
+MYBUILDDIR=${WORKDIR}/build
+src_unpack() {
+ mkdir ${MYBUILDDIR}
+ unpack ${A}
+}
+src_compile() {
+ cd ${MYBUILDDIR}
+ cmake ../${P} -DCMAKE_INSTALL_PREFIX:PATH=/usr || die "cmake failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd ${MYBUILDDIR}
+ make DESTDIR=${D} install || die
+}