summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-01-22 07:31:58 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-01-22 07:31:58 +0000
commit13f4c5862b3495646c88e9d74da60c3457640f82 (patch)
tree533bb8a09c4d3b7d35acceb05aa2ea8ffabacbd9 /dev-cpp
parentRemove old version. (diff)
downloadgentoo-2-13f4c5862b3495646c88e9d74da60c3457640f82.tar.gz
gentoo-2-13f4c5862b3495646c88e9d74da60c3457640f82.tar.bz2
gentoo-2-13f4c5862b3495646c88e9d74da60c3457640f82.zip
Bump to 1.9.8, uses cairo-1.10 API
(Portage version: 2.1.9.34/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/cairomm/ChangeLog7
-rw-r--r--dev-cpp/cairomm/cairomm-1.9.8.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-cpp/cairomm/ChangeLog b/dev-cpp/cairomm/ChangeLog
index 02e571fc011e..0daae86d7b9c 100644
--- a/dev-cpp/cairomm/ChangeLog
+++ b/dev-cpp/cairomm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/cairomm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/ChangeLog,v 1.43 2011/01/04 18:11:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/ChangeLog,v 1.44 2011/01/22 07:31:58 nirbheek Exp $
+
+*cairomm-1.9.8 (22 Jan 2011)
+
+ 22 Jan 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +cairomm-1.9.8.ebuild:
+ Bump to 1.9.8, uses cairo-1.10 API
04 Jan 2011; Raúl Porcel <armin76@gentoo.org> cairomm-1.8.2.ebuild:
alpha/arm/ia64/sh/sparc stable wrt #324077
diff --git a/dev-cpp/cairomm/cairomm-1.9.8.ebuild b/dev-cpp/cairomm/cairomm-1.9.8.ebuild
new file mode 100644
index 000000000000..37724000d803
--- /dev/null
+++ b/dev-cpp/cairomm/cairomm-1.9.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/cairomm-1.9.8.ebuild,v 1.1 2011/01/22 07:31:58 nirbheek Exp $
+
+EAPI="2"
+
+WANT_AUTOMAKE="1.10"
+
+inherit eutils
+
+DESCRIPTION="C++ bindings for the Cairo vector graphics library"
+HOMEPAGE="http://cairographics.org/cairomm"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc +svg"
+
+# FIXME: svg support is automagic
+RDEPEND=">=x11-libs/cairo-1.10[svg?]
+ dev-libs/libsigc++:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? (
+ app-doc/doxygen
+ dev-libs/libxslt
+ media-gfx/graphviz )"
+
+src_prepare() {
+ # don't waste time building examples because they are marked as "noinst"
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || die "sed failed"
+
+ # don't waste time building tests
+ # they require the boost Unit Testing framework, that's not in base boost
+ sed -i 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' Makefile.in || die "sed failed"
+}
+
+src_configure() {
+ econf \
+ --disable-tests \
+ $(use_enable doc documentation)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README ChangeLog || die "dodoc failed"
+}