summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-07-02 21:56:45 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-07-02 21:56:45 +0000
commit2ab25ac0f626c91ca4479e68eefc29cf34cf4a51 (patch)
treec1a3e4025da97fd6d14bb8ad85bd47a2eb4ff18d /dev-cpp
parentInitial commit wrt #220791, thanks to Florian Steinel and Igor. (diff)
downloadgentoo-2-2ab25ac0f626c91ca4479e68eefc29cf34cf4a51.tar.gz
gentoo-2-2ab25ac0f626c91ca4479e68eefc29cf34cf4a51.tar.bz2
gentoo-2-2ab25ac0f626c91ca4479e68eefc29cf34cf4a51.zip
bump to 2.16.3. Various bug fixes.
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/glibmm/ChangeLog7
-rw-r--r--dev-cpp/glibmm/glibmm-2.16.3.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-cpp/glibmm/ChangeLog b/dev-cpp/glibmm/ChangeLog
index 6d341ade5201..1076a06dc98f 100644
--- a/dev-cpp/glibmm/ChangeLog
+++ b/dev-cpp/glibmm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/glibmm
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/ChangeLog,v 1.113 2008/06/30 16:25:26 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/ChangeLog,v 1.114 2008/07/02 21:56:45 eva Exp $
+
+*glibmm-2.16.3 (02 Jul 2008)
+
+ 02 Jul 2008; Gilles Dartiguelongue <eva@gentoo.org> +glibmm-2.16.3.ebuild:
+ bump to 2.16.3. Various bug fixes.
30 Jun 2008; Jeroen Roovers <jer@gentoo.org> glibmm-2.16.1.ebuild:
Stable for HPPA (bug #227679).
diff --git a/dev-cpp/glibmm/glibmm-2.16.3.ebuild b/dev-cpp/glibmm/glibmm-2.16.3.ebuild
new file mode 100644
index 000000000000..49d54b493aae
--- /dev/null
+++ b/dev-cpp/glibmm/glibmm-2.16.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/glibmm-2.16.3.ebuild,v 1.1 2008/07/02 21:56:45 eva Exp $
+
+inherit gnome2
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="http://gtkmm.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=">=dev-libs/libsigc++-2.2
+ >=dev-libs/glib-2.16"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ if ! use examples; then
+ # don't waste time building the examples
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || die "sed failed"
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ if ! use doc && ! use examples; then
+ rm -fr "${D}/usr/share/doc/glibmm-2.4"
+ fi
+
+ if use examples; then
+ find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
+ dodoc examples
+ fi
+}