summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2006-01-10 00:36:06 +0000
committerIlya Volynets <iluxa@gentoo.org>2006-01-10 00:36:06 +0000
commita50447e804b6f5aa8fdd2e887e14aff537ff9313 (patch)
tree8157453bebc105bbc2411d0d01e196fa34bc9b86 /dev-cpp
parentBump to the latest development snapshot. (diff)
downloadgentoo-2-a50447e804b6f5aa8fdd2e887e14aff537ff9313.tar.gz
gentoo-2-a50447e804b6f5aa8fdd2e887e14aff537ff9313.tar.bz2
gentoo-2-a50447e804b6f5aa8fdd2e887e14aff537ff9313.zip
SPTK-3.0.11 is here
(Portage version: 2.0.53)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/sptk/ChangeLog10
-rw-r--r--dev-cpp/sptk/Manifest4
-rw-r--r--dev-cpp/sptk/files/digest-sptk-3.0.111
-rw-r--r--dev-cpp/sptk/sptk-3.0.11.ebuild65
4 files changed, 78 insertions, 2 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index f7a8cacdf48d..5398b625d665 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/sptk
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.11 2005/11/10 19:49:14 nelchael Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.12 2006/01/10 00:36:06 iluxa Exp $
+
+*sptk-3.0.11 (10 Jan 2006)
+
+ 10 Jan 2006; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
+ +sptk-3.0.11.ebuild:
+ 3.0.11 is here
11 Nov 2005; Krzysiek Pawlik <nelchael@gentoo.org> sptk-2.3.28.ebuild:
Stable on x86.
diff --git a/dev-cpp/sptk/Manifest b/dev-cpp/sptk/Manifest
index 1eac4c1c5776..1f573a9adfbf 100644
--- a/dev-cpp/sptk/Manifest
+++ b/dev-cpp/sptk/Manifest
@@ -1,6 +1,10 @@
MD5 c036c2081ec36e646c5997658d46fd32 ChangeLog 1943
MD5 c1961e9d1e8c7ce2861b6a9f9da08038 files/digest-sptk-2.3.28 62
+MD5 2529fe43f441df297184b8f3d8ce3a10 files/digest-sptk-3.0 59
+MD5 e9256a4a57897f70722574b5a45366fc files/digest-sptk-3.0.11 62
MD5 9d6f57f2f01a7c0acbaba21baffa4982 files/digest-sptk-3.0.6 61
MD5 623669b964009bb2a2adfc367f12d072 metadata.xml 334
MD5 b5cd9d1217f0d957c3926185dd0fe4b2 sptk-2.3.28.ebuild 1092
+MD5 c96992fd890d0949f4f968b441be1e2b sptk-3.0.11.ebuild 1398
MD5 954ae150ba200ce2de4d986855b49667 sptk-3.0.6.ebuild 1409
+MD5 2d0d3c20495b816b9452b71f7992aaa0 sptk-3.0.ebuild 1090
diff --git a/dev-cpp/sptk/files/digest-sptk-3.0.11 b/dev-cpp/sptk/files/digest-sptk-3.0.11
new file mode 100644
index 000000000000..e3c97de6faf9
--- /dev/null
+++ b/dev-cpp/sptk/files/digest-sptk-3.0.11
@@ -0,0 +1 @@
+MD5 2779cf1b1d82bcc692c68cddc63f1adb sptk-3.0.11.tbz2 3632287
diff --git a/dev-cpp/sptk/sptk-3.0.11.ebuild b/dev-cpp/sptk/sptk-3.0.11.ebuild
new file mode 100644
index 000000000000..6ce9ab5b6b5a
--- /dev/null
+++ b/dev-cpp/sptk/sptk-3.0.11.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2006-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.0.11.ebuild,v 1.1 2006/01/10 00:36:06 iluxa Exp $
+
+inherit autotools
+
+IUSE="fltk odbc doc"
+
+DESCRIPTION="C++ user interface toolkit for X with database and Excel support"
+SRC_URI="http://www.sptk.net/sptk-${PV}.tbz2"
+HOMEPAGE="http://www.sptk.net"
+
+SLOT="3"
+LICENSE="|| ( FLTK GPL-2 )"
+KEYWORDS="~x86 ~sparc ~mips ~amd64 ~ppc"
+
+DEPEND="fltk? ( x11-libs/fltk )
+ odbc? ( >=dev-db/unixODBC-2.2.6 )
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ # This fixes double ./configure run
+ eautoreconf
+}
+
+src_compile() {
+
+ local myconf
+ myconf="--enable-shared"
+
+ use odbc || myconf="${myconf} --disable-odbc" #default enabled
+ use fltk || myconf="${myconf} --disable-fltk"
+
+ econf \
+ --prefix=/usr \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+
+ if use doc; then
+ cd "${S}"
+ einfo "Fixing sptk3.doxygen"
+ sed -i -e 's,/cvs/sptk3/,,g' sptk3.doxygen
+ einfo "Building docs"
+ doxygen sptk3.doxygen
+ fi
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die "Installation failed"
+
+ dodoc README AUTHORS
+
+ dodir /usr/share/doc/${PF}
+ cp -r ${S}/docs/* ${D}/usr/share/doc/${PF}
+ if use doc; then
+ rm -fr ${D}/usr/share/doc/${PF}/latex
+ cp -r ${S}/pictures ${D}/usr/share/doc/${PF}
+ fi
+
+}