summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-15 17:08:08 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-15 17:08:08 +0000
commitc0175a1d3693ed996078ee6851c108108167d643 (patch)
tree07b0fb62cfc5514d361c94ac56dc3aa9e136fc3e /dev-cpp
parentUpdating remote-id in metadata.xml (diff)
downloadgentoo-2-c0175a1d3693ed996078ee6851c108108167d643.tar.gz
gentoo-2-c0175a1d3693ed996078ee6851c108108167d643.tar.bz2
gentoo-2-c0175a1d3693ed996078ee6851c108108167d643.zip
Version Bump; drop old
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/tbb/ChangeLog10
-rw-r--r--dev-cpp/tbb/files/tbb-4.3.20150611-build.patch196
-rw-r--r--dev-cpp/tbb/tbb-4.2.20140122.ebuild127
-rw-r--r--dev-cpp/tbb/tbb-4.3.20141023-r1.ebuild22
-rw-r--r--dev-cpp/tbb/tbb-4.3.20150611.ebuild (renamed from dev-cpp/tbb/tbb-4.2.20131118.ebuild)101
5 files changed, 269 insertions, 187 deletions
diff --git a/dev-cpp/tbb/ChangeLog b/dev-cpp/tbb/ChangeLog
index a233d78a5ae5..9d2d423eeb49 100644
--- a/dev-cpp/tbb/ChangeLog
+++ b/dev-cpp/tbb/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-cpp/tbb
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.52 2015/06/15 16:50:40 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.53 2015/06/15 17:08:07 jlec Exp $
+
+*tbb-4.3.20150611 (15 Jun 2015)
+
+ 15 Jun 2015; Justin Lecher <jlec@gentoo.org>
+ +files/tbb-4.3.20150611-build.patch, +tbb-4.3.20150611.ebuild,
+ -tbb-4.2.20131118.ebuild, -tbb-4.2.20140122.ebuild,
+ tbb-4.3.20141023-r1.ebuild:
+ Version Bump; drop old
*tbb-4.3.20141023-r1 (15 Jun 2015)
diff --git a/dev-cpp/tbb/files/tbb-4.3.20150611-build.patch b/dev-cpp/tbb/files/tbb-4.3.20150611-build.patch
new file mode 100644
index 000000000000..42a8bae4640a
--- /dev/null
+++ b/dev-cpp/tbb/files/tbb-4.3.20150611-build.patch
@@ -0,0 +1,196 @@
+ build/FreeBSD.gcc.inc | 18 ++++--------------
+ build/linux.clang.inc | 26 +++-----------------------
+ build/linux.gcc.inc | 38 +++++++-------------------------------
+ 3 files changed, 14 insertions(+), 68 deletions(-)
+
+diff --git a/build/FreeBSD.gcc.inc b/build/FreeBSD.gcc.inc
+index 20f0027..8bbdeba 100644
+--- a/build/FreeBSD.gcc.inc
++++ b/build/FreeBSD.gcc.inc
+@@ -28,14 +28,14 @@ WARNING_KEY = -Wall
+ DYLIB_KEY = -shared
+ WARNING_SUPPRESS = -Wno-parentheses
+
+-CPLUS = g++
+-CONLY = gcc
++CPLUS = $(CXX)
++CONLY = $(CC)
+ LIB_LINK_FLAGS = -shared
+ LIBS = -lpthread
+ C_FLAGS = $(CPLUS_FLAGS)
+
+ ifeq ($(cfg), release)
+- CPLUS_FLAGS = -g -O2 -DUSE_PTHREAD
++ CPLUS_FLAGS = -g -DUSE_PTHREAD
+ endif
+ ifeq ($(cfg), debug)
+ CPLUS_FLAGS = -DTBB_USE_DEBUG -g -O0 -DUSE_PTHREAD
+@@ -52,22 +52,12 @@ ifeq (ia64,$(arch))
+ CPLUS_FLAGS += $(PIC_KEY)
+ endif
+
+-ifeq (intel64,$(arch))
+- CPLUS_FLAGS += -m64
+- LIB_LINK_FLAGS += -m64
+-endif
+-
+-ifeq (ia32,$(arch))
+- CPLUS_FLAGS += -m32
+- LIB_LINK_FLAGS += -m32
+-endif
+-
+ #------------------------------------------------------------------------------
+ # Setting assembler data.
+ #------------------------------------------------------------------------------
+ ASSEMBLY_SOURCE=$(arch)-gas
+ ifeq (ia64,$(arch))
+- ASM=as
++ ASM=$(AS)
+ TBB_ASM.OBJ = atomic_support.o lock_byte.o log2.o pause.o
+ MALLOC_ASM.OBJ = atomic_support.o lock_byte.o pause.o
+ endif
+diff --git a/build/linux.clang.inc b/build/linux.clang.inc
+index de9aee5..3a366f1 100644
+--- a/build/linux.clang.inc
++++ b/build/linux.clang.inc
+@@ -31,15 +31,15 @@ DYLIB_KEY = -shared
+ EXPORT_KEY = -Wl,--version-script,
+ LIBDL = -ldl
+
+-CPLUS = clang++
+-CONLY = clang
++CPLUS := $(CXX)
++CONLY := $(CC)
+ LIB_LINK_FLAGS = $(DYLIB_KEY) -Wl,-soname=$(BUILDING_LIBRARY)
+ LIBS += -lpthread -lrt
+ LINK_FLAGS = -Wl,-rpath-link=. -rdynamic
+ C_FLAGS = $(CPLUS_FLAGS)
+
+ ifeq ($(cfg), release)
+- CPLUS_FLAGS = $(ITT_NOTIFY) -g -O2 -DUSE_PTHREAD
++ CPLUS_FLAGS = $(ITT_NOTIFY) -g -DUSE_PTHREAD
+ endif
+ ifeq ($(cfg), debug)
+ CPLUS_FLAGS = -DTBB_USE_DEBUG $(ITT_NOTIFY) -g -O0 -DUSE_PTHREAD
+@@ -61,24 +61,10 @@ MALLOC_ASM.OBJ=
+
+ ifeq (intel64,$(arch))
+ ITT_NOTIFY = -DDO_ITT_NOTIFY
+- CPLUS_FLAGS += -m64
+- LIB_LINK_FLAGS += -m64
+ endif
+
+ ifeq (ia32,$(arch))
+ ITT_NOTIFY = -DDO_ITT_NOTIFY
+- CPLUS_FLAGS += -m32 -march=pentium4
+- LIB_LINK_FLAGS += -m32
+-endif
+-
+-ifeq (ppc64,$(arch))
+- CPLUS_FLAGS += -m64
+- LIB_LINK_FLAGS += -m64
+-endif
+-
+-ifeq (ppc32,$(arch))
+- CPLUS_FLAGS += -m32
+- LIB_LINK_FLAGS += -m32
+ endif
+
+ ifeq (bg,$(arch))
+@@ -90,12 +76,6 @@ endif
+ # Setting assembler data.
+ #------------------------------------------------------------------------------
+ ASM = as
+-ifeq (intel64,$(arch))
+- ASM_FLAGS += --64
+-endif
+-ifeq (ia32,$(arch))
+- ASM_FLAGS += --32
+-endif
+ ifeq ($(cfg),debug)
+ ASM_FLAGS += -g
+ endif
+diff --git a/build/linux.gcc.inc b/build/linux.gcc.inc
+index 4b7122b..e8ba711 100644
+--- a/build/linux.gcc.inc
++++ b/build/linux.gcc.inc
+@@ -32,12 +32,12 @@ DYLIB_KEY = -shared
+ EXPORT_KEY = -Wl,--version-script,
+ LIBDL = -ldl
+
+-CPLUS = g++
+-CONLY = gcc
++CPLUS := $(CXX)
++CONLY := $(CC)
+ LIB_LINK_FLAGS = $(DYLIB_KEY) -Wl,-soname=$(BUILDING_LIBRARY)
+ LIBS += -lpthread -lrt
+ LINK_FLAGS = -Wl,-rpath-link=. -rdynamic
+-C_FLAGS = $(CPLUS_FLAGS)
++C_FLAGS := $(CPLUS_FLAGS)
+ # gcc 4.4 and higher support -std=c++0x
+ ifneq (,$(shell gcc -dumpversion | egrep "^(4\.[4-9]|[5-9])"))
+ CPP11_FLAGS = -std=c++0x -D_TBB_CPP0X
+@@ -54,7 +54,7 @@ ifneq (,$(shell gcc -dumpversion | egrep "^4\.[8-9]"))
+ endif
+
+ ifeq ($(cfg), release)
+- CPLUS_FLAGS = $(ITT_NOTIFY) -g -O2 -DUSE_PTHREAD
++ CPLUS_FLAGS = $(ITT_NOTIFY) -g -DUSE_PTHREAD
+ endif
+ ifeq ($(cfg), debug)
+ CPLUS_FLAGS = -DTBB_USE_DEBUG $(ITT_NOTIFY) -g -O0 -DUSE_PTHREAD
+@@ -74,24 +74,12 @@ endif
+
+ ifeq (intel64,$(arch))
+ ITT_NOTIFY = -DDO_ITT_NOTIFY
+- CPLUS_FLAGS += -m64 $(RTM_KEY)
+- LIB_LINK_FLAGS += -m64
++ CPLUS_FLAGS += $(RTM_KEY)
+ endif
+
+ ifeq (ia32,$(arch))
+ ITT_NOTIFY = -DDO_ITT_NOTIFY
+- CPLUS_FLAGS += -m32 -march=pentium4 $(RTM_KEY)
+- LIB_LINK_FLAGS += -m32
+-endif
+-
+-ifeq (ppc64,$(arch))
+- CPLUS_FLAGS += -m64
+- LIB_LINK_FLAGS += -m64
+-endif
+-
+-ifeq (ppc32,$(arch))
+- CPLUS_FLAGS += -m32
+- LIB_LINK_FLAGS += -m32
++ CPLUS_FLAGS += $(RTM_KEY)
+ endif
+
+ ifeq (bg,$(arch))
+@@ -99,12 +87,6 @@ ifeq (bg,$(arch))
+ CONLY = $(firstword $(notdir $(shell which powerpc{64,32,}-bg{z..a}-linux-gcc 2>/dev/null)))
+ endif
+
+-# for some gcc versions on Solaris, -m64 may imply V9, but perhaps not everywhere (TODO: verify)
+-ifeq (sparc,$(arch))
+- CPLUS_FLAGS += -mcpu=v9 -m64
+- LIB_LINK_FLAGS += -mcpu=v9 -m64
+-endif
+-
+ # automatically generate "IT" instructions when compiling for Thumb ISA
+ ifeq (armv7,$(arch))
+ CPLUS_FLAGS += -Wa,-mimplicit-it=thumb
+@@ -113,13 +95,7 @@ endif
+ #------------------------------------------------------------------------------
+ # Setting assembler data.
+ #------------------------------------------------------------------------------
+-ASM = as
+-ifeq (intel64,$(arch))
+- ASM_FLAGS += --64
+-endif
+-ifeq (ia32,$(arch))
+- ASM_FLAGS += --32
+-endif
++ASM := $(AS)
+ ifeq ($(cfg),debug)
+ ASM_FLAGS += -g
+ endif
diff --git a/dev-cpp/tbb/tbb-4.2.20140122.ebuild b/dev-cpp/tbb/tbb-4.2.20140122.ebuild
deleted file mode 100644
index 9dec2e454592..000000000000
--- a/dev-cpp/tbb/tbb-4.2.20140122.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-4.2.20140122.ebuild,v 1.3 2014/10/30 14:39:47 aballier Exp $
-
-EAPI=5
-inherit eutils flag-o-matic multilib versionator toolchain-funcs
-
-PV1="$(get_version_component_range 1)"
-PV2="$(get_version_component_range 2)"
-PV3="$(get_version_component_range 3)"
-MYP="${PN}${PV1}${PV2}_${PV3}oss"
-
-DESCRIPTION="High level abstract threading library"
-HOMEPAGE="http://www.threadingbuildingblocks.org/"
-SRC_URI="http://threadingbuildingblocks.org/sites/default/files/software_releases/source/${MYP}_src.tgz"
-LICENSE="GPL-2-with-exceptions"
-
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
-IUSE="debug doc examples"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-S="${WORKDIR}/${MYP}"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-4.0.297-underlinking.patch
- # use fully qualified gcc compilers. do not force march/mcpu
- # not tested with icc
- # order in sed expressions is important
- sed -i \
- -e "s/g++/$(tc-getCXX)/g" \
- -e "s/gcc/$(tc-getCC)/g" \
- -e 's/-m\(arch\|cpu\)=*[[:space:]]//g' \
- -e 's/-\(m\|-\)\(64\|32\)//g' \
- -e 's/-O2/$(CXXFLAGS)/g' \
- -e "/^ASM/s/as/$(tc-getAS)/g" \
- build/*.gcc.inc || die
-
- # Give it a soname on FreeBSD
- echo 'LIB_LINK_FLAGS += -Wl,-soname=$(BUILDING_LIBRARY)' >> build/FreeBSD.gcc.inc
- # Set proper versionning on FreeBSD
- sed -i -e '/.DLL =/s/$/.1/' build/FreeBSD.inc || die
-
- # force 64bit where applicable, 32bit where applicable...
- # built-in detection is based on running kernel, which messes up
- # e.g. in a x86 chroot on amd64 kernel. Bug 462130
- # see build/linux.inc for values
- use amd64 && export arch=x86_64
- use amd64-linux && export arch=x86_64
- use x86 && export arch=ia32
- use x86-linux && export arch=ia32
- # no idea what to do with ppc but so far it seems to work
-
- find include -name \*.html -delete || die
-
- # pc files are for debian and fedora compatibility
- # some deps use them
- cat <<-EOF > ${PN}.pc.template
- prefix=${EPREFIX}/usr
- libdir=\${prefix}/$(get_libdir)
- includedir=\${prefix}/include
- Name: ${PN}
- Description: ${DESCRIPTION}
- Version: ${PV}
- URL: ${HOMEPAGE}
- Cflags: -I\${includedir}
- EOF
- cp ${PN}.pc.template ${PN}.pc
- cat <<-EOF >> ${PN}.pc
- Libs: -L\${libdir} -ltbb
- Libs.private: -lm -lrt
- EOF
- cp ${PN}.pc.template ${PN}malloc.pc
- cat <<-EOF >> ${PN}malloc.pc
- Libs: -L\${libdir} -ltbbmalloc
- Libs.private: -lm -lrt
- EOF
- cp ${PN}.pc.template ${PN}malloc_proxy.pc
- cat <<-EOF >> ${PN}malloc_proxy.pc
- Libs: -L\${libdir} -ltbbmalloc_proxy
- Libs.private: -lrt
- Requires: tbbmalloc
- EOF
- use debug || sed -i -e '/_debug/d' Makefile
-}
-
-src_compile() {
- if [[ $(tc-getCXX) == *g++* ]]; then
- comp="gcc"
- elif [[ $(tc-getCXX) == *ic*c ]]; then
- comp="icc"
- else
- die "compiler $(tc-getCXX) not supported by build system"
- fi
- emake compiler=${comp} tbb tbbmalloc
-}
-
-src_test() {
- append-cxxflags -fabi-version=4
- # avoid oversubscribing with -j1
- emake -j1 compiler=${comp} test
-}
-
-src_install(){
- local l
- for l in $(find build -name lib\*.so.\*); do
- dolib.so ${l}
- local bl=$(basename ${l})
- dosym ${bl} /usr/$(get_libdir)/${bl%.*}
- done
- doheader -r include/*
-
- insinto /usr/$(get_libdir)/pkgconfig
- doins *.pc
-
- dodoc README CHANGES doc/Release_Notes.txt
- use doc && dohtml -r doc/html/*
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples/build
- doins build/*.inc
- insinto /usr/share/doc/${PF}/examples
- doins -r examples
- fi
-}
diff --git a/dev-cpp/tbb/tbb-4.3.20141023-r1.ebuild b/dev-cpp/tbb/tbb-4.3.20141023-r1.ebuild
index ecb9e742a154..1b4e2e62e811 100644
--- a/dev-cpp/tbb/tbb-4.3.20141023-r1.ebuild
+++ b/dev-cpp/tbb/tbb-4.3.20141023-r1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-4.3.20141023-r1.ebuild,v 1.1 2015/06/15 16:50:40 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-4.3.20141023-r1.ebuild,v 1.2 2015/06/15 17:08:07 jlec Exp $
EAPI=5
-inherit eutils flag-o-matic versionator toolchain-funcs multilib-minimal
+
+inherit eutils flag-o-matic multilib-minimal toolchain-funcs versionator
PV1="$(get_version_component_range 1)"
PV2="$(get_version_component_range 2)"
@@ -14,7 +15,6 @@ DESCRIPTION="High level abstract threading library"
HOMEPAGE="http://www.threadingbuildingblocks.org/"
SRC_URI="http://threadingbuildingblocks.org/sites/default/files/software_releases/source/${MYP}_src.tgz"
LICENSE="GPL-2-with-exceptions"
-
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
IUSE="debug doc examples"
@@ -75,15 +75,15 @@ local_src_compile() {
local comp arch
case ${MULTILIB_ABI_FLAG} in
- abi_x86_64) arch=x86_64 ;;
- abi_x86_32) arch=ia32 ;;
+ abi_x86_64) arch=x86_64 ;;
+ abi_x86_32) arch=ia32 ;;
esac
case "$(tc-getCXX)" in
- *g++*) comp="gcc" ;;
- *ic*c) comp="icc" ;;
- *clang*) comp="clang" ;;
- *) die "compiler $(tc-getCXX) not supported by build system" ;;
+ *g++*) comp="gcc" ;;
+ *ic*c) comp="icc" ;;
+ *clang*) comp="clang" ;;
+ *) die "compiler $(tc-getCXX) not supported by build system" ;;
esac
CXX="$(tc-getCXX)" \
@@ -104,7 +104,7 @@ multilib_src_test() {
}
multilib_src_install() {
- cd "${BUILD_DIR}_release"
+ cd "${BUILD_DIR}_release" || die
local l
for l in $(find . -name lib\*.so.\*); do
dolib.so ${l}
@@ -112,7 +112,7 @@ multilib_src_install() {
dosym ${bl} /usr/$(get_libdir)/${bl%.*}
done
- cd "${BUILD_DIR}"
+ cd "${BUILD_DIR}" || die
insinto /usr/$(get_libdir)/pkgconfig
doins *.pc
}
diff --git a/dev-cpp/tbb/tbb-4.2.20131118.ebuild b/dev-cpp/tbb/tbb-4.3.20150611.ebuild
index 8c8203c4a4c7..81f9b0416de2 100644
--- a/dev-cpp/tbb/tbb-4.2.20131118.ebuild
+++ b/dev-cpp/tbb/tbb-4.3.20150611.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-4.2.20131118.ebuild,v 1.2 2014/06/08 08:14:26 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-4.3.20150611.ebuild,v 1.1 2015/06/15 17:08:07 jlec Exp $
EAPI=5
-inherit eutils flag-o-matic multilib versionator toolchain-funcs
+
+inherit eutils flag-o-matic multilib-minimal toolchain-funcs versionator
PV1="$(get_version_component_range 1)"
PV2="$(get_version_component_range 2)"
@@ -14,9 +15,8 @@ DESCRIPTION="High level abstract threading library"
HOMEPAGE="http://www.threadingbuildingblocks.org/"
SRC_URI="http://threadingbuildingblocks.org/sites/default/files/software_releases/source/${MYP}_src.tgz"
LICENSE="GPL-2-with-exceptions"
-
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
IUSE="debug doc examples"
DEPEND=""
@@ -25,36 +25,20 @@ S="${WORKDIR}/${MYP}"
src_prepare() {
epatch \
- "${FILESDIR}"/${PN}-4.0.297-underlinking.patch
- # use fully qualified gcc compilers. do not force march/mcpu
- # not tested with icc
- # order in sed expressions is important
- sed -i \
- -e "s/g++/$(tc-getCXX)/g" \
- -e "s/gcc/$(tc-getCC)/g" \
- -e 's/-m\(arch\|cpu\)=*[[:space:]]//g' \
- -e 's/-\(m\|-\)\(64\|32\)//g' \
- -e 's/-O2/$(CXXFLAGS)/g' \
- -e "/^ASM/s/as/$(tc-getAS)/g" \
- build/*.gcc.inc || die
+ "${FILESDIR}"/${PN}-4.0.297-underlinking.patch \
+ "${FILESDIR}"/${P}-build.patch
+
+ find include -name \*.html -delete || die
# Give it a soname on FreeBSD
echo 'LIB_LINK_FLAGS += -Wl,-soname=$(BUILDING_LIBRARY)' >> build/FreeBSD.gcc.inc
# Set proper versionning on FreeBSD
sed -i -e '/.DLL =/s/$/.1/' build/FreeBSD.inc || die
- # force 64bit where applicable, 32bit where applicable...
- # built-in detection is based on running kernel, which messes up
- # e.g. in a x86 chroot on amd64 kernel. Bug 462130
- # see build/linux.inc for values
- use amd64 && export arch=x86_64
- use amd64-linux && export arch=x86_64
- use x86 && export arch=ia32
- use x86-linux && export arch=ia32
- # no idea what to do with ppc but so far it seems to work
-
- find include -name \*.html -delete || die
+ use debug || sed -i -e '/_debug/d' Makefile
+}
+multilib_src_configure() {
# pc files are for debian and fedora compatibility
# some deps use them
cat <<-EOF > ${PN}.pc.template
@@ -67,53 +51,74 @@ src_prepare() {
URL: ${HOMEPAGE}
Cflags: -I\${includedir}
EOF
- cp ${PN}.pc.template ${PN}.pc
+ cp ${PN}.pc.template ${PN}.pc || die
cat <<-EOF >> ${PN}.pc
Libs: -L\${libdir} -ltbb
Libs.private: -lm -lrt
EOF
- cp ${PN}.pc.template ${PN}malloc.pc
+ cp ${PN}.pc.template ${PN}malloc.pc || die
cat <<-EOF >> ${PN}malloc.pc
Libs: -L\${libdir} -ltbbmalloc
Libs.private: -lm -lrt
EOF
- cp ${PN}.pc.template ${PN}malloc_proxy.pc
+ cp ${PN}.pc.template ${PN}malloc_proxy.pc || die
cat <<-EOF >> ${PN}malloc_proxy.pc
Libs: -L\${libdir} -ltbbmalloc_proxy
Libs.private: -lrt
Requires: tbbmalloc
EOF
- use debug || sed -i -e '/_debug/d' Makefile
}
-src_compile() {
- if [[ $(tc-getCXX) == *g++* ]]; then
- comp="gcc"
- elif [[ $(tc-getCXX) == *ic*c ]]; then
- comp="icc"
- else
- die "compiler $(tc-getCXX) not supported by build system"
- fi
- emake compiler=${comp} tbb tbbmalloc
+local_src_compile() {
+ cd "${S}"
+
+ local comp arch
+
+ case ${MULTILIB_ABI_FLAG} in
+ abi_x86_64) arch=x86_64 ;;
+ abi_x86_32) arch=ia32 ;;
+ esac
+
+ case "$(tc-getCXX)" in
+ *g++*) comp="gcc" ;;
+ *ic*c) comp="icc" ;;
+ *clang*) comp="clang" ;;
+ *) die "compiler $(tc-getCXX) not supported by build system" ;;
+ esac
+
+ CXX="$(tc-getCXX)" \
+ CC="$(tc-getCC)" \
+ AS="$(tc-getAS)" \
+ arch=${arch} \
+ CPLUS_FLAGS="${CXXFLAGS}" \
+ emake compiler=${comp} work_dir="${BUILD_DIR}" tbb_root="${S}" $@
+}
+
+multilib_src_compile() {
+ local_src_compile tbb tbbmalloc
}
-src_test() {
- append-cxxflags -fabi-version=4
- # avoid oversubscribing with -j1
- emake -j1 compiler=${comp} test
+multilib_src_test() {
+ CXXFLAGS="${CXXFLAGS} -fabi-version=4" \
+ local_src_compile -j1 test
}
-src_install(){
+multilib_src_install() {
+ cd "${BUILD_DIR}_release" || die
local l
- for l in $(find build -name lib\*.so.\*); do
+ for l in $(find . -name lib\*.so.\*); do
dolib.so ${l}
local bl=$(basename ${l})
dosym ${bl} /usr/$(get_libdir)/${bl%.*}
done
- doheader -r include/*
+ cd "${BUILD_DIR}" || die
insinto /usr/$(get_libdir)/pkgconfig
doins *.pc
+}
+
+multilib_src_install_all() {
+ doheader -r include/*
dodoc README CHANGES doc/Release_Notes.txt
use doc && dohtml -r doc/html/*