summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-12-27 16:26:20 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-12-27 16:26:20 +0000
commitf63c0d5a3b62e26d67835c1ca3758de0e725bf0a (patch)
treefc1a67d8fb36379837b91b3db48dfc29d11d7465 /dev-cpp
parentAdd missing dependency for eautoreconf, bug #533682. (diff)
downloadgentoo-2-f63c0d5a3b62e26d67835c1ca3758de0e725bf0a.tar.gz
gentoo-2-f63c0d5a3b62e26d67835c1ca3758de0e725bf0a.tar.bz2
gentoo-2-f63c0d5a3b62e26d67835c1ca3758de0e725bf0a.zip
Version bump by Andreas Sturmlechner, bug 533140
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libcmis/ChangeLog8
-rw-r--r--dev-cpp/libcmis/libcmis-0.5.0.ebuild71
-rw-r--r--dev-cpp/libcmis/libcmis-9999.ebuild16
3 files changed, 87 insertions, 8 deletions
diff --git a/dev-cpp/libcmis/ChangeLog b/dev-cpp/libcmis/ChangeLog
index f87c5eb6f6a1..781c6e0f66f8 100644
--- a/dev-cpp/libcmis/ChangeLog
+++ b/dev-cpp/libcmis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/libcmis
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/ChangeLog,v 1.29 2014/06/29 16:43:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/ChangeLog,v 1.30 2014/12/27 16:26:20 dilfridge Exp $
+
+*libcmis-0.5.0 (27 Dec 2014)
+
+ 27 Dec 2014; Andreas K. Huettel <dilfridge@gentoo.org> +libcmis-0.5.0.ebuild,
+ libcmis-9999.ebuild:
+ Version bump by Andreas Sturmlechner, bug 533140
29 Jun 2014; Agostino Sarubbo <ago@gentoo.org> libcmis-0.4.1.ebuild:
Stable for x86, wrt bug #514886
diff --git a/dev-cpp/libcmis/libcmis-0.5.0.ebuild b/dev-cpp/libcmis/libcmis-0.5.0.ebuild
new file mode 100644
index 000000000000..3c8466e806e8
--- /dev/null
+++ b/dev-cpp/libcmis/libcmis-0.5.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-0.5.0.ebuild,v 1.1 2014/12/27 16:26:20 dilfridge Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://git.code.sf.net/p/libcmis/code"
+[[ ${PV} == 9999 ]] && SCM_ECLASS="git-r3"
+inherit eutils alternatives autotools ${SCM_ECLASS}
+unset SCM_ECLASS
+
+DESCRIPTION="C++ client library for the CMIS interface"
+HOMEPAGE="https://sourceforge.net/projects/libcmis/"
+[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
+SLOT="0.5"
+
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS=""
+# ^ since this is only needed for live libreoffice
+
+IUSE="static-libs man test"
+
+RDEPEND="
+ !dev-cpp/libcmis:0
+ dev-libs/boost:=
+ dev-libs/libxml2
+ net-misc/curl
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ man? (
+ app-text/docbook2X
+ dev-libs/libxslt
+ )
+ test? (
+ dev-util/cppcheck
+ dev-util/cppunit
+ )
+"
+
+src_prepare() {
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --program-suffix=-${SLOT} \
+ --disable-werror \
+ $(use_with man) \
+ $(use_enable static-libs static) \
+ $(use_enable test tests) \
+ --enable-client
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ alternatives_auto_makesym /usr/bin/cmis-client "/usr/bin/cmis-client-[0-9].[0-9]"
+}
+
+pkg_postrm() {
+ alternatives_auto_makesym /usr/bin/cmis-client "/usr/bin/cmis-client-[0-9].[0-9]"
+}
diff --git a/dev-cpp/libcmis/libcmis-9999.ebuild b/dev-cpp/libcmis/libcmis-9999.ebuild
index 871840d15668..9f62536421df 100644
--- a/dev-cpp/libcmis/libcmis-9999.ebuild
+++ b/dev-cpp/libcmis/libcmis-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-9999.ebuild,v 1.12 2013/08/09 08:51:25 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-9999.ebuild,v 1.13 2014/12/27 16:26:20 dilfridge Exp $
EAPI=5
-EGIT_REPO_URI="git://gitorious.org/libcmis/libcmis.git"
-[[ ${PV} == 9999 ]] && SCM_ECLASS="git-2"
+EGIT_REPO_URI="git://git.code.sf.net/p/libcmis/code"
+[[ ${PV} == 9999 ]] && SCM_ECLASS="git-r3"
inherit eutils alternatives autotools ${SCM_ECLASS}
unset SCM_ECLASS
@@ -14,7 +14,7 @@ HOMEPAGE="https://sourceforge.net/projects/libcmis/"
[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
-SLOT="0.4"
+SLOT="0.5"
# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
[[ ${PV} == 9999 ]] || \
@@ -34,7 +34,10 @@ DEPEND="${RDEPEND}
app-text/docbook2X
dev-libs/libxslt
)
- test? ( dev-util/cppunit )
+ test? (
+ dev-util/cppcheck
+ dev-util/cppunit
+ )
"
src_prepare() {
@@ -49,7 +52,6 @@ src_configure() {
$(use_with man) \
$(use_enable static-libs static) \
$(use_enable test tests) \
- --disable-long-tests \
--enable-client
}