summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-03 00:05:26 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-03 00:05:26 +0000
commitf9af29cbdcbed13f8da2d2f0d08723433db0d1d8 (patch)
treed2fc33a836fa922622bfd5d9acaacd3868d0f17f /dev-cpp
parentDrop old. Seek kids: those were Great Folks to deal with. (diff)
downloadgentoo-2-f9af29cbdcbed13f8da2d2f0d08723433db0d1d8.tar.gz
gentoo-2-f9af29cbdcbed13f8da2d2f0d08723433db0d1d8.tar.bz2
gentoo-2-f9af29cbdcbed13f8da2d2f0d08723433db0d1d8.zip
Use python-any-r1 to enforce Python 2.7 as required for the build system to work.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/pficommon/ChangeLog8
-rw-r--r--dev-cpp/pficommon/pficommon-1.3.1.0.ebuild9
2 files changed, 12 insertions, 5 deletions
diff --git a/dev-cpp/pficommon/ChangeLog b/dev-cpp/pficommon/ChangeLog
index 90d85bdbbcf0..5e12eb0941e2 100644
--- a/dev-cpp/pficommon/ChangeLog
+++ b/dev-cpp/pficommon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/pficommon
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pficommon/ChangeLog,v 1.4 2014/12/28 15:00:55 titanofold Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pficommon/ChangeLog,v 1.5 2015/01/03 00:05:26 mgorny Exp $
+
+ 03 Jan 2015; Michał Górny <mgorny@gentoo.org> pficommon-1.3.1.0.ebuild:
+ Use python-any-r1 to enforce Python 2.7 as required for the build system to
+ work.
28 Dec 2014; Aaron W. Swenson <titanofold@gentoo.org>
pficommon-1.3.1.0.ebuild:
diff --git a/dev-cpp/pficommon/pficommon-1.3.1.0.ebuild b/dev-cpp/pficommon/pficommon-1.3.1.0.ebuild
index bac25a75d1df..381f5b8be611 100644
--- a/dev-cpp/pficommon/pficommon-1.3.1.0.ebuild
+++ b/dev-cpp/pficommon/pficommon-1.3.1.0.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pficommon/pficommon-1.3.1.0.ebuild,v 1.4 2014/12/28 15:00:55 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pficommon/pficommon-1.3.1.0.ebuild,v 1.5 2015/01/03 00:05:26 mgorny Exp $
EAPI=4
-inherit waf-utils eutils
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+inherit python-any-r1 waf-utils eutils
DESCRIPTION="General purpose C++ library for PFI"
HOMEPAGE="https://github.com/pfi/pficommon"
@@ -26,6 +28,7 @@ RDEPEND="fcgi? ( dev-libs/fcgi )
postgres? ( dev-db/postgresql )
"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
test? ( dev-cpp/gtest )"
src_unpack() {