summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-04-05 20:00:13 +0000
committerPeter Volkov <pva@gentoo.org>2007-04-05 20:00:13 +0000
commit6ddd8b051996759201a2637bc458d8eb33032dab (patch)
tree5def1256de304a92d1e6eed8cac342e92154d911 /dev-db/gigabase
parentunmask media-video/ffmpeg-0.4.9_p20070330, non pic safe asm has been disabled... (diff)
downloadgentoo-2-6ddd8b051996759201a2637bc458d8eb33032dab.tar.gz
gentoo-2-6ddd8b051996759201a2637bc458d8eb33032dab.tar.bz2
gentoo-2-6ddd8b051996759201a2637bc458d8eb33032dab.zip
Version bump.
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-db/gigabase')
-rw-r--r--dev-db/gigabase/ChangeLog7
-rw-r--r--dev-db/gigabase/files/digest-gigabase-3.573
-rw-r--r--dev-db/gigabase/gigabase-3.57.ebuild44
3 files changed, 53 insertions, 1 deletions
diff --git a/dev-db/gigabase/ChangeLog b/dev-db/gigabase/ChangeLog
index 89181982c162..15a85bf9c0f8 100644
--- a/dev-db/gigabase/ChangeLog
+++ b/dev-db/gigabase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/gigabase
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/ChangeLog,v 1.21 2007/03/16 09:34:33 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/ChangeLog,v 1.22 2007/04/05 20:00:13 pva Exp $
+
+*gigabase-3.57 (05 Apr 2007)
+
+ 05 Apr 2007; <pva@gentoo.org> +gigabase-3.57.ebuild:
+ Version bump.
*gigabase-3.56 (16 Mar 2007)
diff --git a/dev-db/gigabase/files/digest-gigabase-3.57 b/dev-db/gigabase/files/digest-gigabase-3.57
new file mode 100644
index 000000000000..3ef3aa429675
--- /dev/null
+++ b/dev-db/gigabase/files/digest-gigabase-3.57
@@ -0,0 +1,3 @@
+MD5 921e415b712c70006c202ce0016cd4e0 gigabase-3.57.tar.gz 1421414
+RMD160 228e4a8ab2904fc68c65f8ab7ab8debb4ae3adc2 gigabase-3.57.tar.gz 1421414
+SHA256 97ba44c50bcc85966f4a94c3dc33094e0dea9da2116fb3cbfec6770d26f25989 gigabase-3.57.tar.gz 1421414
diff --git a/dev-db/gigabase/gigabase-3.57.ebuild b/dev-db/gigabase/gigabase-3.57.ebuild
new file mode 100644
index 000000000000..5e06e5bc3ad9
--- /dev/null
+++ b/dev-db/gigabase/gigabase-3.57.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/gigabase-3.57.ebuild,v 1.1 2007/04/05 20:00:13 pva Exp $
+
+inherit multilib
+
+DESCRIPTION="OO-DBMS with interfaces for C/C++/Java/PHP/Perl"
+HOMEPAGE="http://www.garret.ru/~knizhnik/gigabase.html"
+SRC_URI="mirror://sourceforge/gigabase/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~s390 ~x86"
+IUSE="doc"
+DEPEND=""
+
+S="${WORKDIR}"/gigabase
+
+src_compile() {
+ mf="${S}/Makefile"
+
+ econf || die "econf failed"
+
+ sed -r -i -e 's/subsql([^\.]|$)/subsql-gdb\1/' ${mf}
+
+ emake || die "compilation failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ dodoc CHANGES
+ use doc && dohtml GigaBASE.htm
+ use doc && dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ elog "The subsql binary has been renamed to subsql-gdb,"
+ elog "to avoid a name clash with the FastDB version of subsql"
+ echo
+ ewarn "Content of indices created by old (<=3.42) version of GigaBASE with"
+ ewarn "USE_LOCALE_SETTINGS enabled and using non-standard locale will be"
+ ewarn "different with format used by version 3.43 and higher. So you will"
+ ewarn "have to recreate indices in this case."
+}