summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-02-14 21:17:33 +0000
committerPeter Volkov <pva@gentoo.org>2008-02-14 21:17:33 +0000
commit854804e5b61be5575b9a9ad13aed902cf1ba6a87 (patch)
treecc3127a527f90ef80483c9dbb936c295991cb69d /dev-db/gigabase
parentamd64 stable wrt bug #156079 (diff)
downloadgentoo-2-854804e5b61be5575b9a9ad13aed902cf1ba6a87.tar.gz
gentoo-2-854804e5b61be5575b9a9ad13aed902cf1ba6a87.tar.bz2
gentoo-2-854804e5b61be5575b9a9ad13aed902cf1ba6a87.zip
Version bump.
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-db/gigabase')
-rw-r--r--dev-db/gigabase/ChangeLog9
-rw-r--r--dev-db/gigabase/gigabase-3.62.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/dev-db/gigabase/ChangeLog b/dev-db/gigabase/ChangeLog
index 8431fbac54a3..8614640aebea 100644
--- a/dev-db/gigabase/ChangeLog
+++ b/dev-db/gigabase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/gigabase
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/ChangeLog,v 1.31 2007/12/19 19:37:33 drac Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/ChangeLog,v 1.32 2008/02/14 21:17:33 pva Exp $
+
+*gigabase-3.62 (14 Feb 2008)
+
+ 14 Feb 2008; <pva@gentoo.org> +gigabase-3.62.ebuild:
+ Version bump.
19 Dec 2007; Samuli Suominen <drac@gentoo.org> gigabase-3.61.ebuild:
amd64 stable wrt #201840, run eautoreconf to fix libtool & asneeded issues.
diff --git a/dev-db/gigabase/gigabase-3.62.ebuild b/dev-db/gigabase/gigabase-3.62.ebuild
new file mode 100644
index 000000000000..dbadf37919ed
--- /dev/null
+++ b/dev-db/gigabase/gigabase-3.62.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/gigabase-3.62.ebuild,v 1.1 2008/02/14 21:17:33 pva Exp $
+
+inherit autotools eutils multilib
+
+DESCRIPTION="OO-DBMS with interfaces for C/C++/Java/PHP/Perl"
+HOMEPAGE="http://www.garret.ru/~knizhnik/gigabase.html"
+SRC_URI="mirror://sourceforge/gigabase/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~s390 ~x86"
+IUSE="doc"
+DEPEND=""
+
+S=${WORKDIR}/gigabase
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ mf="${S}/Makefile"
+
+ econf || die "econf failed"
+
+ sed -r -i -e 's/subsql([^\.]|$)/subsql-gdb\1/' ${mf}
+
+ emake || die "compilation failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ dodoc CHANGES
+ use doc && dohtml GigaBASE.htm
+ use doc && dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ elog "The subsql binary has been renamed to subsql-gdb,"
+ elog "to avoid a name clash with the FastDB version of subsql"
+ echo
+ ewarn "Content of indices created by old (<=3.42) version of GigaBASE with"
+ ewarn "USE_LOCALE_SETTINGS enabled and using non-standard locale will be"
+ ewarn "different with format used by version 3.43 and higher. So you will"
+ ewarn "have to recreate indices in this case."
+}