summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimone Gotti <motaboy@gentoo.org>2004-12-09 13:59:02 +0000
committerSimone Gotti <motaboy@gentoo.org>2004-12-09 13:59:02 +0000
commitd69f96b59dfb6b80903eecbb73639438e5f93465 (patch)
treea7f35672fe33ebb1e78cba22916bdecb3636b464 /dev-db/hk_classes
parentStable on hppa. (Manifest recommit) (diff)
downloadgentoo-2-d69f96b59dfb6b80903eecbb73639438e5f93465.tar.gz
gentoo-2-d69f96b59dfb6b80903eecbb73639438e5f93465.tar.bz2
gentoo-2-d69f96b59dfb6b80903eecbb73639438e5f93465.zip
Use the patch I sent to the author to selectively choose the db plugins to compile depending on the useflag status instead of compiling the plugin also if the flag is disabled but the DB is installed.
Diffstat (limited to 'dev-db/hk_classes')
-rw-r--r--dev-db/hk_classes/ChangeLog10
-rw-r--r--dev-db/hk_classes/Manifest2
-rw-r--r--dev-db/hk_classes/files/digest-hk_classes-0.7.2-r13
-rw-r--r--dev-db/hk_classes/hk_classes-0.7.2-r1.ebuild48
4 files changed, 62 insertions, 1 deletions
diff --git a/dev-db/hk_classes/ChangeLog b/dev-db/hk_classes/ChangeLog
index 16d875732ba5..6bc40fa957ff 100644
--- a/dev-db/hk_classes/ChangeLog
+++ b/dev-db/hk_classes/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-db/hk_classes
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hk_classes/ChangeLog,v 1.26 2004/12/07 00:47:10 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hk_classes/ChangeLog,v 1.27 2004/12/09 13:59:02 motaboy Exp $
+
+*hk_classes-0.7.2-r1 (09 Dec 2004)
+
+ 09 Dec 2004; Simone Gotti <motaboy@gentoo.org>
+ +hk_classes-0.7.2-r1.ebuild:
+ Use the patch I sent to the author to selectively choose the db plugins to
+ compile depending on the useflag status instead of compiling the plugin also
+ if the flag is disabled but the DB is installed.
*hk_classes-0.7.2 (06 Dec 2004)
diff --git a/dev-db/hk_classes/Manifest b/dev-db/hk_classes/Manifest
index daf818438723..7343c85c9a58 100644
--- a/dev-db/hk_classes/Manifest
+++ b/dev-db/hk_classes/Manifest
@@ -1,9 +1,11 @@
MD5 ca08a6d84c496ac6a05c407400365dee hk_classes-0.7.2.ebuild 1197
+MD5 7b46ee18ed6eb7117903749d85e22d94 hk_classes-0.7.2-r1.ebuild 1251
MD5 d3f84e0d788c00d119bd13c3ae90713e hk_classes-0.6.2a.ebuild 1645
MD5 7f4424bc053df3dccf12d3f64cb5c8a2 hk_classes-0.7.1.ebuild 1147
MD5 f2adc94bb9ed47a2bae3e1f714d01dac hk_classes-0.7.ebuild 1101
MD5 c7e68cf240c58cd0ee60ffed87326b34 ChangeLog 4064
MD5 1b6808bbd78c9161f8b7efb090d966f8 metadata.xml 162
+MD5 9a8287b2b5ae901849742e71aed36a1b files/digest-hk_classes-0.7.2-r1 198
MD5 85913ee0452ca03c30bc07640aa4926e files/digest-hk_classes-0.7.1 198
MD5 9a8287b2b5ae901849742e71aed36a1b files/digest-hk_classes-0.7.2 198
MD5 567cad53853adfda1ae7f205966523a8 files/digest-hk_classes-0.6.2a 198
diff --git a/dev-db/hk_classes/files/digest-hk_classes-0.7.2-r1 b/dev-db/hk_classes/files/digest-hk_classes-0.7.2-r1
new file mode 100644
index 000000000000..d59b795f5ba9
--- /dev/null
+++ b/dev-db/hk_classes/files/digest-hk_classes-0.7.2-r1
@@ -0,0 +1,3 @@
+MD5 e7a9210791432a2458e7e174d84d5a0a hk_classes-0.7.2.tar.bz2 536903
+MD5 74fc61d361e2bef8e747a49210aee94a knodapython.tar.bz2 428940
+MD5 074f486c5d7da5fa74445573396617c0 hk_docs-0.7.tar.bz2 2930613
diff --git a/dev-db/hk_classes/hk_classes-0.7.2-r1.ebuild b/dev-db/hk_classes/hk_classes-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..3212aa0a2129
--- /dev/null
+++ b/dev-db/hk_classes/hk_classes-0.7.2-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hk_classes/hk_classes-0.7.2-r1.ebuild,v 1.1 2004/12/09 13:59:02 motaboy Exp $
+
+inherit eutils
+
+P_DOCS="hk_docs-0.7"
+
+MY_P=${P/_alpha/-test}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="GUI-independent C++ libraries for database applications, including API documentation and tutorials."
+HOMEPAGE="http://hk-classes.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hk-classes/${MY_P}.tar.bz2
+ mirror://sourceforge/knoda/knodapython.tar.bz2
+ mirror://sourceforge/knoda/${P_DOCS}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="mysql postgres sqlite sqlite3 odbc doc"
+
+# At least one of the following is required
+DEPEND="mysql? ( >=dev-db/mysql-3.23.54a )
+ postgres? ( >=dev-db/postgresql-7.3 )
+ sqlite? ( =dev-db/sqlite-2* )
+ sqlite3? ( =dev-db/sqlite-3* )
+ odbc? ( >=dev-db/unixODBC-2.0.6 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-amd64.patch
+}
+
+src_compile() {
+ myconf="$myconf `use_with mysql` `use_with postgres` `use_with odbc` `use_with sqlite` `use_with sqlite3`"
+
+ econf $myconf || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ use doc && dohtml -r ${WORKDIR}/${P_DOCS}/*
+ use doc && dohtml -r ${WORKDIR}/knodapythondoc
+ make DESTDIR=${D} install || die
+}