summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-01-16 09:42:33 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-01-16 09:42:33 +0000
commit701e60453b8fcf161a56ec88fd602ddf4e42b8ca (patch)
treef5a6bcf7b0cffe0fb03702dec3f35865c3b9779e /dev-db/kyotocabinet
parentx86 stable wrt bug #351488 (diff)
downloadgentoo-2-701e60453b8fcf161a56ec88fd602ddf4e42b8ca.tar.gz
gentoo-2-701e60453b8fcf161a56ec88fd602ddf4e42b8ca.tar.bz2
gentoo-2-701e60453b8fcf161a56ec88fd602ddf4e42b8ca.zip
Bump for #351340, thanks to jbergstroem
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/kyotocabinet')
-rw-r--r--dev-db/kyotocabinet/ChangeLog9
-rw-r--r--dev-db/kyotocabinet/kyotocabinet-1.2.34.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-db/kyotocabinet/ChangeLog b/dev-db/kyotocabinet/ChangeLog
index 24bad36c2d42..5162030884bf 100644
--- a/dev-db/kyotocabinet/ChangeLog
+++ b/dev-db/kyotocabinet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/kyotocabinet
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.5 2010/12/19 20:42:27 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.6 2011/01/16 09:42:33 patrick Exp $
+
+*kyotocabinet-1.2.34 (16 Jan 2011)
+
+ 16 Jan 2011; Patrick Lauer <patrick@gentoo.org> +kyotocabinet-1.2.34.ebuild:
+ Bump for #351340, thanks to jbergstroem
*kyotocabinet-1.2.30 (19 Dec 2010)
diff --git a/dev-db/kyotocabinet/kyotocabinet-1.2.34.ebuild b/dev-db/kyotocabinet/kyotocabinet-1.2.34.ebuild
new file mode 100644
index 000000000000..9014896ddd14
--- /dev/null
+++ b/dev-db/kyotocabinet/kyotocabinet-1.2.34.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/kyotocabinet-1.2.34.ebuild,v 1.1 2011/01/16 09:42:33 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A straightforward implementation of DBM"
+HOMEPAGE="http://fallabs.com/kyotocabinet/"
+SRC_URI="${HOMEPAGE}pkg/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="debug doc examples"
+
+DEPEND="sys-libs/zlib
+ app-arch/xz-utils"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_rpath-1.2.4.patch"
+ sed -ie "/ldconfig/d" Makefile.in
+ sed -ie "/DOCDIR/d" Makefile.in
+}
+
+src_configure() {
+ econf $(use_enable debug) --enable-lzma --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ if use examples; then
+ insinto /usr/share/${PF}/example
+ doins example/* || die "Install failed"
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/* || die "Install failed"
+ fi
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+} \ No newline at end of file