summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-12-10 23:47:50 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-12-10 23:47:50 +0000
commit782360c16076f021941410e35a2870d9439a1e07 (patch)
tree0a092d763070e3da14ece6067a179267695a45f3 /dev-db/kyotocabinet
parentChange dep to virtual/jpeg (bug #347971). (diff)
downloadgentoo-2-782360c16076f021941410e35a2870d9439a1e07.tar.gz
gentoo-2-782360c16076f021941410e35a2870d9439a1e07.tar.bz2
gentoo-2-782360c16076f021941410e35a2870d9439a1e07.zip
Bump for #347849, thanks to jbergstroem
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/kyotocabinet')
-rw-r--r--dev-db/kyotocabinet/ChangeLog8
-rw-r--r--dev-db/kyotocabinet/files/remove_docinst-1.2.29.patch13
-rw-r--r--dev-db/kyotocabinet/kyotocabinet-1.2.29.ebuild48
3 files changed, 68 insertions, 1 deletions
diff --git a/dev-db/kyotocabinet/ChangeLog b/dev-db/kyotocabinet/ChangeLog
index 676f96c2d806..ec11d78d090a 100644
--- a/dev-db/kyotocabinet/ChangeLog
+++ b/dev-db/kyotocabinet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/kyotocabinet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.3 2010/11/24 15:08:15 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.4 2010/12/10 23:47:50 patrick Exp $
+
+*kyotocabinet-1.2.29 (10 Dec 2010)
+
+ 10 Dec 2010; Patrick Lauer <patrick@gentoo.org> +kyotocabinet-1.2.29.ebuild,
+ +files/remove_docinst-1.2.29.patch:
+ Bump for #347849, thanks to jbergstroem
*kyotocabinet-1.2.25 (24 Nov 2010)
diff --git a/dev-db/kyotocabinet/files/remove_docinst-1.2.29.patch b/dev-db/kyotocabinet/files/remove_docinst-1.2.29.patch
new file mode 100644
index 000000000000..9ad7934def6d
--- /dev/null
+++ b/dev-db/kyotocabinet/files/remove_docinst-1.2.29.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index 1bf1946..f229fe6 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -121,8 +121,6 @@ install :
+ cp -Rf $(COMMANDFILES) $(DESTDIR)$(BINDIR)
+ mkdir -p $(DESTDIR)$(MAN1DIR)
+ cd man && cp -Rf $(MAN1FILES) $(DESTDIR)$(MAN1DIR)
+- mkdir -p $(DESTDIR)$(DOCDIR)
+- cp -Rf $(DOCUMENTFILES) $(DESTDIR)$(DOCDIR)
+ mkdir -p $(DESTDIR)$(PCDIR)
+ cp -Rf $(PCFILES) $(DESTDIR)$(PCDIR)
+ -[ "$$UID" = 0 ] && PATH=/sbin:/usr/sbin:$(PATH) ldconfig 2>/dev/null || true
diff --git a/dev-db/kyotocabinet/kyotocabinet-1.2.29.ebuild b/dev-db/kyotocabinet/kyotocabinet-1.2.29.ebuild
new file mode 100644
index 000000000000..ea10da8d0bec
--- /dev/null
+++ b/dev-db/kyotocabinet/kyotocabinet-1.2.29.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/kyotocabinet-1.2.29.ebuild,v 1.1 2010/12/10 23:47:50 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A straightforward implementation of DBM"
+HOMEPAGE="http://fallabs.com/kyotocabinet/"
+SRC_URI="${HOMEPAGE}pkg/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="debug doc examples"
+
+DEPEND="sys-libs/zlib
+ app-arch/xz-utils"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_rpath-1.2.4.patch"
+ epatch "${FILESDIR}/remove_ldconfig-1.2.4.patch"
+ epatch "${FILESDIR}/remove_docinst-${PV}.patch"
+}
+
+src_configure() {
+ econf $(use_enable debug) --enable-lzma
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ if use examples; then
+ insinto /usr/share/${PF}/example
+ doins example/* || die "Install failed"
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/* || die "Install failed"
+ fi
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}