summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-21 01:24:05 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-21 01:24:05 +0000
commit8be70cc6c004dbcaea092ab05ceb675b55f20d5a (patch)
tree178400407d1da39581a9e19d1328a12f276e0d9c /dev-db/kyotocabinet
parentOnly depend on net-tools with client USE flag enabled (it's used by the dhcli... (diff)
downloadgentoo-2-8be70cc6c004dbcaea092ab05ceb675b55f20d5a.tar.gz
gentoo-2-8be70cc6c004dbcaea092ab05ceb675b55f20d5a.tar.bz2
gentoo-2-8be70cc6c004dbcaea092ab05ceb675b55f20d5a.zip
Bump for #409071
(Portage version: 2.2.0_alpha93/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/kyotocabinet')
-rw-r--r--dev-db/kyotocabinet/ChangeLog7
-rw-r--r--dev-db/kyotocabinet/kyotocabinet-1.2.74.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-db/kyotocabinet/ChangeLog b/dev-db/kyotocabinet/ChangeLog
index eb3a6ab6bb83..ad966f966f5d 100644
--- a/dev-db/kyotocabinet/ChangeLog
+++ b/dev-db/kyotocabinet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/kyotocabinet
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.15 2012/03/12 06:06:42 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.16 2012/03/21 01:24:05 patrick Exp $
+
+*kyotocabinet-1.2.74 (21 Mar 2012)
+
+ 21 Mar 2012; Patrick Lauer <patrick@gentoo.org> +kyotocabinet-1.2.74.ebuild:
+ Bump for #409071
*kyotocabinet-1.2.73 (12 Mar 2012)
diff --git a/dev-db/kyotocabinet/kyotocabinet-1.2.74.ebuild b/dev-db/kyotocabinet/kyotocabinet-1.2.74.ebuild
new file mode 100644
index 000000000000..600c76718219
--- /dev/null
+++ b/dev-db/kyotocabinet/kyotocabinet-1.2.74.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/kyotocabinet-1.2.74.ebuild,v 1.1 2012/03/21 01:24:05 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A straightforward implementation of DBM"
+HOMEPAGE="http://fallabs.com/kyotocabinet/"
+SRC_URI="${HOMEPAGE}pkg/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="debug doc examples static-libs"
+
+DEPEND="sys-libs/zlib
+ app-arch/xz-utils"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_configure-1.2.62.patch"
+ sed -ie "/ldconfig/d" Makefile.in
+ sed -ie "/DOCDIR/d" Makefile.in
+}
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_enable static-libs static) \
+ $(use_enable !static-libs shared) \
+ --enable-lzma --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ use static-libs || find "${D}" \( -name '*.a' -or -name '*.la' \) -delete
+
+ if use examples; then
+ insinto /usr/share/${PF}/example
+ doins example/* || die "Install failed"
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/* || die "Install failed"
+ fi
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}