summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-10-10 00:24:47 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-10-10 00:24:47 +0000
commit11aa047e56262c3516f6ad7be1afe62961b97bef (patch)
tree9aabad5a8659c3352b9c3810b44f6db487ae4009 /dev-db/libdbi
parentBump to 0.4.7.11 and remove 0.4.7.10 as requested by ferringb. (diff)
downloadgentoo-2-11aa047e56262c3516f6ad7be1afe62961b97bef.tar.gz
gentoo-2-11aa047e56262c3516f6ad7be1afe62961b97bef.tar.bz2
gentoo-2-11aa047e56262c3516f6ad7be1afe62961b97bef.zip
Make documentation build properly optional instead of dependant on system contents.
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-rc1-10246-gca5de40 x86_64)
Diffstat (limited to 'dev-db/libdbi')
-rw-r--r--dev-db/libdbi/ChangeLog7
-rw-r--r--dev-db/libdbi/files/libdbi-0.8.3-doc-build-fix.patch15
-rw-r--r--dev-db/libdbi/libdbi-0.8.3.ebuild9
3 files changed, 26 insertions, 5 deletions
diff --git a/dev-db/libdbi/ChangeLog b/dev-db/libdbi/ChangeLog
index f4a7874303c7..ebe189df00ff 100644
--- a/dev-db/libdbi/ChangeLog
+++ b/dev-db/libdbi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/libdbi
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi/ChangeLog,v 1.22 2008/10/05 21:12:19 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi/ChangeLog,v 1.23 2008/10/10 00:24:46 robbat2 Exp $
+
+ 10 Oct 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/libdbi-0.8.3-doc-build-fix.patch, libdbi-0.8.3.ebuild:
+ Make documentation build properly optional instead of dependant on system
+ contents.
05 Oct 2008; Diego Pettenò <flameeyes@gentoo.org> libdbi-0.8.3.ebuild:
Fix build-time dependencies.
diff --git a/dev-db/libdbi/files/libdbi-0.8.3-doc-build-fix.patch b/dev-db/libdbi/files/libdbi-0.8.3-doc-build-fix.patch
new file mode 100644
index 000000000000..831d6d25c2b7
--- /dev/null
+++ b/dev-db/libdbi/files/libdbi-0.8.3-doc-build-fix.patch
@@ -0,0 +1,15 @@
+diff -Nuar libdbi-0.8.3.orig/configure.in libdbi-0.8.3/configure.in
+--- libdbi-0.8.3.orig/configure.in 2008-10-09 17:09:09.303141877 -0700
++++ libdbi-0.8.3/configure.in 2008-10-09 17:10:48.100635797 -0700
+@@ -149,7 +149,8 @@
+-ac_docs="YES"
++ac_docs="no"
+ AC_ARG_ENABLE(docs,
+ [ --disable-docs do not build and install the documentation.],
+- [ ac_docs="NO" ])
++ [ ac_docs="$enableval" ],
++ [ ac_docs="no" ])
+
+-if test "$ac_docs" = "YES"; then
++if test "$ac_docs" = "yes"; then
+ dnl AC_PATH_PROGS(myjade, openjade jade)
diff --git a/dev-db/libdbi/libdbi-0.8.3.ebuild b/dev-db/libdbi/libdbi-0.8.3.ebuild
index bf732c8cd2d9..184b8645d16a 100644
--- a/dev-db/libdbi/libdbi-0.8.3.ebuild
+++ b/dev-db/libdbi/libdbi-0.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi/libdbi-0.8.3.ebuild,v 1.3 2008/10/05 21:12:19 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi/libdbi-0.8.3.ebuild,v 1.4 2008/10/10 00:24:46 robbat2 Exp $
inherit eutils autotools multilib
@@ -11,10 +11,10 @@ LICENSE="LGPL-2.1"
RDEPEND="virtual/libc"
DEPEND=">=sys-apps/sed-4
dev-util/pkgconfig
- app-text/openjade
+ doc? ( app-text/openjade )
${RDEPEND}"
PDEPEND=">=dev-db/libdbi-drivers-0.8.3"
-IUSE=""
+IUSE="doc"
KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
SLOT=0
@@ -24,6 +24,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/libdbi-0.8.1-pkg-config.patch
cp -f "${FILESDIR}"/dbi.pc.in "${S}"/dbi.pc.in
+ epatch "${FILESDIR}"/libdbi-0.8.3-doc-build-fix.patch
# configure.in has been changed
eautoreconf || die "eautoreconf failed"
@@ -32,7 +33,7 @@ src_unpack() {
src_compile() {
# should append CFLAGS, not replace them
sed -i.orig -e 's/^CFLAGS = /CFLAGS += /g' src/Makefile.in
- econf || die "econf failed"
+ econf $(use_enable doc docs) || die "econf failed"
emake || die "emake failed"
}