summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-03-19 14:07:59 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-03-19 14:07:59 +0000
commit841a002ad000517a4a998e3b679886a4e105d4a5 (patch)
treeff55f54ced34eebc4b453e4be3af3964e86c6f46 /dev-db/libdrizzle
parentDep on <python3 and change sheband to strictly use python2 as package doesn't... (diff)
downloadgentoo-2-841a002ad000517a4a998e3b679886a4e105d4a5.tar.gz
gentoo-2-841a002ad000517a4a998e3b679886a4e105d4a5.tar.bz2
gentoo-2-841a002ad000517a4a998e3b679886a4e105d4a5.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/libdrizzle')
-rw-r--r--dev-db/libdrizzle/ChangeLog8
-rw-r--r--dev-db/libdrizzle/libdrizzle-0.8.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-db/libdrizzle/ChangeLog b/dev-db/libdrizzle/ChangeLog
index abd0ae28a206..978511a34627 100644
--- a/dev-db/libdrizzle/ChangeLog
+++ b/dev-db/libdrizzle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/libdrizzle
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdrizzle/ChangeLog,v 1.3 2010/01/13 09:59:57 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdrizzle/ChangeLog,v 1.4 2010/03/19 14:07:59 flameeyes Exp $
+
+*libdrizzle-0.8 (19 Mar 2010)
+
+ 19 Mar 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +libdrizzle-0.8.ebuild:
+ Version bump.
*libdrizzle-0.7 (13 Jan 2010)
diff --git a/dev-db/libdrizzle/libdrizzle-0.8.ebuild b/dev-db/libdrizzle/libdrizzle-0.8.ebuild
new file mode 100644
index 000000000000..3e1d659730c3
--- /dev/null
+++ b/dev-db/libdrizzle/libdrizzle-0.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdrizzle/libdrizzle-0.8.ebuild,v 1.1 2010/03/19 14:07:59 flameeyes Exp $
+
+EAPI=2
+
+DESCRIPTION="a C client and protocol library for the Drizzle project"
+HOMEPAGE="http://launchpad.net/libdrizzle"
+SRC_URI="http://launchpad.net/libdrizzle/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug tcmalloc +sqlite static-libs"
+
+RDEPEND="tcmalloc? ( dev-util/google-perftools )
+ sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # Don't ever use --enable-assert since configure.ac is broken, and
+ # only does --disable-assert correctly.
+ if use debug; then
+ # Since --with-debug would turn off optimisations as well as
+ # enabling debug, we just enable debug through the
+ # preprocessor then.
+ append-flags -DDEBUG
+
+ # Right now disabling asserts break the code, so never disable
+ # them as it is.
+ #else
+ # myconf="${myconf} --disable-assert"
+ fi
+
+ econf \
+ --disable-static \
+ --disable-dependency-tracking \
+ --disable-mtmalloc \
+ $(use_enable tcmalloc) \
+ $(use_enable libsqlite3)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS PROTOCOL README || die
+
+ find "${D}" -name '*.la' -delete || die
+}