summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2012-09-07 12:25:40 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2012-09-07 12:25:40 +0000
commitc7173d727f6e92f5e5937ba36048ad79f96942ba (patch)
treebfd0723cfea659dd4accb9cc57d8cc5ae242c1f8 /dev-db/libzdb
parentAdd net-misc/leechcraft-launchy and media-sound/leechcraft-hotstreams to depe... (diff)
downloadgentoo-2-c7173d727f6e92f5e5937ba36048ad79f96942ba.tar.gz
gentoo-2-c7173d727f6e92f5e5937ba36048ad79f96942ba.tar.bz2
gentoo-2-c7173d727f6e92f5e5937ba36048ad79f96942ba.zip
fix bug #251063
(Portage version: 2.1.11.12/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/libzdb')
-rw-r--r--dev-db/libzdb/ChangeLog7
-rw-r--r--dev-db/libzdb/libzdb-2.10.5.ebuild94
-rw-r--r--dev-db/libzdb/metadata.xml16
3 files changed, 111 insertions, 6 deletions
diff --git a/dev-db/libzdb/ChangeLog b/dev-db/libzdb/ChangeLog
index 67685a2c464f..46fd713d7bb5 100644
--- a/dev-db/libzdb/ChangeLog
+++ b/dev-db/libzdb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/libzdb
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libzdb/ChangeLog,v 1.2 2012/09/05 19:27:25 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libzdb/ChangeLog,v 1.3 2012/09/07 12:25:40 lordvan Exp $
+
+*libzdb-2.10.5 (07 Sep 2012)
+
+ 07 Sep 2012; <lordvan@gentoo.org> +libzdb-2.10.5.ebuild:
+ latest ebuild from bug #251063 Thanks Johan again
05 Sep 2012; <lordvan@gentoo.org> libzdb-2.10.3.ebuild,
+files/sqlite_configure.patch:
diff --git a/dev-db/libzdb/libzdb-2.10.5.ebuild b/dev-db/libzdb/libzdb-2.10.5.ebuild
new file mode 100644
index 000000000000..61f67cf17436
--- /dev/null
+++ b/dev-db/libzdb/libzdb-2.10.5.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libzdb/libzdb-2.10.5.ebuild,v 1.1 2012/09/07 12:25:40 lordvan Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A thread safe high level multi-database connection pool library"
+HOMEPAGE="http://www.tildeslash.com/libzdb/"
+SRC_URI="http://www.tildeslash.com/${PN}/dist/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug doc mysql postgres +sqlite +sqliteunlock ssl static-libs"
+REQUIRED_USE=" || ( postgres mysql sqlite )"
+
+RESTRICT=test
+
+RDEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( >=dev-db/sqlite-3 )
+ sqliteunlock? ( >=dev-db/sqlite-3.6.12[unlock-notify] )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ sed -i -e "s|&& ./pool||g" test/Makefile.in || die
+}
+
+src_configure() {
+ ## TODO: check what --enable-optimized actually does
+ ## TODO: find someone with oracle db to add oci8 support
+ myconf=""
+ if [[ $(gcc-version) < 4.1 ]];then
+ myconf="${myconf} --disable-protected"
+ else
+ myconf="${myconf} --enable-protected"
+ fi
+
+ if ( use sqlite ); then
+ myconf="${myconf} --with-sqlite=${EPREFIX}/usr/"
+ if has_version 'dev-db/sqlite[unlock-notify]'; then
+ myconf="${myconf} --enable-sqliteunlock"
+ fi
+ else
+ myconf="${myconf} --without-sqlite"
+ fi
+
+ if use mysql; then
+ myconf="${myconf} --with-mysql=${EPREFIX}/usr/bin/mysql_config"
+ else
+ myconf="${myconf} --without-mysql"
+ fi
+
+ if use postgres; then
+ myconf="${myconf} --with-postgresql=${EPREFIX}/usr/bin/pg_config"
+ else
+ myconf="${myconf} --without-postgresql"
+ fi
+
+ econf \
+ $(use_enable debug profiling) \
+ $(use_enable static-libs static) \
+ $(use_enable ssl openssl) \
+ --without-oci \
+ ${myconf}
+}
+
+src_compile() {
+ default_src_compile
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # the --disable-static flag only skips .a
+ use static-libs || rm -f "${D}"/usr/lib*/libzdb.la
+
+ dodoc AUTHORS CHANGES README
+ if use doc;then
+ dohtml -r "${S}/doc/api-docs"/*
+ fi
+}
+
+src_test() {
+ emake verify
+}
diff --git a/dev-db/libzdb/metadata.xml b/dev-db/libzdb/metadata.xml
index 9588cabe3a5e..9d071cf6b5a1 100644
--- a/dev-db/libzdb/metadata.xml
+++ b/dev-db/libzdb/metadata.xml
@@ -2,10 +2,16 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>no-herd</herd>
-<maintainer>
- <email>lordvan@gentoo.org</email>
-</maintainer>
-<use>
+ <maintainer>
+ <email>lordvan@gentoo.org</email>
+ <name>Thomas Raschbacher</name>
+ </maintainer>
+ <maintainer>
+ <email>bugs@bergstroem.nu</email>
+ <name>Johan Bergström</name>
+ <description>Proxy Maintainer. CC on bugs</description>
+ </maintainer>
+ <use>
<flag name="sqliteunlock">Enable SQLite unlock notification api</flag>
-</use>
+ </use>
</pkgmetadata>