summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-07-10 23:47:49 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-07-10 23:47:49 +0000
commitbdf4d353da9b6fa15caeac5cad38f54a7f3b1014 (patch)
tree369f8d24dd8c7e832a330627c7a67f218621e1e4 /dev-db/myodbc/myodbc-3.51.06.ebuild
parentwhitespace (diff)
downloadgentoo-2-bdf4d353da9b6fa15caeac5cad38f54a7f3b1014.tar.gz
gentoo-2-bdf4d353da9b6fa15caeac5cad38f54a7f3b1014.tar.bz2
gentoo-2-bdf4d353da9b6fa15caeac5cad38f54a7f3b1014.zip
Old versions don't work on newer unixODBC, so clean them up. Latest is stable anyway.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/myodbc/myodbc-3.51.06.ebuild')
-rw-r--r--dev-db/myodbc/myodbc-3.51.06.ebuild87
1 files changed, 0 insertions, 87 deletions
diff --git a/dev-db/myodbc/myodbc-3.51.06.ebuild b/dev-db/myodbc/myodbc-3.51.06.ebuild
deleted file mode 100644
index 05956b16cd37..000000000000
--- a/dev-db/myodbc/myodbc-3.51.06.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/myodbc/myodbc-3.51.06.ebuild,v 1.11 2007/01/31 13:46:14 genone Exp $
-
-MY_PN="MyODBC"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="ODBC driver for MySQL"
-HOMEPAGE="http://www.mysql.com/products/myodbc/"
-SRC_URI="mirror://mysql/Downloads/MyODBC3/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86"
-IUSE="debug doc static"
-RDEPEND=">=virtual/mysql-4.0 dev-db/unixODBC sys-devel/m4"
-# perl is required for building docs
-DEPEND="${RDEPEND} doc? ( dev-lang/perl )"
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
- local myconf="--enable-static"
- use static \
- && myconf="${myconf} --disable-shared" \
- || myconf="${myconf} --enable-shared"
-
- myconf="${myconf} `use_with doc docs` `use_with debug`"
-
- econf \
- --libexecdir=/usr/sbin \
- --sysconfdir=/etc/myodbc \
- --localstatedir=/var/lib/myodbc \
- --with-mysql-libs=/usr/lib/mysql \
- --with-mysql-includes=/usr/include/mysql \
- --with-odbc-ini=/etc/unixODBC/odbc.ini \
- --with-unixODBC=/usr \
- ${myconf} || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- into /usr
- einstall \
- libexecdir=${D}/usr/sbin \
- sysconfdir=${D}/etc/myodbc \
- localstatedir=${D}/var/lib/myodbc
- dodoc INSTALL RELEASE-NOTES README
-}
-
-pkg_config() {
- [ "${ROOT}" != "/" ] && \
- die "Sorry, non-standard \$ROOT setting is not supported :-("
-
- for i in odbc.ini odbcinst.ini; do
- einfo "Building $i"
- /usr/bin/m4 -D__PN__=${PN} -D__PF__=${PF} ${FILESDIR}/${i}.m4 >${T}/${i}
- done;
-
- local msg='MySQL ODBC driver'
- local drivers=$(/usr/bin/odbcinst -q -d)
- if echo $drivers | grep -vq "^\[${PN}\]$" ; then
- ebegin "Installing ${msg}"
- /usr/bin/odbcinst -i -d -f ${T}/odbcinst.ini
- rc=$?
- eend $rc
- [ $rc -ne 0 ] && die
- else
- einfo "Skipping already installed ${msg}"
- fi
-
- local sources=$(/usr/bin/odbcinst -q -s)
- msg='sample MySQL ODBC DSN'
- if echo $sources | grep -vq "^\[${PN}-test\]$"; then
- ebegin "Installing ${msg}"
- /usr/bin/odbcinst -i -s -l -f ${T}/odbc.ini
- rc=$?
- eend $rc
- [ $rc -ne 0 ] && die
- else
- einfo "Skipping already installed ${msg}"
- fi
-}
-
-pkg_postinst() {
- elog "If this is a new install, please run the following command"
- elog "to configure the MySQL ODBC drivers and sources:"
- elog "emerge --config =${CATEGORY}/${PF}"
-}