summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-01-10 21:16:53 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-01-10 21:16:53 +0000
commit1bfb8639b115e44ef18be37a1d25073b36822a93 (patch)
tree5034c789b72f1cb52c7b276ddc34f2153ed283cf /dev-db/mysql++/mysql++-1.7.26.ebuild
parentstable on x86 and remove old ebuild (Manifest recommit) (diff)
downloadgentoo-2-1bfb8639b115e44ef18be37a1d25073b36822a93.tar.gz
gentoo-2-1bfb8639b115e44ef18be37a1d25073b36822a93.tar.bz2
gentoo-2-1bfb8639b115e44ef18be37a1d25073b36822a93.zip
Bug #72069, a new upstream version finally (after 3 years), and we can now rip out all of the nasty patching.
Diffstat (limited to 'dev-db/mysql++/mysql++-1.7.26.ebuild')
-rw-r--r--dev-db/mysql++/mysql++-1.7.26.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-db/mysql++/mysql++-1.7.26.ebuild b/dev-db/mysql++/mysql++-1.7.26.ebuild
new file mode 100644
index 000000000000..680a18adefa5
--- /dev/null
+++ b/dev-db/mysql++/mysql++-1.7.26.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/mysql++-1.7.26.ebuild,v 1.1 2005/01/10 21:16:53 robbat2 Exp $
+
+inherit gcc eutils gnuconfig
+
+DESCRIPTION="C++ API interface to the MySQL database"
+# This is the download page but includes links to other places
+HOMEPAGE="http://www.mysql.org/downloads/api-mysql++.html"
+SRC_URI="http://www.tangentsoft.net/mysql++/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~hppa ~mips ~sparc ~ppc ~amd64"
+IUSE=""
+
+DEPEND=">=dev-db/mysql-4.0
+ >=sys-devel/gcc-3"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+}
+
+src_compile() {
+ gnuconfig_update
+ local myconf
+ # we want C++ exceptions turned on
+ myconf="--enable-exceptions"
+ # We do this because of the large number of header files installed to
+ # the include directory
+ # This is a breakage compared to previous versions that installed
+ # straight to /usr/include
+ myconf="${myconf} --includedir=/usr/include/mysql++"
+ # not including the directives to where MySQL is because it seems to
+ # find it just fine without
+
+ # force the cflags into place otherwise they get totally ignored by
+ # configure
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ econf ${myconf} || die "econf failed"
+
+ emake || die "unable to make"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ # install the docs and HTML pages
+ dodoc README LGPL
+ dodoc doc/*
+ dohtml doc/man-html/*
+ prepalldocs
+ warning_movedir
+}
+
+pkg_postinst() {
+ warning_movedir
+}
+
+warning_movedir() {
+ ewarn "The MySQL++ include directory has changed compared to previous"
+ ewarn "versions. It was previously /usr/include, but now it is"
+ ewarn "/usr/include/mysql++"
+}
+
+