summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-07-15 00:26:35 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-07-15 00:26:35 +0000
commit5f532468bcf6e6ae16abaef03e48f1139bba9daf (patch)
tree25b58e7c4e876eadf8800bd6b53647fbb0aa2e56 /dev-db/mysql/mysql-5.0.44-r1.ebuild
parentProvide sane default values for the SERVER_URI if it is not set. (diff)
downloadgentoo-2-5f532468bcf6e6ae16abaef03e48f1139bba9daf.tar.gz
gentoo-2-5f532468bcf6e6ae16abaef03e48f1139bba9daf.tar.bz2
gentoo-2-5f532468bcf6e6ae16abaef03e48f1139bba9daf.zip
Cleanup of src_test code so that the enterprise and community ebuilds can be very similar. Note that upstream has changed the testing procedures such that they will always fail if you use FEATURES=-userpriv.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'dev-db/mysql/mysql-5.0.44-r1.ebuild')
-rw-r--r--dev-db/mysql/mysql-5.0.44-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-db/mysql/mysql-5.0.44-r1.ebuild b/dev-db/mysql/mysql-5.0.44-r1.ebuild
new file mode 100644
index 000000000000..da67d205a11f
--- /dev/null
+++ b/dev-db/mysql/mysql-5.0.44-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.44-r1.ebuild,v 1.1 2007/07/15 00:26:35 robbat2 Exp $
+
+MY_EXTRAS_VER="20070710"
+
+inherit toolchain-funcs mysql
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+# When MY_EXTRAS is bumped, the index should be revised to exclude these.
+EPATCH_EXCLUDE=''
+
+src_test() {
+ make check || die "make check failed"
+ if ! use "minimal" ; then
+ if ! hasq "userpriv" ${FEATURES} ; then
+ die "Testing with FEATURES=-userpriv is no longer supported by upstream"
+ fi
+ cd "${S}"
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus1
+ local retstatus2
+ local t
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # mysqladmin start before dir creation
+ mkdir -p "${S}"/mysql-test/var{,/log}
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+
+ case ${PV} in
+ 5.0.42)
+ mysql_disable_test "archive_gis" "Broken in 5.0.42" ;;
+
+ 5.0.44)
+ [ "$(tc-endian)" == "big" ] && \
+ mysql_disable_test "archive_gis" "Broken in 5.0.4[45] on big-endian boxes only" ;;
+
+ 5.0.45)
+ [ "$(tc-endian)" == "big" ] && \
+ mysql_disable_test "archive_gis" "Broken in 5.0.4[45] on big-endian boxes only" ;;
+ esac
+
+ # We run the test protocols seperately
+ make -j1 test-ns force=--force
+ retstatus1=$?
+ [[ $retstatus1 -eq 0 ]] || eerror "test-ns failed"
+
+ make -j1 test-ps force=--force
+ retstatus2=$?
+ [[ $retstatus2 -eq 0 ]] || eerror "test-ps failed"
+
+ # Cleanup is important for these testcases.
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ [[ $retstatus1 -eq 0 ]] || die "test-ns failed"
+ [[ $retstatus2 -eq 0 ]] || die "test-ps failed"
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}