summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-12-31 10:45:09 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-12-31 10:45:09 +0000
commita0264095d89e9af7f9f719f4c7d6f3e8777463fa (patch)
treeb82111184b3a62013090670fcc07734a55b9bd95 /dev-db/oracle-instantclient-jdbc
parentVersion bump (#293590) (diff)
downloadgentoo-2-a0264095d89e9af7f9f719f4c7d6f3e8777463fa.tar.gz
gentoo-2-a0264095d89e9af7f9f719f4c7d6f3e8777463fa.tar.bz2
gentoo-2-a0264095d89e9af7f9f719f4c7d6f3e8777463fa.zip
Version bump (#293590)
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/oracle-instantclient-jdbc')
-rw-r--r--dev-db/oracle-instantclient-jdbc/ChangeLog12
-rw-r--r--dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.0.2.ebuild52
-rw-r--r--dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.1.ebuild52
3 files changed, 114 insertions, 2 deletions
diff --git a/dev-db/oracle-instantclient-jdbc/ChangeLog b/dev-db/oracle-instantclient-jdbc/ChangeLog
index 573563691a18..9c0ac625a353 100644
--- a/dev-db/oracle-instantclient-jdbc/ChangeLog
+++ b/dev-db/oracle-instantclient-jdbc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-db/oracle-instantclient-jdbc
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/ChangeLog,v 1.25 2008/12/31 09:09:16 dertobi123 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/ChangeLog,v 1.26 2009/12/31 10:45:09 dertobi123 Exp $
+
+*oracle-instantclient-jdbc-11.2.0.1 (31 Dec 2009)
+*oracle-instantclient-jdbc-11.2.0.0.2 (31 Dec 2009)
+
+ 31 Dec 2009; Tobias Scherbaum <dertobi123@gentoo.org>
+ +oracle-instantclient-jdbc-11.2.0.0.2.ebuild,
+ +oracle-instantclient-jdbc-11.2.0.1.ebuild:
+ Version bump (#293590)
31 Dec 2008; Tobias Scherbaum <dertobi123@gentoo.org>
oracle-instantclient-jdbc-11.1.0.7.0.ebuild:
diff --git a/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.0.2.ebuild b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.0.2.ebuild
new file mode 100644
index 000000000000..2ce11d534950
--- /dev/null
+++ b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.0.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.0.2.ebuild,v 1.1 2009/12/31 10:45:09 dertobi123 Exp $
+
+inherit eutils
+
+MY_P_amd64="${PN/oracle-instantclient-/oracle-instantclient11.2-}-${PV}-1.x86_64"
+
+S="${WORKDIR}"
+DESCRIPTION="Oracle 11g client installation for Linux: JDBC supplement"
+HOMEPAGE="http://www.oracle.com/technology/tech/oci/instantclient/index.html"
+SRC_URI="amd64? ( ${MY_P_amd64}.zip )"
+
+LICENSE="OTN"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="fetch"
+IUSE=""
+
+RDEPEND=">=dev-db/oracle-instantclient-basic-${PV}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+pkg_setup() {
+ MY_P=MY_P_${ARCH}
+ export MY_P=${!MY_P}
+}
+
+pkg_nofetch() {
+ eerror "Please go to:"
+ eerror " ${HOMEPAGE}"
+ eerror "and download the JDBC supplemental package. Put it in:"
+ eerror " ${DISTDIR}"
+ eerror "after downloading it."
+}
+
+src_unpack() {
+ unzip "${DISTDIR}"/${MY_P}.zip
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)/oracle/${PV}/client/lib
+ cd "${S}"/instantclient_11_2
+ insinto /usr/$(get_libdir)/oracle/${PV}/client/lib
+ doins libheteroxa11.so orai18n.jar
+}
+
+pkg_postinst() {
+ elog "The JDBC supplement package for Oracle 11g has been installed."
+ elog "You may wish to install the oracle-instantclient-sqlplus (for "
+ elog "running the SQL*Plus application) package as well."
+}
diff --git a/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.1.ebuild b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.1.ebuild
new file mode 100644
index 000000000000..8d3217a53d20
--- /dev/null
+++ b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.2.0.1.ebuild,v 1.1 2009/12/31 10:45:09 dertobi123 Exp $
+
+inherit eutils
+
+MY_P_x86="${PN/oracle-/}-linux32-${PV}"
+
+S="${WORKDIR}"
+DESCRIPTION="Oracle 11g client installation for Linux: JDBC supplement"
+HOMEPAGE="http://www.oracle.com/technology/tech/oci/instantclient/index.html"
+SRC_URI="x86? ( ${MY_P_x86}.zip )"
+
+LICENSE="OTN"
+SLOT="0"
+KEYWORDS="-* ~x86"
+RESTRICT="fetch"
+IUSE=""
+
+RDEPEND=">=dev-db/oracle-instantclient-basic-${PV}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+pkg_setup() {
+ MY_P=MY_P_${ARCH}
+ export MY_P=${!MY_P}
+}
+
+pkg_nofetch() {
+ eerror "Please go to:"
+ eerror " ${HOMEPAGE}"
+ eerror "and download the JDBC supplemental package. Put it in:"
+ eerror " ${DISTDIR}"
+ eerror "after downloading it."
+}
+
+src_unpack() {
+ unzip "${DISTDIR}"/${MY_P}.zip
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)/oracle/${PV}/client/lib
+ cd "${S}"/instantclient_11_2
+ insinto /usr/$(get_libdir)/oracle/${PV}/client/lib
+ doins libheteroxa11.so orai18n.jar
+}
+
+pkg_postinst() {
+ elog "The JDBC supplement package for Oracle 11g has been installed."
+ elog "You may wish to install the oracle-instantclient-sqlplus (for "
+ elog "running the SQL*Plus application) package as well."
+}