summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-12-13 09:55:34 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-12-13 09:55:34 +0000
commit324259631eddabfacb788e7e46e976354af7ed13 (patch)
tree6be3ab9c5bebd234f45fa1cea9b8570aeb1c04af /dev-db/pgadmin3
parentVersion bump wrt bug #437690 (diff)
downloadgentoo-2-324259631eddabfacb788e7e46e976354af7ed13.tar.gz
gentoo-2-324259631eddabfacb788e7e46e976354af7ed13.tar.bz2
gentoo-2-324259631eddabfacb788e7e46e976354af7ed13.zip
Bump for #447074
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db/pgadmin3')
-rw-r--r--dev-db/pgadmin3/ChangeLog8
-rw-r--r--dev-db/pgadmin3/metadata.xml3
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.16.1.ebuild55
3 files changed, 65 insertions, 1 deletions
diff --git a/dev-db/pgadmin3/ChangeLog b/dev-db/pgadmin3/ChangeLog
index fb3fa8bb1256..50497d7232e3 100644
--- a/dev-db/pgadmin3/ChangeLog
+++ b/dev-db/pgadmin3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/pgadmin3
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.87 2012/11/08 11:15:01 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.88 2012/12/13 09:55:34 patrick Exp $
+
+*pgadmin3-1.16.1 (13 Dec 2012)
+
+ 13 Dec 2012; Patrick Lauer <patrick@gentoo.org> +pgadmin3-1.16.1.ebuild,
+ metadata.xml:
+ Bump for #447074
*pgadmin3-1.16.0 (08 Nov 2012)
diff --git a/dev-db/pgadmin3/metadata.xml b/dev-db/pgadmin3/metadata.xml
index d06e452b35af..b47a7d0a6763 100644
--- a/dev-db/pgadmin3/metadata.xml
+++ b/dev-db/pgadmin3/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>postgresql</herd>
+<use>
+ <flag name='database-designer'>Enable the Database Designer component</flag>
+</use>
</pkgmetadata>
diff --git a/dev-db/pgadmin3/pgadmin3-1.16.1.ebuild b/dev-db/pgadmin3/pgadmin3-1.16.1.ebuild
new file mode 100644
index 000000000000..d460401d07b7
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.16.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.16.1.ebuild,v 1.1 2012/12/13 09:55:34 patrick Exp $
+
+EAPI="4"
+
+WX_GTK_VER="2.8"
+
+inherit multilib versionator wxwidgets
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL."
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/${PN}/release/v${PV}/src/${P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE="debug +database-designer"
+
+DEPEND="x11-libs/wxGTK:2.8[X,debug=]
+ >=dev-db/postgresql-base-8.4.0
+ >=dev-libs/libxml2-2.6.18
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ local pgslot=$(postgresql-config show)
+
+ if [[ ${pgslot//.} < 84 ]] ; then
+ eerror "PostgreSQL slot must be set to 8.4 or higher."
+ eerror " postgresql-config set 8.4"
+ die "PostgreSQL slot is not set to 8.4 or higher."
+ fi
+}
+
+src_configure() {
+ econf --with-wx-version=2.8 \
+ $(use_enable debug) \
+ $(use_enable database-designer)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png
+
+ # icon location for the desktop file provided in pkg folder
+ insinto /usr/share/pgadmin3
+ doins "${S}/pgadmin/include/images/pgAdmin3.png"
+
+ domenu "${S}/pkg/pgadmin3.desktop"
+
+ # Fixing world-writable files
+ fperms -R go-w /usr/share
+}