summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2004-10-14 23:06:04 +0000
committerCarsten Lohrke <carlo@gentoo.org>2004-10-14 23:06:04 +0000
commitcfcde097a1afdfc00b7d39a1a6e4eb93d2af6f32 (patch)
treecd93912911132a4d9266e895468a890e9f5394fb /dev-db/rekall
parentAdding nvu to package.mask for testing version. See package.mask file for de... (diff)
downloadgentoo-2-cfcde097a1afdfc00b7d39a1a6e4eb93d2af6f32.tar.gz
gentoo-2-cfcde097a1afdfc00b7d39a1a6e4eb93d2af6f32.tar.bz2
gentoo-2-cfcde097a1afdfc00b7d39a1a6e4eb93d2af6f32.zip
gcc-3.4 patch, minor fixes
Diffstat (limited to 'dev-db/rekall')
-rw-r--r--dev-db/rekall/ChangeLog6
-rw-r--r--dev-db/rekall/files/rekall-2.2.1-gcc-3.4-compat.patch114
-rw-r--r--dev-db/rekall/rekall-2.2.1.ebuild15
3 files changed, 129 insertions, 6 deletions
diff --git a/dev-db/rekall/ChangeLog b/dev-db/rekall/ChangeLog
index 0887db340dd5..ed261a3d5959 100644
--- a/dev-db/rekall/ChangeLog
+++ b/dev-db/rekall/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/rekall
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/rekall/ChangeLog,v 1.5 2004/09/13 19:23:10 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/rekall/ChangeLog,v 1.6 2004/10/14 23:06:04 carlo Exp $
+
+ 15 Oct 2004; Carsten Lohrke <carlo@gentoo.org>
+ +files/rekall-2.2.1-gcc-3.4-compat.patch, rekall-2.2.1.ebuild:
+ gcc-3.4 patch, minor fixes
*rekall-2.2.1 (13 Sep 2004)
diff --git a/dev-db/rekall/files/rekall-2.2.1-gcc-3.4-compat.patch b/dev-db/rekall/files/rekall-2.2.1-gcc-3.4-compat.patch
new file mode 100644
index 000000000000..c7d49f645ecf
--- /dev/null
+++ b/dev-db/rekall/files/rekall-2.2.1-gcc-3.4-compat.patch
@@ -0,0 +1,114 @@
+--- libs/kbase/kb_options.cpp.orig 2004-10-14 16:46:56.000000000 +0200
++++ libs/kbase/kb_options.cpp 2004-10-14 16:48:28.000000000 +0200
+@@ -251,41 +251,41 @@
+ return kbOptions.value ; \
+ }
+
+-GETVALUE(uint, GridXStep, gridX ) ;
+-GETVALUE(uint, GridYStep, gridY ) ;
+-GETVALUE(uint, FormWidth, formW ) ;
+-GETVALUE(uint, FormHeight, formH ) ;
+-GETVALUE(int, DefaultDX, defDX ) ;
+-GETVALUE(int, DefaultDY, defDY ) ;
+-GETVALUE(uint, CtrlSpace, space ) ;
+-
+-GETVALUE(bool, UseMDI, useMdi ) ;
+-GETVALUE(bool, SingleDBOnly, singleDBOnly ) ;
+-
+-GETVALUE(uint, LeftMargin, marginL ) ;
+-GETVALUE(uint, RightMargin, marginR ) ;
+-GETVALUE(uint, TopMargin, marginT ) ;
+-GETVALUE(uint, BottomMargin, marginB ) ;
+-GETVALUE(uint, DPI, dpi ) ;
+-
+-GETVALUE(bool, OpenLast, openLast ) ;
+-GETVALUE(bool, DesignInches, designInches ) ;
+-GETVALUE(bool, TablesModal, tablesModal ) ;
+-GETVALUE(bool, FormsModal, formsModal ) ;
+-GETVALUE(bool, ReportsModal, reportsModal ) ;
+-GETVALUE(bool, QueriesModal, queriesModal ) ;
+-
+-GETVALUE(uint, LogMaxQueries, logMaxQueries ) ;
+-GETVALUE(uint, LogMaxEvents, logMaxEvents ) ;
+-GETVALUE(uint, LogMaxArgs, logMaxArgs ) ;
+-GETVALUE(uint, LogMaxArgLen, logMaxArgLen ) ;
+-
+-GETVALUE(KBOptions::ScriptType, ScriptType, scriptType ) ;
+-GETVALUE(KBOptions::MacroDebug, MacroDebug, macroDebug ) ;
+-
+-GETVALUE(KBOptions::VerifyOption, VerInsert, verInsert ) ;
+-GETVALUE(KBOptions::VerifyOption, VerUpdate, verUpdate ) ;
+-GETVALUE(KBOptions::VerifyOption, VerDelete, verDelete ) ;
+-GETVALUE(bool, VerMultiple, verMultiple ) ;
++GETVALUE(uint, GridXStep, gridX )
++GETVALUE(uint, GridYStep, gridY )
++GETVALUE(uint, FormWidth, formW )
++GETVALUE(uint, FormHeight, formH )
++GETVALUE(int, DefaultDX, defDX )
++GETVALUE(int, DefaultDY, defDY )
++GETVALUE(uint, CtrlSpace, space )
++
++GETVALUE(bool, UseMDI, useMdi )
++GETVALUE(bool, SingleDBOnly, singleDBOnly )
++
++GETVALUE(uint, LeftMargin, marginL )
++GETVALUE(uint, RightMargin, marginR )
++GETVALUE(uint, TopMargin, marginT )
++GETVALUE(uint, BottomMargin, marginB )
++GETVALUE(uint, DPI, dpi )
++
++GETVALUE(bool, OpenLast, openLast )
++GETVALUE(bool, DesignInches, designInches )
++GETVALUE(bool, TablesModal, tablesModal )
++GETVALUE(bool, FormsModal, formsModal )
++GETVALUE(bool, ReportsModal, reportsModal )
++GETVALUE(bool, QueriesModal, queriesModal )
++
++GETVALUE(uint, LogMaxQueries, logMaxQueries )
++GETVALUE(uint, LogMaxEvents, logMaxEvents )
++GETVALUE(uint, LogMaxArgs, logMaxArgs )
++GETVALUE(uint, LogMaxArgLen, logMaxArgLen )
++
++GETVALUE(KBOptions::ScriptType, ScriptType, scriptType )
++GETVALUE(KBOptions::MacroDebug, MacroDebug, macroDebug )
++
++GETVALUE(KBOptions::VerifyOption, VerInsert, verInsert )
++GETVALUE(KBOptions::VerifyOption, VerUpdate, verUpdate )
++GETVALUE(KBOptions::VerifyOption, VerDelete, verDelete )
++GETVALUE(bool, VerMultiple, verMultiple )
+
+-GETVALUE(QString, ScriptFont, scriptFont ) ;
++GETVALUE(QString, ScriptFont, scriptFont )
+--- libs/kbase/kb_draglist.h.orig 2004-10-14 17:21:21.000000000 +0200
++++ libs/kbase/kb_draglist.h 2004-10-14 17:21:43.000000000 +0200
+@@ -25,7 +25,7 @@
+
+ class LIBKBASE_API KBDragBox : public QListBox
+ {
+- Q_OBJECT ;
++ Q_OBJECT
+
+ int mouseDownAt ;
+ int mouseUpAt ;
+--- libs/kbase/kb_optionsdlg.h.orig 2004-10-14 17:38:25.000000000 +0200
++++ libs/kbase/kb_optionsdlg.h 2004-10-14 17:38:40.000000000 +0200
+@@ -302,7 +302,7 @@
+ /* */
+ class LIBKBASE_API KBOptionsDlg : public _KBDialog
+ {
+- Q_OBJECT ;
++ Q_OBJECT
+
+ #if ! __KB_EMBEDDED
+ QTextView m_blurb ;
+--- libs/common/kb_libloader_kde.h.orig 2004-10-14 22:48:37.000000000 +0200
++++ libs/common/kb_libloader_kde.h 2004-10-14 22:49:03.000000000 +0200
+@@ -233,7 +233,7 @@
+ { \
+ return new className ; \
+ } \
+- } ; \
++ } \
+ KInstance *className::s_instance = 0 ;
+
+
diff --git a/dev-db/rekall/rekall-2.2.1.ebuild b/dev-db/rekall/rekall-2.2.1.ebuild
index ab9f7c1b929e..ba0f352e83d2 100644
--- a/dev-db/rekall/rekall-2.2.1.ebuild
+++ b/dev-db/rekall/rekall-2.2.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/rekall/rekall-2.2.1.ebuild,v 1.1 2004/09/13 19:23:10 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/rekall/rekall-2.2.1.ebuild,v 1.2 2004/10/14 23:06:04 carlo Exp $
-inherit kde
+inherit kde eutils
DESCRIPTION="Rekall - a database frontend for MySQL, PostgreSQL and XBase"
HOMEPAGE="http://www.rekallrevealed.org/"
@@ -13,7 +13,8 @@ LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc"
IUSE="mysql odbc postgres xbase"
-DEPEND="virtual/python
+DEPEND="sys-apps/sed
+ virtual/python
mysql? ( >=dev-db/mysql-3.23.57-r1 )
postgres? ( >=dev-db/postgresql-7.3.4-r1 )
xbase? ( =dev-db/xbsql-0.11 )"
@@ -23,6 +24,12 @@ RDEPEND="virtual/python
xbase? ( =dev-db/xbsql-0.11 )"
need-kde 3
+src_unpack() {
+ kde_src_unpack
+ epatch ${FILESDIR}/${P}-gcc-3.4-compat.patch
+ sed -i -e 's/$(LN_S) $(kde_libs_htmldir)\/$(KDE_LANG)\/common/$(LN_S) common/' ${S}/doc/rekall/Makefile.in
+}
+
src_compile() {
myconf="--with-gui=kde \
`use_enable mysql` \
@@ -30,8 +37,6 @@ src_compile() {
`use_enable xbase` \
`use_enable odbc` \
`use_enable odbc iodbc`"
-
- sed -i -e 's/$(LN_S) $(kde_libs_htmldir)\/$(KDE_LANG)\/common/$(LN_S) common/' ${S}/doc/rekall/Makefile.in
kde_src_compile
}