summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-01-26 18:37:39 +0000
committerMike Gilbert <floppym@gentoo.org>2014-01-26 18:37:39 +0000
commit83311b2d4032dfaaac71294a3e8432dfa5664887 (patch)
tree8078adc371f0f04a872bcb0842845d7125e4be0b /dev-db/sqlite
parentRemoving stable keyword for sh/s390 (diff)
downloadgentoo-2-83311b2d4032dfaaac71294a3e8432dfa5664887.tar.gz
gentoo-2-83311b2d4032dfaaac71294a3e8432dfa5664887.tar.bz2
gentoo-2-83311b2d4032dfaaac71294a3e8432dfa5664887.zip
Remove old per Arfrever.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/ChangeLog7
-rw-r--r--dev-db/sqlite/sqlite-3.7.16.2.ebuild161
-rw-r--r--dev-db/sqlite/sqlite-3.7.17.ebuild161
-rw-r--r--dev-db/sqlite/sqlite-3.8.0.1.ebuild150
-rw-r--r--dev-db/sqlite/sqlite-3.8.0.2.ebuild150
-rw-r--r--dev-db/sqlite/sqlite-3.8.0.ebuild150
-rw-r--r--dev-db/sqlite/sqlite-3.8.1.ebuild159
7 files changed, 6 insertions, 932 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 2872e45f32c0..499fd905d102 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/sqlite
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.505 2014/01/26 12:22:21 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.506 2014/01/26 18:37:39 floppym Exp $
+
+ 26 Jan 2014; Mike Gilbert <floppym@gentoo.org> -sqlite-3.7.16.2.ebuild,
+ -sqlite-3.7.17.ebuild, -sqlite-3.8.0.1.ebuild, -sqlite-3.8.0.2.ebuild,
+ -sqlite-3.8.0.ebuild, -sqlite-3.8.1.ebuild:
+ Remove old per Arfrever.
26 Jan 2014; Agostino Sarubbo <ago@gentoo.org> sqlite-3.8.2.ebuild:
Stable for sparc, wrt bug #497736
diff --git a/dev-db/sqlite/sqlite-3.7.16.2.ebuild b/dev-db/sqlite/sqlite-3.7.16.2.ebuild
deleted file mode 100644
index f1ec9b3bd24d..000000000000
--- a/dev-db/sqlite/sqlite-3.7.16.2.ebuild
+++ /dev/null
@@ -1,161 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.7.16.2.ebuild,v 1.12 2013/05/20 17:58:44 ago Exp $
-
-EAPI="5"
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-SRC_PV="$(printf "%u%02u%02u%02u" $(get_version_components))"
-DOC_PV="${SRC_PV}"
-# DOC_PV="$(printf "%u%02u%02u00" $(get_version_components $(get_version_component_range 1-3)))"
-
-DESCRIPTION="A SQL Database Engine in a C Library"
-HOMEPAGE="http://sqlite.org/"
-SRC_URI="doc? ( http://sqlite.org/2013/${PN}-doc-${DOC_PV}.zip )
- tcl? ( http://sqlite.org/2013/${PN}-src-${SRC_PV}.zip )
- !tcl? (
- test? ( http://sqlite.org/2013/${PN}-src-${SRC_PV}.zip )
- !test? ( http://sqlite.org/2013/${PN}-autoconf-${SRC_PV}.tar.gz )
- )"
-
-LICENSE="public-domain"
-SLOT="3"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc +extensions icu +readline secure-delete static-libs tcl test"
-
-RDEPEND="icu? ( dev-libs/icu:= )
- readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl:= )"
-DEPEND="${RDEPEND}
- doc? ( app-arch/unzip )
- tcl? ( app-arch/unzip )
- test? (
- app-arch/unzip
- dev-lang/tcl
- )"
-
-amalgamation() {
- use !tcl && use !test
-}
-
-pkg_setup() {
- if amalgamation; then
- S="${WORKDIR}/${PN}-autoconf-${SRC_PV}"
- else
- S="${WORKDIR}/${PN}-src-${SRC_PV}"
- fi
-}
-
-src_prepare() {
- # At least ppc-aix, x86-interix and *-solaris need newer libtool.
- use prefix && eautoreconf
-
- if amalgamation; then
- epunt_cxx
- fi
-}
-
-src_configure() {
- # `configure` from amalgamation tarball does not add -DSQLITE_DEBUG or -DNDEBUG flag.
- if amalgamation; then
- if use debug; then
- append-cppflags -DSQLITE_DEBUG
- else
- append-cppflags -DNDEBUG
- fi
- fi
-
- # Support column metadata functions.
- # http://sqlite.org/c3ref/column_database_name.html
- # http://sqlite.org/c3ref/table_column_metadata.html
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # Support Full-Text Search versions 3 and 4.
- # http://sqlite.org/fts3.html
- append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_ENABLE_FTS4 -DSQLITE_ENABLE_FTS4_UNICODE61
-
- # Support R*Trees.
- # http://sqlite.org/rtree.html
- append-cppflags -DSQLITE_ENABLE_RTREE
-
- # Support soundex() function.
- # http://sqlite.org/lang_corefunc.html#soundex
- append-cppflags -DSQLITE_SOUNDEX
-
- # Support unlock notification.
- # http://sqlite.org/unlock_notify.html
- append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
-
- if use icu; then
- append-cppflags -DSQLITE_ENABLE_ICU
- if amalgamation; then
- sed -e "s/LIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- else
- sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- fi
- fi
-
- # Enable secure_delete pragma by default.
- # http://sqlite.org/pragma.html#pragma_secure_delete
- if use secure-delete; then
- append-cppflags -DSQLITE_SECURE_DELETE -DSQLITE_CHECK_PAGES -DSQLITE_CORE
- fi
-
- local extensions_option
- if amalgamation; then
- extensions_option="dynamic-extensions"
- else
- extensions_option="load-extension"
- fi
-
- # Starting from 3.6.23, SQLite has locking strategies that are specific to
- # OSX. By default they are enabled, and use semantics that only make sense
- # on OSX. However, they require gethostuuid() function for that, which is
- # only available on OSX starting from 10.6 (Snow Leopard). For earlier
- # versions of OSX we have to disable all this nifty locking options, as
- # suggested by upstream.
- if [[ "${CHOST}" == *-darwin[56789] ]]; then
- append-cppflags -DSQLITE_ENABLE_LOCKING_STYLE="0"
- fi
-
- if [[ "${CHOST}" == *-mint* ]]; then
- append-cppflags -DSQLITE_OMIT_WAL
- fi
-
- # `configure` from amalgamation tarball does not support
- # --with-readline-inc and --(enable|disable)-tcl options.
- econf \
- --enable-threadsafe \
- $(use_enable extensions ${extensions_option}) \
- $(use_enable readline) \
- $(use_enable static-libs static) \
- $(amalgamation || echo --with-readline-inc="-I${EPREFIX}/usr/include/readline") \
- $(amalgamation || use_enable debug) \
- $(amalgamation || echo --enable-tcl)
-}
-
-src_compile() {
- emake TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}"
-}
-
-src_test() {
- if [[ "${EUID}" -eq 0 ]]; then
- ewarn "Skipping tests due to root permissions"
- return
- fi
-
- emake $(use debug && echo fulltest || echo test)
-}
-
-src_install() {
- emake DESTDIR="${D}" HAVE_TCL="$(usex tcl 1 "")" TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" install
- prune_libtool_files
-
- doman sqlite3.1
-
- if use doc; then
- find "${WORKDIR}/${PN}-doc-${DOC_PV}" -name ".[_~]*" -delete
- dohtml -A ico,odg,pdf,svg -r "${WORKDIR}/${PN}-doc-${DOC_PV}/"
- fi
-}
diff --git a/dev-db/sqlite/sqlite-3.7.17.ebuild b/dev-db/sqlite/sqlite-3.7.17.ebuild
deleted file mode 100644
index 127f0c4544a5..000000000000
--- a/dev-db/sqlite/sqlite-3.7.17.ebuild
+++ /dev/null
@@ -1,161 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.7.17.ebuild,v 1.10 2013/09/06 18:36:03 ago Exp $
-
-EAPI="5"
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-SRC_PV="$(printf "%u%02u%02u%02u" $(get_version_components))"
-DOC_PV="${SRC_PV}"
-# DOC_PV="$(printf "%u%02u%02u00" $(get_version_components $(get_version_component_range 1-3)))"
-
-DESCRIPTION="A SQL Database Engine in a C Library"
-HOMEPAGE="http://sqlite.org/"
-SRC_URI="doc? ( http://sqlite.org/2013/${PN}-doc-${DOC_PV}.zip )
- tcl? ( http://sqlite.org/2013/${PN}-src-${SRC_PV}.zip )
- !tcl? (
- test? ( http://sqlite.org/2013/${PN}-src-${SRC_PV}.zip )
- !test? ( http://sqlite.org/2013/${PN}-autoconf-${SRC_PV}.tar.gz )
- )"
-
-LICENSE="public-domain"
-SLOT="3"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc +extensions icu +readline secure-delete static-libs tcl test"
-
-RDEPEND="icu? ( dev-libs/icu:= )
- readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl:= )"
-DEPEND="${RDEPEND}
- doc? ( app-arch/unzip )
- tcl? ( app-arch/unzip )
- test? (
- app-arch/unzip
- dev-lang/tcl
- )"
-
-amalgamation() {
- use !tcl && use !test
-}
-
-pkg_setup() {
- if amalgamation; then
- S="${WORKDIR}/${PN}-autoconf-${SRC_PV}"
- else
- S="${WORKDIR}/${PN}-src-${SRC_PV}"
- fi
-}
-
-src_prepare() {
- # At least ppc-aix, x86-interix and *-solaris need newer libtool.
- use prefix && eautoreconf
-
- if amalgamation; then
- epunt_cxx
- fi
-}
-
-src_configure() {
- # `configure` from amalgamation tarball does not add -DSQLITE_DEBUG or -DNDEBUG flag.
- if amalgamation; then
- if use debug; then
- append-cppflags -DSQLITE_DEBUG
- else
- append-cppflags -DNDEBUG
- fi
- fi
-
- # Support column metadata functions.
- # http://sqlite.org/c3ref/column_database_name.html
- # http://sqlite.org/c3ref/table_column_metadata.html
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # Support Full-Text Search versions 3 and 4.
- # http://sqlite.org/fts3.html
- append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_ENABLE_FTS4 -DSQLITE_ENABLE_FTS4_UNICODE61
-
- # Support R*Trees.
- # http://sqlite.org/rtree.html
- append-cppflags -DSQLITE_ENABLE_RTREE
-
- # Support soundex() function.
- # http://sqlite.org/lang_corefunc.html#soundex
- append-cppflags -DSQLITE_SOUNDEX
-
- # Support unlock notification.
- # http://sqlite.org/unlock_notify.html
- append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
-
- if use icu; then
- append-cppflags -DSQLITE_ENABLE_ICU
- if amalgamation; then
- sed -e "s/LIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- else
- sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- fi
- fi
-
- # Enable secure_delete pragma by default.
- # http://sqlite.org/pragma.html#pragma_secure_delete
- if use secure-delete; then
- append-cppflags -DSQLITE_SECURE_DELETE -DSQLITE_CHECK_PAGES -DSQLITE_CORE
- fi
-
- local extensions_option
- if amalgamation; then
- extensions_option="dynamic-extensions"
- else
- extensions_option="load-extension"
- fi
-
- # Starting from 3.6.23, SQLite has locking strategies that are specific to
- # OSX. By default they are enabled, and use semantics that only make sense
- # on OSX. However, they require gethostuuid() function for that, which is
- # only available on OSX starting from 10.6 (Snow Leopard). For earlier
- # versions of OSX we have to disable all this nifty locking options, as
- # suggested by upstream.
- if [[ "${CHOST}" == *-darwin[56789] ]]; then
- append-cppflags -DSQLITE_ENABLE_LOCKING_STYLE="0"
- fi
-
- if [[ "${CHOST}" == *-mint* ]]; then
- append-cppflags -DSQLITE_OMIT_WAL
- fi
-
- # `configure` from amalgamation tarball does not support
- # --with-readline-inc and --(enable|disable)-tcl options.
- econf \
- --enable-threadsafe \
- $(use_enable extensions ${extensions_option}) \
- $(use_enable readline) \
- $(use_enable static-libs static) \
- $(amalgamation || echo --with-readline-inc="-I${EPREFIX}/usr/include/readline") \
- $(amalgamation || use_enable debug) \
- $(amalgamation || echo --enable-tcl)
-}
-
-src_compile() {
- emake TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}"
-}
-
-src_test() {
- if [[ "${EUID}" -eq 0 ]]; then
- ewarn "Skipping tests due to root permissions"
- return
- fi
-
- emake $(use debug && echo fulltest || echo test)
-}
-
-src_install() {
- emake DESTDIR="${D}" HAVE_TCL="$(usex tcl 1 "")" TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" install
- prune_libtool_files
-
- doman sqlite3.1
-
- if use doc; then
- find "${WORKDIR}/${PN}-doc-${DOC_PV}" -name ".[_~]*" -delete
- dohtml -A ico,odg,pdf,svg -r "${WORKDIR}/${PN}-doc-${DOC_PV}/"
- fi
-}
diff --git a/dev-db/sqlite/sqlite-3.8.0.1.ebuild b/dev-db/sqlite/sqlite-3.8.0.1.ebuild
deleted file mode 100644
index 84a6ff88e9f5..000000000000
--- a/dev-db/sqlite/sqlite-3.8.0.1.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.8.0.1.ebuild,v 1.1 2013/09/01 06:10:18 floppym Exp $
-
-EAPI="5"
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-SRC_PV="$(printf "%u%02u%02u%02u" $(get_version_components))"
-DOC_PV="${SRC_PV}"
-# DOC_PV="$(printf "%u%02u%02u00" $(get_version_components $(get_version_component_range 1-3)))"
-
-DESCRIPTION="A SQL Database Engine in a C Library"
-HOMEPAGE="http://sqlite.org/"
-SRC_URI="doc? ( http://sqlite.org/2013/${PN}-doc-${DOC_PV}.zip )
- tcl? ( http://sqlite.org/2013/${PN}-src-${SRC_PV}.zip )
- !tcl? (
- test? ( http://sqlite.org/2013/${PN}-src-${SRC_PV}.zip )
- !test? ( http://sqlite.org/2013/${PN}-autoconf-${SRC_PV}.tar.gz )
- )"
-
-LICENSE="public-domain"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc icu +readline secure-delete static-libs tcl test"
-
-RDEPEND="icu? ( dev-libs/icu:= )
- readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl:= )"
-DEPEND="${RDEPEND}
- doc? ( app-arch/unzip )
- tcl? ( app-arch/unzip )
- test? (
- app-arch/unzip
- dev-lang/tcl
- )"
-
-amalgamation() {
- use !tcl && use !test
-}
-
-pkg_setup() {
- if amalgamation; then
- S="${WORKDIR}/${PN}-autoconf-${SRC_PV}"
- else
- S="${WORKDIR}/${PN}-src-${SRC_PV}"
- fi
-}
-
-src_prepare() {
- # At least ppc-aix, x86-interix and *-solaris need newer libtool.
- use prefix && eautoreconf
-}
-
-src_configure() {
- # `configure` from amalgamation tarball does not add -DSQLITE_DEBUG or -DNDEBUG flag.
- if amalgamation; then
- if use debug; then
- append-cppflags -DSQLITE_DEBUG
- else
- append-cppflags -DNDEBUG
- fi
- fi
-
- # Support column metadata functions.
- # http://sqlite.org/c3ref/column_database_name.html
- # http://sqlite.org/c3ref/table_column_metadata.html
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # Support Full-Text Search versions 3 and 4.
- # http://sqlite.org/fts3.html
- append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_ENABLE_FTS4 -DSQLITE_ENABLE_FTS4_UNICODE61
-
- # Support R*Trees.
- # http://sqlite.org/rtree.html
- append-cppflags -DSQLITE_ENABLE_RTREE
-
- # Support soundex() function.
- # http://sqlite.org/lang_corefunc.html#soundex
- append-cppflags -DSQLITE_SOUNDEX
-
- # Support unlock notification.
- # http://sqlite.org/unlock_notify.html
- append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
-
- if use icu; then
- append-cppflags -DSQLITE_ENABLE_ICU
- if amalgamation; then
- sed -e "s/LIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- else
- sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- fi
- fi
-
- # Enable secure_delete pragma.
- # http://sqlite.org/pragma.html#pragma_secure_delete
- if use secure-delete; then
- append-cppflags -DSQLITE_SECURE_DELETE -DSQLITE_CHECK_PAGES -DSQLITE_CORE
- fi
-
- # Starting from 3.6.23, SQLite has locking strategies that are specific to
- # OSX. By default they are enabled, and use semantics that only make sense
- # on OSX. However, they require gethostuuid() function for that, which is
- # only available on OSX starting from 10.6 (Snow Leopard). For earlier
- # versions of OSX we have to disable all this nifty locking options, as
- # suggested by upstream.
- if [[ "${CHOST}" == *-darwin[56789] ]]; then
- append-cppflags -DSQLITE_ENABLE_LOCKING_STYLE="0"
- fi
-
- if [[ "${CHOST}" == *-mint* ]]; then
- append-cppflags -DSQLITE_OMIT_WAL
- fi
-
- # `configure` from amalgamation tarball does not support
- # --with-readline-inc and --(enable|disable)-tcl options.
- econf \
- --enable-$(amalgamation && echo dynamic-extensions || echo load-extension) \
- --enable-threadsafe \
- $(use_enable readline) \
- $(use_enable static-libs static) \
- $(amalgamation || echo --with-readline-inc="-I${EPREFIX}/usr/include/readline") \
- $(amalgamation || use_enable debug) \
- $(amalgamation || echo --enable-tcl)
-}
-
-src_compile() {
- emake TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}"
-}
-
-src_test() {
- if [[ "${EUID}" -eq 0 ]]; then
- ewarn "Skipping tests due to root permissions"
- return
- fi
-
- emake $(use debug && echo fulltest || echo test)
-}
-
-src_install() {
- emake DESTDIR="${D}" HAVE_TCL="$(usex tcl 1 "")" TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" install
- prune_libtool_files
-
- doman sqlite3.1
-
- if use doc; then
- find "${WORKDIR}/${PN}-doc-${DOC_PV}" -name ".[_~]*" -delete
- dohtml -A ico,odg,pdf,svg -r "${WORKDIR}/${PN}-doc-${DOC_PV}/"
- fi
-}
diff --git a/dev-db/sqlite/sqlite-3.8.0.2.ebuild b/dev-db/sqlite/sqlite-3.8.0.2.ebuild
deleted file mode 100644
index 176c8eab3c6b..000000000000
--- a/dev-db/sqlite/sqlite-3.8.0.2.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.8.0.2.ebuild,v 1.1 2013/09/04 17:38:27 floppym Exp $
-
-EAPI="5"
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-SRC_PV="$(printf "%u%02u%02u%02u" $(get_version_components))"
-DOC_PV="${SRC_PV}"
-# DOC_PV="$(printf "%u%02u%02u00" $(get_version_components $(get_version_component_range 1-3)))"
-
-DESCRIPTION="A SQL Database Engine in a C Library"
-HOMEPAGE="http://sqlite.org/"
-SRC_URI="doc? ( http://sqlite.org/2013/${PN}-doc-${DOC_PV}.zip )
- tcl? ( http://sqlite.org/2013/${PN}-src-${SRC_PV}.zip )
- !tcl? (
- test? ( http://sqlite.org/2013/${PN}-src-${SRC_PV}.zip )
- !test? ( http://sqlite.org/2013/${PN}-autoconf-${SRC_PV}.tar.gz )
- )"
-
-LICENSE="public-domain"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc icu +readline secure-delete static-libs tcl test"
-
-RDEPEND="icu? ( dev-libs/icu:= )
- readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl:= )"
-DEPEND="${RDEPEND}
- doc? ( app-arch/unzip )
- tcl? ( app-arch/unzip )
- test? (
- app-arch/unzip
- dev-lang/tcl
- )"
-
-amalgamation() {
- use !tcl && use !test
-}
-
-pkg_setup() {
- if amalgamation; then
- S="${WORKDIR}/${PN}-autoconf-${SRC_PV}"
- else
- S="${WORKDIR}/${PN}-src-${SRC_PV}"
- fi
-}
-
-src_prepare() {
- # At least ppc-aix, x86-interix and *-solaris need newer libtool.
- use prefix && eautoreconf
-}
-
-src_configure() {
- # `configure` from amalgamation tarball does not add -DSQLITE_DEBUG or -DNDEBUG flag.
- if amalgamation; then
- if use debug; then
- append-cppflags -DSQLITE_DEBUG
- else
- append-cppflags -DNDEBUG
- fi
- fi
-
- # Support column metadata functions.
- # http://sqlite.org/c3ref/column_database_name.html
- # http://sqlite.org/c3ref/table_column_metadata.html
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # Support Full-Text Search versions 3 and 4.
- # http://sqlite.org/fts3.html
- append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_ENABLE_FTS4 -DSQLITE_ENABLE_FTS4_UNICODE61
-
- # Support R*Trees.
- # http://sqlite.org/rtree.html
- append-cppflags -DSQLITE_ENABLE_RTREE
-
- # Support soundex() function.
- # http://sqlite.org/lang_corefunc.html#soundex
- append-cppflags -DSQLITE_SOUNDEX
-
- # Support unlock notification.
- # http://sqlite.org/unlock_notify.html
- append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
-
- if use icu; then
- append-cppflags -DSQLITE_ENABLE_ICU
- if amalgamation; then
- sed -e "s/LIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- else
- sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- fi
- fi
-
- # Enable secure_delete pragma.
- # http://sqlite.org/pragma.html#pragma_secure_delete
- if use secure-delete; then
- append-cppflags -DSQLITE_SECURE_DELETE -DSQLITE_CHECK_PAGES -DSQLITE_CORE
- fi
-
- # Starting from 3.6.23, SQLite has locking strategies that are specific to
- # OSX. By default they are enabled, and use semantics that only make sense
- # on OSX. However, they require gethostuuid() function for that, which is
- # only available on OSX starting from 10.6 (Snow Leopard). For earlier
- # versions of OSX we have to disable all this nifty locking options, as
- # suggested by upstream.
- if [[ "${CHOST}" == *-darwin[56789] ]]; then
- append-cppflags -DSQLITE_ENABLE_LOCKING_STYLE="0"
- fi
-
- if [[ "${CHOST}" == *-mint* ]]; then
- append-cppflags -DSQLITE_OMIT_WAL
- fi
-
- # `configure` from amalgamation tarball does not support
- # --with-readline-inc and --(enable|disable)-tcl options.
- econf \
- --enable-$(amalgamation && echo dynamic-extensions || echo load-extension) \
- --enable-threadsafe \
- $(use_enable readline) \
- $(use_enable static-libs static) \
- $(amalgamation || echo --with-readline-inc="-I${EPREFIX}/usr/include/readline") \
- $(amalgamation || use_enable debug) \
- $(amalgamation || echo --enable-tcl)
-}
-
-src_compile() {
- emake TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}"
-}
-
-src_test() {
- if [[ "${EUID}" -eq 0 ]]; then
- ewarn "Skipping tests due to root permissions"
- return
- fi
-
- emake $(use debug && echo fulltest || echo test)
-}
-
-src_install() {
- emake DESTDIR="${D}" HAVE_TCL="$(usex tcl 1 "")" TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" install
- prune_libtool_files
-
- doman sqlite3.1
-
- if use doc; then
- find "${WORKDIR}/${PN}-doc-${DOC_PV}" -name ".[_~]*" -delete
- dohtml -A ico,odg,pdf,svg -r "${WORKDIR}/${PN}-doc-${DOC_PV}/"
- fi
-}
diff --git a/dev-db/sqlite/sqlite-3.8.0.ebuild b/dev-db/sqlite/sqlite-3.8.0.ebuild
deleted file mode 100644
index 758fffdf024d..000000000000
--- a/dev-db/sqlite/sqlite-3.8.0.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.8.0.ebuild,v 1.2 2013/08/29 10:55:35 kensington Exp $
-
-EAPI="5"
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-SRC_PV="$(printf "%u%02u%02u%02u" $(get_version_components))"
-DOC_PV="${SRC_PV}"
-# DOC_PV="$(printf "%u%02u%02u00" $(get_version_components $(get_version_component_range 1-3)))"
-
-DESCRIPTION="A SQL Database Engine in a C Library"
-HOMEPAGE="http://sqlite.org/"
-SRC_URI="doc? ( http://sqlite.org/2013/${PN}-doc-${DOC_PV}.zip )
- tcl? ( http://sqlite.org/2013/${PN}-src-${SRC_PV}.zip )
- !tcl? (
- test? ( http://sqlite.org/2013/${PN}-src-${SRC_PV}.zip )
- !test? ( http://sqlite.org/2013/${PN}-autoconf-${SRC_PV}.tar.gz )
- )"
-
-LICENSE="public-domain"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc icu +readline secure-delete static-libs tcl test"
-
-RDEPEND="icu? ( dev-libs/icu:= )
- readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl:= )"
-DEPEND="${RDEPEND}
- doc? ( app-arch/unzip )
- tcl? ( app-arch/unzip )
- test? (
- app-arch/unzip
- dev-lang/tcl
- )"
-
-amalgamation() {
- use !tcl && use !test
-}
-
-pkg_setup() {
- if amalgamation; then
- S="${WORKDIR}/${PN}-autoconf-${SRC_PV}"
- else
- S="${WORKDIR}/${PN}-src-${SRC_PV}"
- fi
-}
-
-src_prepare() {
- # At least ppc-aix, x86-interix and *-solaris need newer libtool.
- use prefix && eautoreconf
-}
-
-src_configure() {
- # `configure` from amalgamation tarball does not add -DSQLITE_DEBUG or -DNDEBUG flag.
- if amalgamation; then
- if use debug; then
- append-cppflags -DSQLITE_DEBUG
- else
- append-cppflags -DNDEBUG
- fi
- fi
-
- # Support column metadata functions.
- # http://sqlite.org/c3ref/column_database_name.html
- # http://sqlite.org/c3ref/table_column_metadata.html
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # Support Full-Text Search versions 3 and 4.
- # http://sqlite.org/fts3.html
- append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_ENABLE_FTS4 -DSQLITE_ENABLE_FTS4_UNICODE61
-
- # Support R*Trees.
- # http://sqlite.org/rtree.html
- append-cppflags -DSQLITE_ENABLE_RTREE
-
- # Support soundex() function.
- # http://sqlite.org/lang_corefunc.html#soundex
- append-cppflags -DSQLITE_SOUNDEX
-
- # Support unlock notification.
- # http://sqlite.org/unlock_notify.html
- append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
-
- if use icu; then
- append-cppflags -DSQLITE_ENABLE_ICU
- if amalgamation; then
- sed -e "s/LIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- else
- sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- fi
- fi
-
- # Enable secure_delete pragma.
- # http://sqlite.org/pragma.html#pragma_secure_delete
- if use secure-delete; then
- append-cppflags -DSQLITE_SECURE_DELETE -DSQLITE_CHECK_PAGES -DSQLITE_CORE
- fi
-
- # Starting from 3.6.23, SQLite has locking strategies that are specific to
- # OSX. By default they are enabled, and use semantics that only make sense
- # on OSX. However, they require gethostuuid() function for that, which is
- # only available on OSX starting from 10.6 (Snow Leopard). For earlier
- # versions of OSX we have to disable all this nifty locking options, as
- # suggested by upstream.
- if [[ "${CHOST}" == *-darwin[56789] ]]; then
- append-cppflags -DSQLITE_ENABLE_LOCKING_STYLE="0"
- fi
-
- if [[ "${CHOST}" == *-mint* ]]; then
- append-cppflags -DSQLITE_OMIT_WAL
- fi
-
- # `configure` from amalgamation tarball does not support
- # --with-readline-inc and --(enable|disable)-tcl options.
- econf \
- --enable-$(amalgamation && echo dynamic-extensions || echo load-extension) \
- --enable-threadsafe \
- $(use_enable readline) \
- $(use_enable static-libs static) \
- $(amalgamation || echo --with-readline-inc="-I${EPREFIX}/usr/include/readline") \
- $(amalgamation || use_enable debug) \
- $(amalgamation || echo --enable-tcl)
-}
-
-src_compile() {
- emake TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}"
-}
-
-src_test() {
- if [[ "${EUID}" -eq 0 ]]; then
- ewarn "Skipping tests due to root permissions"
- return
- fi
-
- emake $(use debug && echo fulltest || echo test)
-}
-
-src_install() {
- emake DESTDIR="${D}" HAVE_TCL="$(usex tcl 1 "")" TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" install
- prune_libtool_files
-
- doman sqlite3.1
-
- if use doc; then
- find "${WORKDIR}/${PN}-doc-${DOC_PV}" -name ".[_~]*" -delete
- dohtml -A ico,odg,pdf,svg -r "${WORKDIR}/${PN}-doc-${DOC_PV}/"
- fi
-}
diff --git a/dev-db/sqlite/sqlite-3.8.1.ebuild b/dev-db/sqlite/sqlite-3.8.1.ebuild
deleted file mode 100644
index 982851a0a707..000000000000
--- a/dev-db/sqlite/sqlite-3.8.1.ebuild
+++ /dev/null
@@ -1,159 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.8.1.ebuild,v 1.1 2013/10/17 20:20:55 floppym Exp $
-
-EAPI="5"
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-SRC_PV="$(printf "%u%02u%02u%02u" $(get_version_components))"
-DOC_PV="${SRC_PV}"
-# DOC_PV="$(printf "%u%02u%02u00" $(get_version_components $(get_version_component_range 1-3)))"
-
-DESCRIPTION="A SQL Database Engine in a C Library"
-HOMEPAGE="http://sqlite.org/"
-SRC_URI="doc? ( http://sqlite.org/2013/${PN}-doc-${DOC_PV}.zip )
- tcl? ( http://sqlite.org/2013/${PN}-src-${SRC_PV}.zip )
- !tcl? (
- test? ( http://sqlite.org/2013/${PN}-src-${SRC_PV}.zip )
- !test? ( http://sqlite.org/2013/${PN}-autoconf-${SRC_PV}.tar.gz )
- )"
-
-LICENSE="public-domain"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc icu +readline secure-delete static-libs tcl test"
-
-RDEPEND="icu? ( dev-libs/icu:= )
- readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl:= )"
-DEPEND="${RDEPEND}
- doc? ( app-arch/unzip )
- tcl? ( app-arch/unzip )
- test? (
- app-arch/unzip
- dev-lang/tcl
- )"
-
-amalgamation() {
- use !tcl && use !test
-}
-
-pkg_setup() {
- if amalgamation; then
- S="${WORKDIR}/${PN}-autoconf-${SRC_PV}"
- else
- S="${WORKDIR}/${PN}-src-${SRC_PV}"
- fi
-}
-
-src_prepare() {
- if amalgamation; then
- epatch "${FILESDIR}/${P}-autoconf-dlopen_check.patch"
- else
- epatch "${FILESDIR}/${P}-src-dlopen_check.patch"
- epatch "${FILESDIR}/${P}-tests-icu-52.patch"
- fi
-
- eautoreconf
-
- # At least ppc-aix, x86-interix and *-solaris need newer libtool.
- # use prefix && eautoreconf
-}
-
-src_configure() {
- # `configure` from amalgamation tarball does not add -DSQLITE_DEBUG or -DNDEBUG flag.
- if amalgamation; then
- if use debug; then
- append-cppflags -DSQLITE_DEBUG
- else
- append-cppflags -DNDEBUG
- fi
- fi
-
- # Support column metadata functions.
- # http://sqlite.org/c3ref/column_database_name.html
- # http://sqlite.org/c3ref/table_column_metadata.html
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # Support Full-Text Search versions 3 and 4.
- # http://sqlite.org/fts3.html
- append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_ENABLE_FTS4 -DSQLITE_ENABLE_FTS4_UNICODE61
-
- # Support R*Trees.
- # http://sqlite.org/rtree.html
- append-cppflags -DSQLITE_ENABLE_RTREE
-
- # Support soundex() function.
- # http://sqlite.org/lang_corefunc.html#soundex
- append-cppflags -DSQLITE_SOUNDEX
-
- # Support unlock notification.
- # http://sqlite.org/unlock_notify.html
- append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
-
- if use icu; then
- append-cppflags -DSQLITE_ENABLE_ICU
- if amalgamation; then
- sed -e "s/LIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- else
- sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- fi
- fi
-
- # Enable secure_delete pragma.
- # http://sqlite.org/pragma.html#pragma_secure_delete
- if use secure-delete; then
- append-cppflags -DSQLITE_SECURE_DELETE -DSQLITE_CHECK_PAGES -DSQLITE_CORE
- fi
-
- # Starting from 3.6.23, SQLite has locking strategies that are specific to
- # OSX. By default they are enabled, and use semantics that only make sense
- # on OSX. However, they require gethostuuid() function for that, which is
- # only available on OSX starting from 10.6 (Snow Leopard). For earlier
- # versions of OSX we have to disable all this nifty locking options, as
- # suggested by upstream.
- if [[ "${CHOST}" == *-darwin[56789] ]]; then
- append-cppflags -DSQLITE_ENABLE_LOCKING_STYLE="0"
- fi
-
- if [[ "${CHOST}" == *-mint* ]]; then
- append-cppflags -DSQLITE_OMIT_WAL
- fi
-
- # `configure` from amalgamation tarball does not support
- # --with-readline-inc and --(enable|disable)-tcl options.
- econf \
- --enable-$(amalgamation && echo dynamic-extensions || echo load-extension) \
- --enable-threadsafe \
- $(use_enable readline) \
- $(use_enable static-libs static) \
- $(amalgamation || echo --with-readline-inc="-I${EPREFIX}/usr/include/readline") \
- $(amalgamation || use_enable debug) \
- $(amalgamation || echo --enable-tcl)
-}
-
-src_compile() {
- emake TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}"
-}
-
-src_test() {
- if [[ "${EUID}" -eq 0 ]]; then
- ewarn "Skipping tests due to root permissions"
- return
- fi
-
- emake $(use debug && echo fulltest || echo test)
-}
-
-src_install() {
- emake DESTDIR="${D}" HAVE_TCL="$(usex tcl 1 "")" TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" install
- prune_libtool_files
-
- doman sqlite3.1
-
- if use doc; then
- find "${WORKDIR}/${PN}-doc-${DOC_PV}" -name ".[_~]*" -delete
- dohtml -A ico,odg,pdf,svg -r "${WORKDIR}/${PN}-doc-${DOC_PV}/"
- fi
-}