summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2005-08-12 13:25:50 +0000
committerCaleb Tennis <caleb@gentoo.org>2005-08-12 13:25:50 +0000
commit05e8fa267d95470c47aa4a89715c53a547f6f10b (patch)
tree521762eb55204b0b59e9e26118fb3348c1c84e67 /dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild
parentInstall the actual *_dri drivers into /usr/lib/xorg/modules/dri, and remove m... (diff)
downloadgentoo-2-05e8fa267d95470c47aa4a89715c53a547f6f10b.tar.gz
gentoo-2-05e8fa267d95470c47aa4a89715c53a547f6f10b.tar.bz2
gentoo-2-05e8fa267d95470c47aa4a89715c53a547f6f10b.zip
Bump to x86 stable
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild')
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild b/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild
new file mode 100644
index 000000000000..102756922669
--- /dev/null
+++ b/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.11-r1.ebuild,v 1.1 2005/08/12 13:25:50 caleb Exp $
+
+inherit eutils gnuconfig
+
+DESCRIPTION="ODBC Interface for Linux"
+HOMEPAGE="http://www.unixodbc.org/"
+SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
+IUSE="qt gnome"
+
+DEPEND="virtual/libc
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ gnome? ( gnome-base/gnome-libs )
+ qt? ( =x11-libs/qt-3* )"
+
+# the configure.in patch is required for 'use qt'
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ # braindead check in configure fails - hack approach
+ epatch ${FILESDIR}/${P}-configure.in.patch
+ epatch ${FILESDIR}/${P}-Makefile.am.patch
+ aclocal && \
+ libtoolize -c -f && \
+ automake && \
+ autoconf || die "autotools failed"
+}
+
+src_compile() {
+ local myconf
+
+ if use qt && ! use mips;
+ then
+ myconf="--enable-gui=yes --x-libraries=/usr/lib "
+ else
+ myconf="--enable-gui=no"
+ fi
+
+ # Detect mips systems properly
+ gnuconfig_update
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
+ ${myconf} || die
+
+ make || die
+
+ if use gnome;
+ then
+ # Symlink for configure
+ ln -s ${S}/odbcinst/.libs ./lib
+ # Symlink for libtool
+ ln -s ${S}/odbcinst/.libs ./lib/.libs
+ cd gODBCConfig
+ ./configure --host=${CHOST} \
+ --with-odbc=${S} \
+ --prefix=/usr \
+ --x-libraries=/usr/lib \
+ --sysconfdir=/etc/unixODBC \
+ ${myconf} || die
+
+ # not sure why these symlinks are needed. busted configure, i guess...
+ ln -s ../depcomp .
+ ln -s ../libtool .
+ make || die
+ cd ..
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ if use gnome;
+ then
+ cd gODBCConfig
+ make DESTDIR=${D} install || die
+ cd ..
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README*
+ find doc/ -name "Makefile*" -exec rm '{}' \;
+ dohtml doc/*
+ prepalldocs
+}