summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-04-11 09:54:13 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-04-11 09:54:13 +0000
commit084d781b4d3103428bceaae8204d0fb04d7786a9 (patch)
treedc003e5222f6c993ed87615b5574ad7d8d175d48 /dev-db
parentremove old ebuild (diff)
downloadgentoo-2-084d781b4d3103428bceaae8204d0fb04d7786a9.tar.gz
gentoo-2-084d781b4d3103428bceaae8204d0fb04d7786a9.tar.bz2
gentoo-2-084d781b4d3103428bceaae8204d0fb04d7786a9.zip
Bump, adding 2.0, fixes #306369
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/slony1/ChangeLog11
-rw-r--r--dev-db/slony1/slony1-1.2.22.ebuild44
-rw-r--r--dev-db/slony1/slony1-2.0.6.ebuild44
3 files changed, 97 insertions, 2 deletions
diff --git a/dev-db/slony1/ChangeLog b/dev-db/slony1/ChangeLog
index 2fe64cd3db95..565eedd4f2ca 100644
--- a/dev-db/slony1/ChangeLog
+++ b/dev-db/slony1/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/slony1
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/ChangeLog,v 1.22 2010/06/17 19:15:30 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/ChangeLog,v 1.23 2011/04/11 09:54:13 patrick Exp $
+
+*slony1-2.0.6 (11 Apr 2011)
+*slony1-1.2.22 (11 Apr 2011)
+
+ 11 Apr 2011; Patrick Lauer <patrick@gentoo.org> +slony1-1.2.22.ebuild,
+ +slony1-2.0.6.ebuild:
+ Bump, adding 2.0, fixes #306369
17 Jun 2010; Patrick Lauer <patrick@gentoo.org> slony1-1.1.5.ebuild,
slony1-1.2.10.ebuild, slony1-1.2.12.ebuild, slony1-1.2.17.ebuild:
diff --git a/dev-db/slony1/slony1-1.2.22.ebuild b/dev-db/slony1/slony1-1.2.22.ebuild
new file mode 100644
index 000000000000..b22cee8329b3
--- /dev/null
+++ b/dev-db/slony1/slony1-1.2.22.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/slony1-1.2.22.ebuild,v 1.1 2011/04/11 09:54:13 patrick Exp $
+
+inherit eutils
+
+IUSE="perl"
+
+DESCRIPTION="A replication system for the PostgreSQL Database Management System"
+HOMEPAGE="http://slony.info/"
+SRC_URI="http://main.slony.info/downloads/1.2/source/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-db/postgresql-server
+ perl? ( dev-perl/DBD-Pg )"
+
+src_compile() {
+ local myconf=""
+
+ myconf="${myconf} --with-pgincludedir=/usr/include/postgresql/pgsql"
+ myconf="${myconf} --with-pgincludeserverdir=/usr/include/postgresql/server"
+ myconf="${myconf} $(use_with perl perltools)"
+
+ econf ${myconf} || die "econf failed!"
+ emake || die "emake failed!"
+
+ if use perl ; then
+ cd "${S}"/tools
+ emake || die "emake tools failed!"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed!"
+
+ dodoc HISTORY-1.1 INSTALL README SAMPLE TODO UPGRADING doc/howto/*.txt
+ dohtml doc/howto/*.html
+
+ newinitd "${FILESDIR}"/slony1.init slony1 || die "newinitd failed!"
+ newconfd "${FILESDIR}"/slony1.conf slony1 || die "newconfd failed!"
+}
diff --git a/dev-db/slony1/slony1-2.0.6.ebuild b/dev-db/slony1/slony1-2.0.6.ebuild
new file mode 100644
index 000000000000..8367c1c2440b
--- /dev/null
+++ b/dev-db/slony1/slony1-2.0.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/slony1-2.0.6.ebuild,v 1.1 2011/04/11 09:54:13 patrick Exp $
+
+inherit eutils
+
+IUSE="perl"
+
+DESCRIPTION="A replication system for the PostgreSQL Database Management System"
+HOMEPAGE="http://slony.info/"
+SRC_URI="http://main.slony.info/downloads/2.0/source/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-db/postgresql-server
+ perl? ( dev-perl/DBD-Pg )"
+
+src_compile() {
+ local myconf=""
+
+ myconf="${myconf} --with-pgincludedir=/usr/include/postgresql/pgsql"
+ myconf="${myconf} --with-pgincludeserverdir=/usr/include/postgresql/server"
+ myconf="${myconf} $(use_with perl perltools)"
+
+ econf ${myconf} || die "econf failed!"
+ emake || die "emake failed!"
+
+ if use perl ; then
+ cd "${S}"/tools
+ emake || die "emake tools failed!"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed!"
+
+ dodoc HISTORY-1.1 INSTALL README SAMPLE TODO UPGRADING doc/howto/*.txt
+ dohtml doc/howto/*.html
+
+ newinitd "${FILESDIR}"/slony1.init slony1 || die "newinitd failed!"
+ newconfd "${FILESDIR}"/slony1.conf slony1 || die "newconfd failed!"
+}