summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2015-03-15 18:03:52 +0000
committerUlrich Müller <ulm@gentoo.org>2015-03-15 18:03:52 +0000
commit1878fd00b586a470877fb9d93c129520f4d08eb8 (patch)
tree4fc141c63d3295f452695c9b9f993dda298fd70d /dev-db
parentAdd conditional bindist restriction and remove bindist USE flag, bug 541452. (diff)
downloadgentoo-2-1878fd00b586a470877fb9d93c129520f4d08eb8.tar.gz
gentoo-2-1878fd00b586a470877fb9d93c129520f4d08eb8.tar.bz2
gentoo-2-1878fd00b586a470877fb9d93c129520f4d08eb8.zip
Add conditional bindist restriction and remove bindist USE flag, bug 541488.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/opendbx/ChangeLog8
-rw-r--r--dev-db/opendbx/metadata.xml4
-rw-r--r--dev-db/opendbx/opendbx-1.4.5.ebuild13
-rw-r--r--dev-db/opendbx/opendbx-1.4.6.ebuild11
-rw-r--r--dev-db/opendbx/opendbx-1.5.0.ebuild11
5 files changed, 23 insertions, 24 deletions
diff --git a/dev-db/opendbx/ChangeLog b/dev-db/opendbx/ChangeLog
index fe789a593aab..4ee743a30d10 100644
--- a/dev-db/opendbx/ChangeLog
+++ b/dev-db/opendbx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/opendbx
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/ChangeLog,v 1.42 2014/12/28 15:06:33 titanofold Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/ChangeLog,v 1.43 2015/03/15 18:03:52 ulm Exp $
+
+ 15 Mar 2015; Ulrich Müller <ulm@gentoo.org> opendbx-1.4.5.ebuild,
+ opendbx-1.4.6.ebuild, opendbx-1.5.0.ebuild, metadata.xml:
+ Add conditional bindist restriction and remove bindist USE flag, bug 541488.
28 Dec 2014; Aaron W. Swenson <titanofold@gentoo.org> opendbx-1.4.5.ebuild,
opendbx-1.4.6.ebuild, opendbx-1.5.0.ebuild:
diff --git a/dev-db/opendbx/metadata.xml b/dev-db/opendbx/metadata.xml
index cb3bf7e77b13..35926e0cab20 100644
--- a/dev-db/opendbx/metadata.xml
+++ b/dev-db/opendbx/metadata.xml
@@ -5,8 +5,4 @@
<email>alicef@gentoo.org</email>
<name>Alice Ferrazzi</name>
</maintainer>
-<use>
- <flag name="bindist">Disable support for <pkg>dev-db/firebird</pkg> database
- which is not GPL compatible.</flag>
-</use>
</pkgmetadata>
diff --git a/dev-db/opendbx/opendbx-1.4.5.ebuild b/dev-db/opendbx/opendbx-1.4.5.ebuild
index 1aa9a0c5af88..239aa94b1cc3 100644
--- a/dev-db/opendbx/opendbx-1.4.5.ebuild
+++ b/dev-db/opendbx/opendbx-1.4.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/opendbx-1.4.5.ebuild,v 1.8 2014/12/28 15:06:33 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/opendbx-1.4.5.ebuild,v 1.9 2015/03/15 18:03:52 ulm Exp $
EAPI="2"
@@ -13,18 +13,19 @@ SRC_URI="http://www.linuxnetworks.de/opendbx/download/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="bindist firebird +mysql oracle postgres sqlite sqlite3"
+IUSE="firebird +mysql oracle postgres sqlite sqlite3"
+RESTRICT="firebird? ( bindist )"
DEPEND="mysql? ( virtual/mysql )
postgres? ( dev-db/postgresql )
sqlite? ( <dev-db/sqlite-3 )
sqlite3? ( =dev-db/sqlite-3* )
oracle? ( dev-db/oracle-instantclient-basic )
- !bindist? ( firebird? ( dev-db/firebird ) )"
+ firebird? ( dev-db/firebird )"
RDEPEND="${DEPEND}"
pkg_setup() {
- if ! ( use !bindist && use firebird || use mysql || use oracle || use postgres || use sqlite || use sqlite3 )
+ if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite || use sqlite3 )
then
ewarn "You should enable at least one of the following USE flags:"
ewarn "firebird, mysql, oracle, postgres, sqlite or sqlite3"
@@ -43,7 +44,7 @@ pkg_setup() {
src_configure() {
local backends=""
- use !bindist && use firebird && backends="${backends} firebird"
+ use firebird && backends="${backends} firebird"
use mysql && backends="${backends} mysql"
use oracle && backends="${backends} oracle"
use postgres && backends="${backends} pgsql"
diff --git a/dev-db/opendbx/opendbx-1.4.6.ebuild b/dev-db/opendbx/opendbx-1.4.6.ebuild
index 650e4437389f..858b015cc4d2 100644
--- a/dev-db/opendbx/opendbx-1.4.6.ebuild
+++ b/dev-db/opendbx/opendbx-1.4.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/opendbx-1.4.6.ebuild,v 1.5 2014/12/28 15:06:33 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/opendbx-1.4.6.ebuild,v 1.6 2015/03/15 18:03:52 ulm Exp $
EAPI="5"
@@ -13,7 +13,8 @@ SRC_URI="http://www.linuxnetworks.de/opendbx/download/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="bindist firebird +mysql oracle postgres sqlite sqlite3"
+IUSE="firebird +mysql oracle postgres sqlite sqlite3"
+RESTRICT="firebird? ( bindist )"
DEPEND="mysql? ( virtual/mysql )
postgres? ( dev-db/postgresql )
@@ -23,8 +24,6 @@ DEPEND="mysql? ( virtual/mysql )
firebird? ( dev-db/firebird )"
RDEPEND="${DEPEND}"
-REQUIRED_USE="bindist? ( !firebird )"
-
pkg_setup() {
if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite || use sqlite3 )
then
@@ -45,7 +44,7 @@ pkg_setup() {
src_configure() {
local backends=""
- use !bindist && use firebird && backends="${backends} firebird"
+ use firebird && backends="${backends} firebird"
use mysql && backends="${backends} mysql"
use oracle && backends="${backends} oracle"
use postgres && backends="${backends} pgsql"
diff --git a/dev-db/opendbx/opendbx-1.5.0.ebuild b/dev-db/opendbx/opendbx-1.5.0.ebuild
index baeadc701af7..cefa1d6899e5 100644
--- a/dev-db/opendbx/opendbx-1.5.0.ebuild
+++ b/dev-db/opendbx/opendbx-1.5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/opendbx-1.5.0.ebuild,v 1.5 2014/12/28 15:06:33 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/opendbx/opendbx-1.5.0.ebuild,v 1.6 2015/03/15 18:03:52 ulm Exp $
EAPI="5"
@@ -16,7 +16,8 @@ SRC_URI="http://www.linuxnetworks.de/opendbx/download/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~x64-solaris"
-IUSE="bindist firebird +mysql oracle postgres sqlite sqlite3"
+IUSE="firebird +mysql oracle postgres sqlite sqlite3"
+RESTRICT="firebird? ( bindist )"
DEPEND="mysql? ( virtual/mysql )
postgres? ( dev-db/postgresql )
@@ -26,8 +27,6 @@ DEPEND="mysql? ( virtual/mysql )
firebird? ( dev-db/firebird )"
RDEPEND="${DEPEND}"
-REQUIRED_USE="bindist? ( !firebird )"
-
S="${WORKDIR}"/${MY_P}
pkg_setup() {
@@ -50,7 +49,7 @@ pkg_setup() {
src_configure() {
local backends=""
- use !bindist && use firebird && backends="${backends} firebird"
+ use firebird && backends="${backends} firebird"
use mysql && backends="${backends} mysql"
use oracle && backends="${backends} oracle"
use postgres && backends="${backends} pgsql"