summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-03-17 21:25:38 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-03-17 21:25:38 +0000
commit274a95a16adcf10c28a4e5fd11f7187a1ce29054 (patch)
tree3245c976e47ef3ac9a56d2b7a20cfecbb67b7022 /dev-db
parentBump (diff)
downloadgentoo-2-274a95a16adcf10c28a4e5fd11f7187a1ce29054.tar.gz
gentoo-2-274a95a16adcf10c28a4e5fd11f7187a1ce29054.tar.bz2
gentoo-2-274a95a16adcf10c28a4e5fd11f7187a1ce29054.zip
Bump, small patch for sandbox violation thanks to jbergstroem
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/tokyocabinet/ChangeLog8
-rw-r--r--dev-db/tokyocabinet/files/1.4.43.patch12
-rw-r--r--dev-db/tokyocabinet/tokyocabinet-1.4.43.ebuild45
3 files changed, 64 insertions, 1 deletions
diff --git a/dev-db/tokyocabinet/ChangeLog b/dev-db/tokyocabinet/ChangeLog
index cd5bf01debf9..711ae0b783b9 100644
--- a/dev-db/tokyocabinet/ChangeLog
+++ b/dev-db/tokyocabinet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/tokyocabinet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/ChangeLog,v 1.21 2010/02/01 19:49:42 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/ChangeLog,v 1.22 2010/03/17 21:25:37 patrick Exp $
+
+*tokyocabinet-1.4.43 (17 Mar 2010)
+
+ 17 Mar 2010; Patrick Lauer <patrick@gentoo.org> +files/1.4.43.patch,
+ +tokyocabinet-1.4.43.ebuild:
+ Bump, small patch for sandbox violation thanks to jbergstroem
01 Feb 2010; Markus Meier <maekke@gentoo.org> tokyocabinet-1.4.41.ebuild:
amd64 stable, bug #290660
diff --git a/dev-db/tokyocabinet/files/1.4.43.patch b/dev-db/tokyocabinet/files/1.4.43.patch
new file mode 100644
index 000000000000..a75da590ee38
--- /dev/null
+++ b/dev-db/tokyocabinet/files/1.4.43.patch
@@ -0,0 +1,12 @@
+diff --git a/Makefile.in b/Makefile.in
+index 60b1036..12f02b0 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -125,7 +125,6 @@ install :
+ cd man && cp -Rf $(MAN3FILES) $(DESTDIR)$(MAN3DIR)
+ mkdir -p $(DESTDIR)$(PCDIR)
+ cp -Rf $(PCFILES) $(DESTDIR)$(PCDIR)
+- [ "$$UID" == 0 ] && ldconfig || true
+ @printf '\n'
+ @printf '#================================================================\n'
+ @printf '# Thanks for using Tokyo Cabinet.\n'
diff --git a/dev-db/tokyocabinet/tokyocabinet-1.4.43.ebuild b/dev-db/tokyocabinet/tokyocabinet-1.4.43.ebuild
new file mode 100644
index 000000000000..a195f2b77031
--- /dev/null
+++ b/dev-db/tokyocabinet/tokyocabinet-1.4.43.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/tokyocabinet-1.4.43.ebuild,v 1.1 2010/03/17 21:25:37 patrick Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="A library of routines for managing a database"
+HOMEPAGE="http://1978th.net/tokyocabinet/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="debug doc examples"
+
+DEPEND="sys-libs/zlib
+ app-arch/bzip2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_rpath.patch"
+ epatch "${FILESDIR}/${PV}.patch"
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ if use examples; then
+ dodoc example/* || die "Install failed"
+ fi
+
+ if use doc; then
+ dodoc doc/* || die "Install failed"
+ fi
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}