summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-09-23 05:07:11 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-09-23 05:07:11 +0000
commit301f076b3405c03127a62b925fbadb521bce5e80 (patch)
tree6eb3c208a68f5c6c7b3480fe6a8e80f9bd05fb7c /dev-db
parentppc64 stable for openssl-1.0.1e and ~ppc64 for openssl-1.0.1e-r1 wrt bug #469976 (diff)
downloadgentoo-2-301f076b3405c03127a62b925fbadb521bce5e80.tar.gz
gentoo-2-301f076b3405c03127a62b925fbadb521bce5e80.tar.bz2
gentoo-2-301f076b3405c03127a62b925fbadb521bce5e80.zip
Bump
(Portage version: 2.2.6/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/slony1/ChangeLog8
-rw-r--r--dev-db/slony1/slony1-2.1.4.ebuild3
-rw-r--r--dev-db/slony1/slony1-2.2.0.ebuild68
3 files changed, 77 insertions, 2 deletions
diff --git a/dev-db/slony1/ChangeLog b/dev-db/slony1/ChangeLog
index 0dc6e59b4637..ea05844d9810 100644
--- a/dev-db/slony1/ChangeLog
+++ b/dev-db/slony1/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/slony1
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/ChangeLog,v 1.45 2013/08/26 05:27:35 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/ChangeLog,v 1.46 2013/09/23 05:07:11 patrick Exp $
+
+*slony1-2.2.0 (23 Sep 2013)
+
+ 23 Sep 2013; Patrick Lauer <patrick@gentoo.org> +slony1-2.2.0.ebuild,
+ slony1-2.1.4.ebuild:
+ Bump
*slony1-2.1.4 (26 Aug 2013)
diff --git a/dev-db/slony1/slony1-2.1.4.ebuild b/dev-db/slony1/slony1-2.1.4.ebuild
index 53c74f809b45..5bbc83553e60 100644
--- a/dev-db/slony1/slony1-2.1.4.ebuild
+++ b/dev-db/slony1/slony1-2.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/slony1-2.1.4.ebuild,v 1.1 2013/08/26 05:27:35 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/slony1-2.1.4.ebuild,v 1.2 2013/09/23 05:07:11 patrick Exp $
EAPI="4"
@@ -21,6 +21,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
DEPEND="|| (
+ dev-db/postgresql-server:9.3
dev-db/postgresql-server:9.2
dev-db/postgresql-server:9.1
dev-db/postgresql-server:9.0
diff --git a/dev-db/slony1/slony1-2.2.0.ebuild b/dev-db/slony1/slony1-2.2.0.ebuild
new file mode 100644
index 000000000000..83e01353474a
--- /dev/null
+++ b/dev-db/slony1/slony1-2.2.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/slony1/slony1-2.2.0.ebuild,v 1.1 2013/09/23 05:07:11 patrick Exp $
+
+EAPI="4"
+
+inherit eutils versionator
+
+IUSE="doc perl"
+
+DESCRIPTION="A replication system for the PostgreSQL Database Management System"
+HOMEPAGE="http://slony.info/"
+
+# ${P}-docs.tar.bz2 contains man pages as well as additional documentation
+MAJ_PV=$(get_version_component_range 1-2)
+SRC_URI="http://main.slony.info/downloads/${MAJ_PV}/source/${P}.tar.bz2
+ http://main.slony.info/downloads/${MAJ_PV}/source/${P}-docs.tar.bz2"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="|| (
+ dev-db/postgresql-server:9.3
+ dev-db/postgresql-server:9.2
+ dev-db/postgresql-server:9.1
+ dev-db/postgresql-server:9.0
+ dev-db/postgresql-server:8.4
+ dev-db/postgresql-server:8.3
+ )
+ dev-db/postgresql-base[threads]
+ perl? ( dev-perl/DBD-Pg )
+"
+
+pkg_setup() {
+ local PGSLOT="$(postgresql-config show)"
+ if [[ ${PGSLOT//.} < 83 ]] ; then
+ eerror "You must build ${CATEGORY}/${PN} against PostgreSQL 8.3 or higher."
+ eerror "Set an appropriate slot with postgresql-config."
+ die "postgresql-config not set to 8.3 or higher."
+ fi
+
+# if [[ ${PGSLOT//.} > 90 ]] ; then
+# ewarn "You are building ${CATEGORY}/${PN} against a version of PostgreSQL greater than 9.0."
+# ewarn "This is neither supported here nor upstream."
+# ewarn "Any bugs you encounter should be reported upstream."
+# fi
+}
+
+src_configure() {
+ local myconf
+ use perl && myconf='--with-perltools'
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc INSTALL README SAMPLE TODO UPGRADING share/slon.conf-sample
+
+ if use doc ; then
+ cd "${S}"/doc
+ dohtml -r *
+ fi
+
+ newinitd "${FILESDIR}"/slony1.init slony1
+ newconfd "${FILESDIR}"/slony1.conf slony1
+}