summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-16 08:41:59 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-16 08:41:59 +0000
commit56266dfd04ff91ca54fbfc5029bafcb0a0649f8b (patch)
treee59e2cc0716dffc58b55ac80cf8a0cdd38a4b04d /dev-db
parentI'm an idiot and forgot to commit this 3-4 days ago. (diff)
downloadgentoo-2-56266dfd04ff91ca54fbfc5029bafcb0a0649f8b.tar.gz
gentoo-2-56266dfd04ff91ca54fbfc5029bafcb0a0649f8b.tar.bz2
gentoo-2-56266dfd04ff91ca54fbfc5029bafcb0a0649f8b.zip
PHP update
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/mysql-3.23.51-r1.ebuild13
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-2.2.6.ebuild4
-rw-r--r--dev-db/phppgadmin/phppgadmin-2.4.1-r1.ebuild4
3 files changed, 8 insertions, 13 deletions
diff --git a/dev-db/mysql/mysql-3.23.51-r1.ebuild b/dev-db/mysql/mysql-3.23.51-r1.ebuild
index acf83e6f5512..86321c2ee17a 100644
--- a/dev-db/mysql/mysql-3.23.51-r1.ebuild
+++ b/dev-db/mysql/mysql-3.23.51-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.51-r1.ebuild,v 1.1 2002/07/02 17:59:29 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.51-r1.ebuild,v 1.2 2002/07/16 08:41:59 rphillips Exp $
SVER=${PV%.*}
#normal releases:
@@ -70,16 +70,11 @@ src_unpack() {
src_compile() {
local myconf
# use the bundled db on gentoo 1.3+
- if [ "${COMPILER}" != "gcc3" ]
- then
- use berkdb && myconf="${myconf} \
- --with-berkeley-db \
- --with-berkeley-db-includes=/usr/include/db3 \
- --with-berkeley-db-libs=/usr/lib"
+ if use berkdb; then
+ myconf="${myconf} --with-berkeley-db=./bdb"
else
- use berkdb && myconf="${myconf} --with-berkeley-db"
+ myconf="${myconf} --without-berkeley-db"
fi
- use berkdb || myconf="${myconf} --without-berkeley-db"
# first one means use the system readline
use readline && myconf="${myconf} --without-readline"
use readline || myconf="${myconf} --with-readline"
diff --git a/dev-db/phpmyadmin/phpmyadmin-2.2.6.ebuild b/dev-db/phpmyadmin/phpmyadmin-2.2.6.ebuild
index 17bf97c77e51..cf749bfa2922 100644
--- a/dev-db/phpmyadmin/phpmyadmin-2.2.6.ebuild
+++ b/dev-db/phpmyadmin/phpmyadmin-2.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-2.2.6.ebuild,v 1.3 2002/07/08 08:03:56 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-2.2.6.ebuild,v 1.4 2002/07/16 08:41:59 rphillips Exp $
MY_PN=phpMyAdmin
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-php.tar.bz2"
HOMEPAGE="http://phpmyadmin.sourceforge.net/"
LICENSE="GPL-2"
-DEPEND=">=net-www/apache-1.3.24-r1 >=dev-db/mysql-3.23.38 >=dev-lang/php-4.1.2-r5"
+DEPEND=">=net-www/apache-1.3.24-r1 >=dev-db/mysql-3.23.38 >=dev-php/mod_php-4.1.2-r5"
src_compile() { :; }
diff --git a/dev-db/phppgadmin/phppgadmin-2.4.1-r1.ebuild b/dev-db/phppgadmin/phppgadmin-2.4.1-r1.ebuild
index 98f2b6bc438e..caf62b48069d 100644
--- a/dev-db/phppgadmin/phppgadmin-2.4.1-r1.ebuild
+++ b/dev-db/phppgadmin/phppgadmin-2.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phppgadmin/phppgadmin-2.4.1-r1.ebuild,v 1.2 2002/05/27 17:27:37 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phppgadmin/phppgadmin-2.4.1-r1.ebuild,v 1.3 2002/07/16 08:41:59 rphillips Exp $
MY_PN=phpPgAdmin
MY_PV="`echo ${PV} | sed -e 's:\.:-:g'`"
@@ -10,7 +10,7 @@ DESCRIPTION="Web-based administration for Postgres database in php"
SRC_URI="mirror://sourceforge/${PN}/${MY_PN}_${MY_PV}.tar.bz2"
HOMEPAGE="http://phppgadmin.sourceforge.net/"
-DEPEND=">=net-www/apache-1.3.24-r1 >=dev-db/postgresql-7.0.3-r3 >=dev-lang/php-4.1.2-r5"
+DEPEND=">=net-www/apache-1.3.24-r1 >=dev-db/postgresql-7.0.3-r3 >=dev-php/mod_php-4.1.2-r5"
LICENSE="GPL-2"
SLOT="0"