summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-04-24 17:30:05 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-04-24 17:30:05 +0000
commit82d4af0408bfb29cc6a6b93a997407f6c829a328 (patch)
tree4ead245c7a5da36190e93ac9f19d9687037ec88f /dev-db
parentBump to 4.4.1 (diff)
downloadgentoo-2-82d4af0408bfb29cc6a6b93a997407f6c829a328.tar.gz
gentoo-2-82d4af0408bfb29cc6a6b93a997407f6c829a328.tar.bz2
gentoo-2-82d4af0408bfb29cc6a6b93a997407f6c829a328.zip
Cleanup.
(Portage version: 2.1.2.3)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/cdb/ChangeLog6
-rw-r--r--dev-db/cdb/cdb-0.75-r1.ebuild34
-rw-r--r--dev-db/cdb/cdb-0.75-r2.ebuild30
-rw-r--r--dev-db/cdb/cdb-0.75.ebuild58
-rw-r--r--dev-db/cdb/files/digest-cdb-0.753
-rw-r--r--dev-db/cdb/metadata.xml5
6 files changed, 37 insertions, 99 deletions
diff --git a/dev-db/cdb/ChangeLog b/dev-db/cdb/ChangeLog
index ef9c8cec58d1..42f7b78504da 100644
--- a/dev-db/cdb/ChangeLog
+++ b/dev-db/cdb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/cdb
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/ChangeLog,v 1.34 2007/03/26 07:48:10 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/ChangeLog,v 1.35 2007/04/24 17:30:05 chtekk Exp $
+
+ 24 Apr 2007; Luca Longinotti <chtekk@gentoo.org> metadata.xml,
+ -cdb-0.75.ebuild, cdb-0.75-r1.ebuild, cdb-0.75-r2.ebuild:
+ Remove old versions, cleanup ebuilds, take over maintainership.
26 Mar 2007; Alec Warner <antarus@gentoo.org> cdb-0.75.ebuild,
cdb-0.75-r1.ebuild, cdb-0.75-r2.ebuild:
diff --git a/dev-db/cdb/cdb-0.75-r1.ebuild b/dev-db/cdb/cdb-0.75-r1.ebuild
index 56af19d63194..584d58fb11a8 100644
--- a/dev-db/cdb/cdb-0.75-r1.ebuild
+++ b/dev-db/cdb/cdb-0.75-r1.ebuild
@@ -1,52 +1,50 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/cdb-0.75-r1.ebuild,v 1.15 2007/03/26 07:48:10 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/cdb-0.75-r1.ebuild,v 1.16 2007/04/24 17:30:05 chtekk Exp $
inherit eutils toolchain-funcs
-DESCRIPTION="fast, reliable, simple package for creating and reading constant databases"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ~ppc-macos ppc64 s390 sh sparc x86"
+
+DESCRIPTION="Fast, reliable, simple package for creating and reading constant databases."
HOMEPAGE="http://cr.yp.to/cdb.html"
SRC_URI="http://cr.yp.to/cdb/${P}.tar.gz"
-
LICENSE="as-is"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ~ppc-macos ppc64 s390 sh sparc x86"
IUSE=""
DEPEND=">=sys-apps/sed-4
- app-arch/tar
- app-arch/gzip
- !dev-db/freecdb"
-RDEPEND=""
+ !dev-db/freecdb
+ !dev-db/tinycdb"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-errno.diff
- sed -i \
- -e 's/head -1/head -n 1/g' Makefile || \
- die "sed Makefile failed"
+ sed -i -e 's/head -1/head -n 1/g' Makefile \
+ || die "sed Makefile failed"
}
src_compile() {
echo "$(tc-getCC) ${CFLAGS}" > conf-cc
- echo "$(tc-getCC)" > conf-ld
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
echo "/usr" > conf-home
emake || die "emake failed"
}
src_install() {
- dobin cdbdump cdbget cdbmake cdbmake-12 cdbmake-sv cdbstats cdbtest || \
- die "dobin failed"
+ dobin cdbdump cdbget cdbmake cdbmake-12 cdbmake-sv cdbstats cdbtest \
+ || die "dobin failed"
- # ok so.. first off, some automakes fail at not finding
- # cdb.a, so install that
- dolib *.a || die
+ # ok so ... first off, some automakes fail at finding
+ # cdb.a, so install that now
+ dolib *.a || die "dolib failed"
# then do this pretty little symlinking to solve the somewhat
# cosmetic library issue at hand
- dosym cdb.a /usr/$(get_libdir)/libcdb.a || die "newlib.a failed"
+ dosym cdb.a /usr/$(get_libdir)/libcdb.a || die "dosym failed"
# uint32.h needs installation too, otherwise compiles depending
# on it will fail
diff --git a/dev-db/cdb/cdb-0.75-r2.ebuild b/dev-db/cdb/cdb-0.75-r2.ebuild
index 188c2ce4b192..9e91be6d4894 100644
--- a/dev-db/cdb/cdb-0.75-r2.ebuild
+++ b/dev-db/cdb/cdb-0.75-r2.ebuild
@@ -1,30 +1,30 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/cdb-0.75-r2.ebuild,v 1.2 2007/03/26 07:48:10 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/cdb-0.75-r2.ebuild,v 1.3 2007/04/24 17:30:05 chtekk Exp $
inherit eutils toolchain-funcs
-DESCRIPTION="fast, reliable, simple package for creating and reading constant databases"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="Fast, reliable, simple package for creating and reading constant databases."
HOMEPAGE="http://cr.yp.to/cdb.html"
SRC_URI="http://cr.yp.to/cdb/${P}.tar.gz"
-
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE=""
DEPEND=">=sys-apps/sed-4
- !dev-db/freecdb"
-RDEPEND=""
+ !dev-db/freecdb
+ !dev-db/tinycdb"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-errno.diff
- sed -i \
- -e 's/head -1/head -n 1/g' Makefile || \
- die "sed Makefile failed"
+ sed -i -e 's/head -1/head -n 1/g' Makefile \
+ || die "sed Makefile failed"
}
src_compile() {
@@ -35,16 +35,16 @@ src_compile() {
}
src_install() {
- dobin cdbdump cdbget cdbmake cdbmake-12 cdbmake-sv cdbstats cdbtest || \
- die "dobin failed"
+ dobin cdbdump cdbget cdbmake cdbmake-12 cdbmake-sv cdbstats cdbtest \
+ || die "dobin failed"
- # ok so.. first off, some automakes fail at not finding
- # cdb.a, so install that
- dolib *.a || die
+ # ok so ... first off, some automakes fail at finding
+ # cdb.a, so install that now
+ dolib *.a || die "dolib failed"
# then do this pretty little symlinking to solve the somewhat
# cosmetic library issue at hand
- dosym cdb.a /usr/$(get_libdir)/libcdb.a || die "newlib.a failed"
+ dosym cdb.a /usr/$(get_libdir)/libcdb.a || die "dosym failed"
# uint32.h needs installation too, otherwise compiles depending
# on it will fail
diff --git a/dev-db/cdb/cdb-0.75.ebuild b/dev-db/cdb/cdb-0.75.ebuild
deleted file mode 100644
index 1676d7bc263b..000000000000
--- a/dev-db/cdb/cdb-0.75.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/cdb-0.75.ebuild,v 1.33 2007/03/26 07:48:10 antarus Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="fast, reliable, simple package for creating and reading constant databases"
-HOMEPAGE="http://cr.yp.to/cdb.html"
-SRC_URI="http://cr.yp.to/cdb/${P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ia64 ppc ~ppc-macos ppc64 s390 sh sparc x86"
-IUSE=""
-
-DEPEND=">=sys-apps/sed-4
- app-arch/tar
- app-arch/gzip
- !dev-db/freecdb"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-errno.diff
-
- sed -i \
- -e 's/head -1/head -n 1/g' Makefile || \
- die "sed Makefile failed"
-}
-
-src_compile() {
- echo "$(tc-getCC) ${CFLAGS}" > conf-cc
- echo "$(tc-getCC)" > conf-ld
- echo "/usr" > conf-home
- emake || die "emake failed"
-}
-
-src_install() {
- dobin cdbdump cdbget cdbmake cdbmake-12 cdbmake-sv cdbstats cdbtest || \
- die "dobin failed"
-
- # ok so.. first off, some automakes fail at not finding
- # cdb.a, so install that
- dolib cdb.a
-
- # then do this pretty little symlinking to solve the somewhat
- # cosmetic library issue at hand
- dosym /usr/$(get_libdir)/cdb.a /usr/$(get_libdir)/libcdb.a || die "newlib.a failed"
-
- # uint32.h needs installation too, otherwise compiles depending
- # on it will fail
- insinto /usr/include
- doins cdb.h uint32.h || die "doins failed"
-
- dodoc CHANGES FILES README SYSDEPS TARGETS TODO VERSION || \
- die "dodoc failed"
-}
diff --git a/dev-db/cdb/files/digest-cdb-0.75 b/dev-db/cdb/files/digest-cdb-0.75
deleted file mode 100644
index c987a0d3c784..000000000000
--- a/dev-db/cdb/files/digest-cdb-0.75
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 81fed54d0bde51b147dd6c20cdb92d51 cdb-0.75.tar.gz 54162
-RMD160 d52288ee6df58fdc5a79efc16693cd5e305f9c65 cdb-0.75.tar.gz 54162
-SHA256 1919577799a50c080a8a05a1cbfa5fa7e7abc823d8d7df2eeb181e624b7952c5 cdb-0.75.tar.gz 54162
diff --git a/dev-db/cdb/metadata.xml b/dev-db/cdb/metadata.xml
index 73420b6cf0f0..fd3dbe39fa64 100644
--- a/dev-db/cdb/metadata.xml
+++ b/dev-db/cdb/metadata.xml
@@ -1,8 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>no-herd</herd>
-<maintainer>
- <email>maintainer-needed@gentoo.org</email>
-</maintainer>
+ <herd>php</herd>
</pkgmetadata>