summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2014-09-03 22:44:00 +0000
committerBrian Evans <grknight@gentoo.org>2014-09-03 22:44:00 +0000
commit8df24b6430860a7b075fb8dd10c43c7dca173245 (patch)
tree596609d513869c706a9c6bff845ea61656a1adfd /dev-db
parentNew snapshot. (diff)
downloadgentoo-2-8df24b6430860a7b075fb8dd10c43c7dca173245.tar.gz
gentoo-2-8df24b6430860a7b075fb8dd10c43c7dca173245.tar.bz2
gentoo-2-8df24b6430860a7b075fb8dd10c43c7dca173245.zip
Version bump, convert to multilib
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 67C78E1D)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mariadb-galera/ChangeLog7
-rw-r--r--dev-db/mariadb-galera/mariadb-galera-10.0.13.ebuild124
2 files changed, 130 insertions, 1 deletions
diff --git a/dev-db/mariadb-galera/ChangeLog b/dev-db/mariadb-galera/ChangeLog
index bd9b542ad160..4656c00f8495 100644
--- a/dev-db/mariadb-galera/ChangeLog
+++ b/dev-db/mariadb-galera/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/mariadb-galera
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb-galera/ChangeLog,v 1.1 2014/07/30 06:26:21 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb-galera/ChangeLog,v 1.2 2014/09/03 22:44:00 grknight Exp $
+
+*mariadb-galera-10.0.13 (03 Sep 2014)
+
+ 03 Sep 2014; Brian Evans <grknight@gentoo.org> +mariadb-galera-10.0.13.ebuild:
+ Version bump, convert to multilib
*mariadb-galera-10.0.12 (30 Jul 2014)
diff --git a/dev-db/mariadb-galera/mariadb-galera-10.0.13.ebuild b/dev-db/mariadb-galera/mariadb-galera-10.0.13.ebuild
new file mode 100644
index 000000000000..bcc41bc8dfb8
--- /dev/null
+++ b/dev-db/mariadb-galera/mariadb-galera-10.0.13.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mariadb-galera/mariadb-galera-10.0.13.ebuild,v 1.1 2014/09/03 22:44:00 grknight Exp $
+
+EAPI="5"
+MY_EXTRAS_VER="20140903-1928Z"
+WSREP_REVISION="25"
+
+inherit toolchain-funcs mysql-multilib
+# only to make repoman happy. it is really set in the eclass
+IUSE="$IUSE"
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~amd64 ~x86"
+
+# When MY_EXTRAS is bumped, the index should be revised to exclude these.
+EPATCH_EXCLUDE=''
+
+DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )"
+RDEPEND="${RDEPEND}"
+
+# Please do not add a naive src_unpack to this ebuild
+# If you want to add a single patch, copy the ebuild to an overlay
+# and create your own mysql-extras tarball, looking at 000_index.txt
+
+# Official test instructions:
+# USE='-cluster embedded extraengine perl ssl static-libs community' \
+# FEATURES='test userpriv -usersandbox' \
+# ebuild mariadb-galera-X.X.XX.ebuild \
+# digest clean package
+multilib_src_test() {
+
+ if ! multilib_is_native_abi ; then
+ einfo "Server tests not available on non-native abi".
+ return 0;
+ fi
+
+ local TESTDIR="${BUILD_DIR}/mysql-test"
+ local retstatus_unit
+ local retstatus_tests
+
+ # Bug #213475 - MySQL _will_ object strenously if your machine is named
+ # localhost. Also causes weird failures.
+ [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
+
+ if ! use "minimal" ; then
+
+ if [[ $UID -eq 0 ]]; then
+ die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
+ fi
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # Run CTest (test-units)
+ cmake-utils_src_test
+ retstatus_unit=$?
+ [[ $retstatus_unit -eq 0 ]] || eerror "test-unit failed"
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+ # You may set this by hand.
+ # The default maximum is 8 unless MTR_MAX_PARALLEL is increased
+ export MTR_PARALLEL="${MTR_PARALLEL:-auto}"
+
+ # create directories because mysqladmin might right out of order
+ mkdir -p "${S}"/mysql-test/var-tests{,/log}
+
+ # These are failing in MariaDB 10.0 for now and are believed to be
+ # false positives:
+ #
+ # main.information_schema, binlog.binlog_statement_insert_delayed,
+ # main.mysqld--help, funcs_1.is_triggers, funcs_1.is_tables_mysql,
+ # funcs_1.is_columns_mysql
+ # fails due to USE=-latin1 / utf8 default
+ #
+ # main.mysql_client_test, main.mysql_client_test_nonblock
+ # mina.mysql_client_test_comp:
+ # segfaults at random under Portage only, suspect resource limits.
+ #
+ # innodb.innodb_simulate_comp_failures_small
+ # Has a very long timeout requirement to be consistent
+ # Upstream bug MDEV-6546
+ #
+
+ for t in main.mysql_client_test main.mysql_client_test_nonblock \
+ main.mysql_client_test_comp \
+ binlog.binlog_statement_insert_delayed main.information_schema \
+ main.mysqld--help innodb.innodb_simulate_comp_failures_small \
+ funcs_1.is_triggers funcs_1.is_tables_mysql funcs_1.is_columns_mysql ; do
+ mysql-multilib_disable_test "$t" "False positives in Gentoo"
+ done
+
+ # Run mysql tests
+ pushd "${TESTDIR}"
+
+ # run mysql-test tests
+ # Skip all CONNECT engine tests until upstream respondes to how to reference data files
+ perl mysql-test-run.pl --force --vardir="${S}/mysql-test/var-tests" \
+ --skip-test=connect
+ retstatus_tests=$?
+ [[ $retstatus_tests -eq 0 ]] || eerror "tests failed"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ popd
+
+ # Cleanup is important for these testcases.
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+
+ failures=""
+ [[ $retstatus_unit -eq 0 ]] || failures="${failures} test-unit"
+ [[ $retstatus_tests -eq 0 ]] || failures="${failures} tests"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ [[ -z "$failures" ]] || die "Test failures: $failures"
+ einfo "Tests successfully completed"
+
+ else
+
+ einfo "Skipping server tests due to minimal build."
+ fi
+}