summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2007-03-11 16:15:47 +0000
committerAkinori Hattori <hattya@gentoo.org>2007-03-11 16:15:47 +0000
commitd0bab1aa07c7f3e265b38271cad22b4d742e0328 (patch)
tree7648f93363895ad3626de02641ba719e144385ad /dev-db
parentNow systray icon works, Bug #170364. Country options can be changed, Bug #170... (diff)
downloadgentoo-2-d0bab1aa07c7f3e265b38271cad22b4d742e0328.tar.gz
gentoo-2-d0bab1aa07c7f3e265b38271cad22b4d742e0328.tar.bz2
gentoo-2-d0bab1aa07c7f3e265b38271cad22b4d742e0328.zip
cosmetic change.
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/qdbm/qdbm-1.8.74.ebuild29
1 files changed, 23 insertions, 6 deletions
diff --git a/dev-db/qdbm/qdbm-1.8.74.ebuild b/dev-db/qdbm/qdbm-1.8.74.ebuild
index 7ac15694ce14..fad6f8679a1b 100644
--- a/dev-db/qdbm/qdbm-1.8.74.ebuild
+++ b/dev-db/qdbm/qdbm-1.8.74.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/qdbm/qdbm-1.8.74.ebuild,v 1.3 2007/03/11 16:08:12 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/qdbm/qdbm-1.8.74.ebuild,v 1.4 2007/03/11 16:15:47 hattya Exp $
inherit eutils java-pkg-opt-2 multilib
+IUSE="debug java perl ruby zlib"
+
DESCRIPTION="Quick Database Manager"
HOMEPAGE="http://qdbm.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
-SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc x86"
-IUSE="debug java perl ruby zlib"
+SLOT="0"
RDEPEND="java? ( >=virtual/jre-1.4 )
perl? ( dev-lang/perl )
@@ -21,14 +22,17 @@ DEPEND="${RDEPEND}
java? ( >=virtual/jdk-1.4 )"
src_unpack() {
+
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-runpath.diff
epatch "${FILESDIR}"/${PN}-perl-runpath-vendor.diff
+
}
src_compile() {
+
econf \
$(use_enable debug) \
$(use_enable zlib) \
@@ -38,30 +42,40 @@ src_compile() {
emake || die
local u
+
for u in java perl ruby; do
- use ${u} || continue
+ if ! use ${u}; then
+ continue
+ fi
cd ${u}
econf || die
emake || die
cd -
done
+
}
src_test() {
+
emake -j1 check || die
local u
+
for u in java perl ruby; do
- use ${u} || continue
+ if ! use ${u}; then
+ continue
+ fi
cd ${u}
emake -j1 check || die
cd -
done
+
}
src_install() {
+
emake DESTDIR="${D}" install || die
dodoc ChangeLog NEWS README THANKS
@@ -72,7 +86,9 @@ src_install() {
local u mydatadir=/usr/share/doc/${P}/html
for u in java perl ruby; do
- use ${u} || continue
+ if ! use ${u}; then
+ continue
+ fi
cd ${u}
emake DESTDIR="${D}" MYDATADIR=${mydatadir}/${u} install || die
@@ -90,4 +106,5 @@ src_install() {
done
rm -f "${D}"/usr/bin/*test
+
}