summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-03-23 06:46:48 +0000
committerPeter Volkov <pva@gentoo.org>2009-03-23 06:46:48 +0000
commitfdba7f04758a8430f3744a1212e3bc83edd6003d (patch)
tree1d773a2a271b5fb9541ef077d73d16d6f858faf1 /dev-db
parentVersion bump thanks to Lars (Polynomial-C) (bug #263442). (diff)
downloadgentoo-2-fdba7f04758a8430f3744a1212e3bc83edd6003d.tar.gz
gentoo-2-fdba7f04758a8430f3744a1212e3bc83edd6003d.tar.bz2
gentoo-2-fdba7f04758a8430f3744a1212e3bc83edd6003d.zip
Version bump.
(Portage version: 2.2_rc26/cvs/Linux i686)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/gigabase/ChangeLog7
-rw-r--r--dev-db/gigabase/gigabase-3.69.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-db/gigabase/ChangeLog b/dev-db/gigabase/ChangeLog
index c359ce7f74a9..af2930f73423 100644
--- a/dev-db/gigabase/ChangeLog
+++ b/dev-db/gigabase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/gigabase
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/ChangeLog,v 1.41 2009/01/22 08:21:40 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/ChangeLog,v 1.42 2009/03/23 06:46:48 pva Exp $
+
+*gigabase-3.69 (23 Mar 2009)
+
+ 23 Mar 2009; Peter Volkov <pva@gentoo.org> +gigabase-3.69.ebuild:
+ Version bump.
*gigabase-3.68 (22 Jan 2009)
diff --git a/dev-db/gigabase/gigabase-3.69.ebuild b/dev-db/gigabase/gigabase-3.69.ebuild
new file mode 100644
index 000000000000..d99002e9dbca
--- /dev/null
+++ b/dev-db/gigabase/gigabase-3.69.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/gigabase/gigabase-3.69.ebuild,v 1.1 2009/03/23 06:46:48 pva Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="OO-DBMS with interfaces for C/C++/Java/PHP/Perl"
+HOMEPAGE="http://www.garret.ru/~knizhnik/gigabase.html"
+SRC_URI="mirror://sourceforge/gigabase/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~s390 ~x86"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/gigabase
+
+src_compile() {
+ mf="${S}/Makefile"
+
+ econf
+ sed -r -i -e 's/subsql([^\.]|$)/subsql-gdb\1/' ${mf}
+ emake || die "compilation failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+
+ dodoc CHANGES
+ use doc && dohtml GigaBASE.htm
+ use doc && dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ elog "The subsql binary has been renamed to subsql-gdb,"
+ elog "to avoid a name clash with the FastDB version of subsql"
+}