summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2010-10-15 07:44:06 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2010-10-15 07:44:06 +0000
commit0ca7d9b05a2a4e7f4325bc009f867e6eb23adc83 (patch)
tree329ac52190bdfec8ecae59e1ce71103149ddc3cc /dev-dotnet/google-gdata-sharp
parentremoved jsr305 since it is no longer a live ebuild (diff)
downloadgentoo-2-0ca7d9b05a2a4e7f4325bc009f867e6eb23adc83.tar.gz
gentoo-2-0ca7d9b05a2a4e7f4325bc009f867e6eb23adc83.tar.bz2
gentoo-2-0ca7d9b05a2a4e7f4325bc009f867e6eb23adc83.zip
Pass arguments to emake instead of setting MAKEOPTS. Drop base.eclass while we're at it.
(Portage version: 2.2_rc91/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet/google-gdata-sharp')
-rw-r--r--dev-dotnet/google-gdata-sharp/ChangeLog9
-rw-r--r--dev-dotnet/google-gdata-sharp/google-gdata-sharp-1.4.0.2-r1.ebuild35
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-dotnet/google-gdata-sharp/ChangeLog b/dev-dotnet/google-gdata-sharp/ChangeLog
index 7bfc314f11a0..5b00fb8f215f 100644
--- a/dev-dotnet/google-gdata-sharp/ChangeLog
+++ b/dev-dotnet/google-gdata-sharp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-dotnet/google-gdata-sharp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/google-gdata-sharp/ChangeLog,v 1.4 2010/07/12 17:49:04 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/google-gdata-sharp/ChangeLog,v 1.5 2010/10/15 07:44:06 ford_prefect Exp $
+
+*google-gdata-sharp-1.4.0.2-r1 (15 Oct 2010)
+
+ 15 Oct 2010; Arun Raghavan <ford_prefect@gentoo.org>
+ +google-gdata-sharp-1.4.0.2-r1.ebuild:
+ Pass arguments to emake instead of setting MAKEOPTS. Drop base.eclass
+ while we're at it.
12 Jul 2010; Christian Faulhammer <fauli@gentoo.org>
google-gdata-sharp-1.4.0.2.ebuild:
diff --git a/dev-dotnet/google-gdata-sharp/google-gdata-sharp-1.4.0.2-r1.ebuild b/dev-dotnet/google-gdata-sharp/google-gdata-sharp-1.4.0.2-r1.ebuild
new file mode 100644
index 000000000000..e931a9815c50
--- /dev/null
+++ b/dev-dotnet/google-gdata-sharp/google-gdata-sharp-1.4.0.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/google-gdata-sharp/google-gdata-sharp-1.4.0.2-r1.ebuild,v 1.1 2010/10/15 07:44:06 ford_prefect Exp $
+
+EAPI=3
+
+inherit mono
+
+MY_PN="libgoogle-data-mono"
+
+DESCRIPTION="C# bindings for the Google GData API"
+HOMEPAGE="http://code.google.com/p/google-gdata/"
+SRC_URI="http://google-gdata.googlecode.com/files/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# tests are completely broken (bug #310101), revisit in future bumps.
+RESTRICT="test"
+
+DEPEND=">=dev-lang/mono-2.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/pkgconfig-typo-fix.patch
+}
+
+src_install() {
+ # The Makefile has prefix=/usr/local by default :|
+ emake PREFIX=/usr || die "compilation failed"
+}