summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-02 20:46:18 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-02 20:46:18 +0000
commit634da4b7ba82eb8252ac7791a3d402429a9f01c0 (patch)
tree547901143a48813a45b971f6019975b07b39e955 /dev-dotnet/mono
parentFix metadata.xml.. (Manifest recommit) (diff)
downloadgentoo-2-634da4b7ba82eb8252ac7791a3d402429a9f01c0.tar.gz
gentoo-2-634da4b7ba82eb8252ac7791a3d402429a9f01c0.tar.bz2
gentoo-2-634da4b7ba82eb8252ac7791a3d402429a9f01c0.zip
Fix use invocation
Diffstat (limited to 'dev-dotnet/mono')
-rw-r--r--dev-dotnet/mono/ChangeLog6
-rw-r--r--dev-dotnet/mono/mono-0.31.ebuild4
-rw-r--r--dev-dotnet/mono/mono-0.91.ebuild4
-rw-r--r--dev-dotnet/mono/mono-0.95.ebuild4
4 files changed, 11 insertions, 7 deletions
diff --git a/dev-dotnet/mono/ChangeLog b/dev-dotnet/mono/ChangeLog
index 58ddf981eb78..14e69d8dca80 100644
--- a/dev-dotnet/mono/ChangeLog
+++ b/dev-dotnet/mono/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-dotnet/mono
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/ChangeLog,v 1.16 2004/06/02 20:06:38 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/ChangeLog,v 1.17 2004/06/02 20:45:30 agriffis Exp $
+
+ 02 Jun 2004; Aron Griffis <agriffis@gentoo.org> mono-0.31.ebuild,
+ mono-0.91.ebuild, mono-0.95.ebuild:
+ Fix use invocation
02 Jun 2004; David Holm <dholm@gentoo.org> mono-0.95.ebuild:
Added to ~ppc.
diff --git a/dev-dotnet/mono/mono-0.31.ebuild b/dev-dotnet/mono/mono-0.31.ebuild
index 1455716d736e..99fc97c04bcc 100644
--- a/dev-dotnet/mono/mono-0.31.ebuild
+++ b/dev-dotnet/mono/mono-0.31.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/mono-0.31.ebuild,v 1.3 2004/03/30 04:59:17 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/mono-0.31.ebuild,v 1.4 2004/06/02 20:45:30 agriffis Exp $
inherit eutils mono flag-o-matic
@@ -45,7 +45,7 @@ src_unpack() {
src_compile() {
local myconf=""
- if [ -n "`use nptl`" ] && have_NPTL
+ if use nptl && have_NPTL
then
myconf="${myconf} --with-nptl=yes"
else
diff --git a/dev-dotnet/mono/mono-0.91.ebuild b/dev-dotnet/mono/mono-0.91.ebuild
index ecd67c926fce..d2419b0d8dc1 100644
--- a/dev-dotnet/mono/mono-0.91.ebuild
+++ b/dev-dotnet/mono/mono-0.91.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/mono-0.91.ebuild,v 1.3 2004/05/10 20:58:07 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/mono-0.91.ebuild,v 1.4 2004/06/02 20:45:30 agriffis Exp $
inherit eutils mono flag-o-matic
@@ -30,7 +30,7 @@ RDEPEND="${DEPEND}
src_compile() {
local myconf=""
- if [ -n "`use nptl`" ] && have_NPTL
+ if use nptl && have_NPTL
then
myconf="${myconf} --with-nptl=yes"
else
diff --git a/dev-dotnet/mono/mono-0.95.ebuild b/dev-dotnet/mono/mono-0.95.ebuild
index d0b4fb054bca..2f40ebdedf35 100644
--- a/dev-dotnet/mono/mono-0.95.ebuild
+++ b/dev-dotnet/mono/mono-0.95.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/mono-0.95.ebuild,v 1.2 2004/06/02 20:06:38 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono/mono-0.95.ebuild,v 1.3 2004/06/02 20:45:30 agriffis Exp $
inherit eutils mono flag-o-matic
@@ -27,7 +27,7 @@ RDEPEND="${DEPEND}
src_compile() {
local myconf=""
- if [ -n "`use nptl`" ] && have_NPTL
+ if use nptl && have_NPTL
then
myconf="${myconf} --with-nptl=yes"
else