summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-04-05 12:39:46 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-04-05 12:39:46 +0000
commit5d68088712cb7e88297b7cf0ed93fa567a652d66 (patch)
tree1f73e7f6cbc6c5de8dfc43ab791771c6d297661d /dev-dotnet/monotorrent
parentStable on alpha, bug #264173 (diff)
downloadgentoo-2-5d68088712cb7e88297b7cf0ed93fa567a652d66.tar.gz
gentoo-2-5d68088712cb7e88297b7cf0ed93fa567a652d66.tar.bz2
gentoo-2-5d68088712cb7e88297b7cf0ed93fa567a652d66.zip
Initial commit, ebuild by me.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet/monotorrent')
-rw-r--r--dev-dotnet/monotorrent/ChangeLog10
-rw-r--r--dev-dotnet/monotorrent/files/mono.snkbin0 -> 596 bytes
-rw-r--r--dev-dotnet/monotorrent/files/monotorrent.pc.in8
-rw-r--r--dev-dotnet/monotorrent/metadata.xml5
-rw-r--r--dev-dotnet/monotorrent/monotorrent-0.70.ebuild48
5 files changed, 71 insertions, 0 deletions
diff --git a/dev-dotnet/monotorrent/ChangeLog b/dev-dotnet/monotorrent/ChangeLog
new file mode 100644
index 000000000000..197a23b4cf9d
--- /dev/null
+++ b/dev-dotnet/monotorrent/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-dotnet/monotorrent
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monotorrent/ChangeLog,v 1.1 2009/04/05 12:39:45 loki_val Exp $
+
+*monotorrent-0.70 (05 Apr 2009)
+
+ 05 Apr 2009; Peter Alfredsen <loki_val@gentoo.org> +files/mono.snk,
+ +files/monotorrent.pc.in, +metadata.xml, +monotorrent-0.70.ebuild:
+ Initial commit, ebuild by me.
+
diff --git a/dev-dotnet/monotorrent/files/mono.snk b/dev-dotnet/monotorrent/files/mono.snk
new file mode 100644
index 000000000000..380116c18fc3
--- /dev/null
+++ b/dev-dotnet/monotorrent/files/mono.snk
Binary files differ
diff --git a/dev-dotnet/monotorrent/files/monotorrent.pc.in b/dev-dotnet/monotorrent/files/monotorrent.pc.in
new file mode 100644
index 000000000000..33d48a810842
--- /dev/null
+++ b/dev-dotnet/monotorrent/files/monotorrent.pc.in
@@ -0,0 +1,8 @@
+prefix=${pcfiledir}/../..
+exec_prefix=${prefix}
+libdir=${exec_prefix}/@LIBDIR@
+
+Name: @PACKAGENAME@
+Description: @DESCRIPTION@
+Version: @VERSION@
+Libs: @LIBS@
diff --git a/dev-dotnet/monotorrent/metadata.xml b/dev-dotnet/monotorrent/metadata.xml
new file mode 100644
index 000000000000..e01adbb307db
--- /dev/null
+++ b/dev-dotnet/monotorrent/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+</pkgmetadata>
diff --git a/dev-dotnet/monotorrent/monotorrent-0.70.ebuild b/dev-dotnet/monotorrent/monotorrent-0.70.ebuild
new file mode 100644
index 000000000000..8405f903074b
--- /dev/null
+++ b/dev-dotnet/monotorrent/monotorrent-0.70.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monotorrent/monotorrent-0.70.ebuild,v 1.1 2009/04/05 12:39:45 loki_val Exp $
+
+EAPI=2
+
+inherit mono multilib
+
+DESCRIPTION="Monotorrent is an open source C# bittorrent library"
+HOMEPAGE="http://www.monotorrent.com/"
+SRC_URI="http://monotorrent.com/Files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND=">=dev-lang/mono-2.0.1"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.23"
+
+# The hack we do to get the dll installed in the GAC makes the unit-tests
+# defunct.
+RESTRICT="test"
+
+src_prepare() {
+ sed -i \
+ -e "/InternalsVisibleTo/d" \
+ MonoTorrent/AssemblyInfo.cs* || die
+}
+
+src_compile() {
+ emake -j1 ASSEMBLY_COMPILER_COMMAND="/usr/bin/gmcs -keyfile:${FILESDIR}/mono.snk"
+}
+
+src_install() {
+ egacinstall $(find . -name "MonoTorrent.dll")
+ dodir /usr/$(get_libdir)/pkgconfig
+ ebegin "Installing .pc file"
+ sed \
+ -e "s:@LIBDIR@:$(get_libdir):" \
+ -e "s:@PACKAGENAME@:${PN}:" \
+ -e "s:@DESCRIPTION@:${DESCRIPTION}:" \
+ -e "s:@VERSION@:${PV}:" \
+ -e 's;@LIBS@;-r:${libdir}/mono/monotorrent/MonoTorrent.dll;' \
+ "${FILESDIR}"/${PN}.pc.in > "${D}"/usr/$(get_libdir)/pkgconfig/${PN}.pc
+ PKG_CONFIG_PATH="${D}/usr/$(get_libdir)/pkgconfig/" pkg-config --exists monotorrent || die ".pc file failed to validate."
+ eend $?
+}