summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-04-27 09:01:42 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-04-27 09:01:42 +0000
commit82f9d976a43d0359378f94e4d1abaf8a74a4f81d (patch)
tree1ff198e4c1a2a1c71a1a051414ad457cbc41f2c2 /dev-dotnet/monotorrent
parentBump (diff)
downloadgentoo-2-82f9d976a43d0359378f94e4d1abaf8a74a4f81d.tar.gz
gentoo-2-82f9d976a43d0359378f94e4d1abaf8a74a4f81d.tar.bz2
gentoo-2-82f9d976a43d0359378f94e4d1abaf8a74a4f81d.zip
Bump
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet/monotorrent')
-rw-r--r--dev-dotnet/monotorrent/ChangeLog8
-rw-r--r--dev-dotnet/monotorrent/monotorrent-0.72.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-dotnet/monotorrent/ChangeLog b/dev-dotnet/monotorrent/ChangeLog
index 197a23b4cf9d..60af669b9511 100644
--- a/dev-dotnet/monotorrent/ChangeLog
+++ b/dev-dotnet/monotorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-dotnet/monotorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monotorrent/ChangeLog,v 1.1 2009/04/05 12:39:45 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monotorrent/ChangeLog,v 1.2 2009/04/27 09:01:42 loki_val Exp $
+
+*monotorrent-0.72 (27 Apr 2009)
+
+ 27 Apr 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +monotorrent-0.72.ebuild:
+ Bump
*monotorrent-0.70 (05 Apr 2009)
diff --git a/dev-dotnet/monotorrent/monotorrent-0.72.ebuild b/dev-dotnet/monotorrent/monotorrent-0.72.ebuild
new file mode 100644
index 000000000000..ecd4767dae6f
--- /dev/null
+++ b/dev-dotnet/monotorrent/monotorrent-0.72.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/monotorrent/monotorrent-0.72.ebuild,v 1.1 2009/04/27 09:01:42 loki_val Exp $
+
+EAPI=2
+
+inherit mono multilib
+
+DESCRIPTION="Monotorrent is an open source C# bittorrent library"
+HOMEPAGE="http://www.monotorrent.com/"
+SRC_URI="http://projects.qnetp.net/attachments/download/13/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND=">=dev-lang/mono-2.0.1"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.23"
+
+# The hack we do to get the dll installed in the GAC makes the unit-tests
+# defunct.
+RESTRICT="test"
+
+src_prepare() {
+ sed -i \
+ -e "/InternalsVisibleTo/d" \
+ MonoTorrent/AssemblyInfo.cs* || die
+}
+
+src_compile() {
+ emake -j1 ASSEMBLY_COMPILER_COMMAND="/usr/bin/gmcs -keyfile:${FILESDIR}/mono.snk"
+}
+
+src_install() {
+ egacinstall $(find . -name "MonoTorrent.dll")
+ dodir /usr/$(get_libdir)/pkgconfig
+ ebegin "Installing .pc file"
+ sed \
+ -e "s:@LIBDIR@:$(get_libdir):" \
+ -e "s:@PACKAGENAME@:${PN}:" \
+ -e "s:@DESCRIPTION@:${DESCRIPTION}:" \
+ -e "s:@VERSION@:${PV}:" \
+ -e 's;@LIBS@;-r:${libdir}/mono/monotorrent/MonoTorrent.dll;' \
+ "${FILESDIR}"/${PN}.pc.in > "${D}"/usr/$(get_libdir)/pkgconfig/${PN}.pc
+ PKG_CONFIG_PATH="${D}/usr/$(get_libdir)/pkgconfig/" pkg-config --exists monotorrent || die ".pc file failed to validate."
+ eend $?
+}